Results 1 to 4 of 4

Thread: NVidia CUDA driver woes

  1. #1

    Default NVidia CUDA driver woes

    I'm still struggling to get the CUDA server running against my old video card GT 610 in 42.3.
    Each time I try a new idea from the mulitple threads on this issue I end up with no graphic login.
    For example removing the existing GT04 set will work, but gives me the black screen on reboot.
    Rollback to a previous snapshot is consistently reliable so I can always get back to a working boot.

    The new thing that is a puzzle is that I realize that my loaded GT04 set (default on installation)
    is too advanced for my old card but when I use Yast to replace the GT04 set with a more appropriate GT 02
    the only thing Yast will allow me to do is replace the 04 with BOTH 02 AND 03.
    This results in a message during the installation process that "file conflicts detected"
    as Yast tries to deal with 02 and 03 at the same time.
    Any attempt to allow Yast to auto add packages and then subsequently remove them are not successful.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: NVidia CUDA driver woes

    If 04 does not work try 03 with that card not 02. Try black listing both 04 and 02 after full removal

  3. #3

    Default Re: NVidia CUDA driver woes

    Quote Originally Posted by gogalthorp View Post
    If 04 does not work try 03 with that card not 02. Try black listing both 04 and 02 after full removal
    I tried 03 and it led to black screen login as well.
    What I have managed to do is to go from G04 to G03, and then in the same yast session go from G03 to G02.
    After this I am able to boot normally, still in Yast G02 set of programmes.

    Now from root I can get a result from nvidia-smi which contains a lot of N/A results.
    nvidia-smi does not work from regular user.
    After make of samples, the result of the deviceQuery test is:

    HTML Code:
    ~/cuda> ./NVIDIA_CUDA-8.0_Samples/bin/x86_64/linux/release/deviceQuery
    ./NVIDIA_CUDA-8.0_Samples/bin/x86_64/linux/release/deviceQuery Starting...
    
     CUDA Device Query (Runtime API) version (CUDART static linking)
    
    cudaGetDeviceCount returned 35
    -> CUDA driver version is insufficient for CUDA runtime version
    Result = FAIL
    So I think I am making progress, but there is a disconnect in versions somewhere.

  4. #4

    Default Re: NVidia CUDA driver woes

    Attempting to back down from CUDA 8 to CUDA 7 (lowest available in Yast)
    results in Yast trying to bring me back to G03 which is wrong.
    So there may not be a Yast solution to this problem, unless I can find a CUDA set which will comply with my G02 installed.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •