Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: Bridging is broken on virt-manager

  1. #1

    Default Bridging is broken on virt-manager

    From my previous thread:
    https://forums.opensuse.org/showthre...27#post2834727

    So as I mentioned, a network bridge should have been created back when installing kvm through Yast, but virt-manager doesn't recognize it!
    You can see in my post what options I am given, but the real problem here is, I'm missing this option
    "Bridge br0: host device eth0"
    Instead given a grayed out message "no virtual networks available"!!
    In command line I type "ip addr" and effectively only the 3 usual interfaces: lo, eth0 and wlan0. No br0 at all!!

    W T F!? I've been broken ALL the freaking time!! Libvirt has BUG!

    Any help please?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Bridging is broken on virt-manager

    Quote Originally Posted by F_style View Post
    From my previous thread:
    https://forums.opensuse.org/showthre...27#post2834727

    So as I mentioned, a network bridge should have been created back when installing kvm through Yast, but virt-manager doesn't recognize it!
    You can see in my post what options I am given, but the real problem here is, I'm missing this option
    "Bridge br0: host device eth0"
    Instead given a grayed out message "no virtual networks available"!!
    In command line I type "ip addr" and effectively only the 3 usual interfaces: lo, eth0 and wlan0. No br0 at all!!

    W T F!? I've been broken ALL the freaking time!! Libvirt has BUG!

    Any help please?
    Hi
    Not really, you need to go into YaST Network Settings and create the bridge device, then attach to the ethernet interface. Once that's done it will be available in virt-manager.

    Or create via brctl from the command line...
    Code:
    brctl addbr br0
    brctl addif br0 eth0
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Bridging is broken on virt-manager

    @malcolmlewis:
    I cannot understand it... Why does one still have to manually create the bridge? Wasn't it supposed to be created *precisely by Yast* the moment KVM server was installed? I installed KVM through Yast following the opensuse guide, and after downloading and installing the packages it asked to install a bridge device, for which I answered "yes".

    (And as a very very brief offtopic, do you happen to know something about the SPICE thing? See my other thread...)

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Bridging is broken on virt-manager

    Better to create your bridge devices using vm manager.
    When creating a bridge device using vm manager, your devices will be named something like "virbr0" instead of "br0"
    The reason why it's best to use libvirt (vm manager) to create these devices is that you can configure many more options within the device.

    However,
    No matter how you create your device (eg during virtualization install, YaST,, command line, some other virtualization app, etc) the device should be available for your Guests.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5

    Default Re: Bridging is broken on virt-manager

    Quote Originally Posted by F_style View Post
    So as I mentioned, a network bridge should have been created back when installing kvm through Yast, but virt-manager doesn't recognize it!
    You can see in my post what options I am given, but the real problem here is, I'm missing this option
    "Bridge br0: host device eth0"
    Instead given a grayed out message "no virtual networks available"!!
    In command line I type "ip addr" and effectively only the 3 usual interfaces: lo, eth0 and wlan0. No br0 at all!!
    So no one really can help with this issue? Am I really alone in it? Know this is extremly frustrating!

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Bridging is broken on virt-manager

    On Sun 20 Aug 2017 04:56:01 PM CDT, F style wrote:

    F_style;2834878 Wrote:
    > So as I mentioned, a network bridge should have been created back when
    > installing kvm through Yast, but virt-manager doesn't recognize it!
    > You can see in my post what options I am given, but the real problem
    > here is, I'm missing this option
    > "Bridge br0: host device eth0"
    > Instead given a grayed out message "no virtual networks available"!!
    > In command line I type "ip addr" and effectively only the 3 usual
    > interfaces: lo, eth0 and wlan0. No br0 at all!!

    So no one really can help with this issue? Am I really alone in it? Know
    this is extremly frustrating!


    Hi
    I can setup a test machine tomorrow with three ethernet ports and wifi
    (for management). But I have always just installed libvirt/qemu and
    created the bridges manually since I never install/run a desktop on this
    type of machine.... then I just connect from a remote machine with
    virt-manager or ssh and virsh...

    The question I guess is was the ethernet port in use when you created
    stuff?

    I would suspect you need to go into YaST network settings and
    unconfigure the ethernet port (as in just delete it) and it will show
    as unconfigured. Then In virt-manager see if you can create a virbr0
    interface.

    Else just create a br0 via YaST or command line.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.79-18.26-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7

    Default Re: Bridging is broken on virt-manager

    @malcolmlewis:

    Thanks very much sir. It would greately help me if you could do that. Though that doesn't mean I'll stop searching on my own neither.

    In this laptop I only have 2 physical interfaces, eth0 and wifi0. When doing the create virtual machine stuff yes, eth0 is in use, while wifi0 is not. Also, I have only attempted the pure virtual machine creation "wizard"; I have never actually finished the process by hitting "create machine", only hitting "cancel installation".

    So the reason this is getting complicated to diagnose is, I'm most likely the first dumb to attempt whole KVM and guest installations through Yast, while everyone else do at least the bridge creation manually through command line or not accepting Yast offering when installing KVM server...

    I guess I could certainly manually create the bridge device, but what's greately grinding my nerves now is the fact Yast's automatic bridge creation during KVM server installation is seemingly not working.
    Maybe the vhost-net mistake I did has to do? https://forums.opensuse.org/showthre...06#post2833906

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Bridging is broken on virt-manager

    On Sun 20 Aug 2017 06:56:02 PM CDT, F style wrote:

    @malcolmlewis:

    Thanks very much sir. It would greately help me if you could do that.
    Though that doesn't mean I'll stop searching on my own neither.

    In this laptop I only have 2 physical interfaces, eth0 and wifi0. When
    doing the create virtual machine stuff yes, eth0 is in use, while wifi0
    is not. Also, I have only attempted the pure virtual machine creation
    "wizard"; I have never actually finished the process by hitting "create
    machine", only hitting "cancel installation".

    So the reason this is getting complicated to diagnose is, I'm most
    likely the first dumb to attempt whole KVM and guest installations
    through Yast, while everyone else do at least the bridge creation
    manually through command line or not accepting Yast offering when
    installing KVM server...

    I guess I could certainly manually create the bridge device, but what's
    greately grinding my nerves now is the fact Yast's automatic bridge
    creation during KVM server installation is seemingly not working.
    Maybe the vhost-net mistake I did has to do? http://tinyurl.com/yaqrmwyp


    Hi
    Ok, so you need to use wireless for the machine (host running kvm), the
    enterent port must be free to use as a bridge, else if you only want to
    use the ethernet port for your machine then the VM's must use NAT.

    Bridging won't work over wireless only ethernet....

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.79-18.26-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  9. #9

    Default Re: Bridging is broken on virt-manager

    Wait WHAT?
    I didn't read anywhere else around internet nor I was told by anyone that in order to create a bridge for a KVM virtual guest one had to have the desired network device to share "free"! Is this the reason Yast's bridge creation is not working?
    And what does it mean? Is it enough to just unplug ethernet cable, or one must disable the device with ip command?

    From what I have read around internet *all day along*, a bridged setting should be the more complete and flexible one for KVM guests! Once set up, it should allow everything in communication at same time: virtual guest to host, virtual guest to other physical PCs in physical LAN, virtual guest to other virtual guests either in host itself and other hosts, internet access. Which implies host's "shared" network device should still be functional for host itself!
    NAT on the other hand, from what I read, only provides internet access and to other outer networks, but no guest to host communication.

    W T H?

  10. #10
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,336
    Blog Entries
    15

    Default Re: Bridging is broken on virt-manager

    Quote Originally Posted by F_style View Post
    Wait WHAT?
    I didn't read anywhere else around internet nor I was told by anyone that in order to create a bridge for a KVM virtual guest one had to have the desired network device to share "free"! Is this the reason Yast's bridge creation is not working?
    And what does it mean? Is it enough to just unplug ethernet cable, or one must disable the device with ip command?

    From what I have read around internet *all day along*, a bridged setting should be the more complete and flexible one for KVM guests! Once set up, it should allow everything in communication at same time: virtual guest to host, virtual guest to other physical PCs in physical LAN, virtual guest to other virtual guests either in host itself and other hosts, internet access. Which implies host's "shared" network device should still be functional for host itself!
    NAT on the other hand, from what I read, only provides internet access and to other outer networks, but no guest to host communication.

    W T H?
    Hi
    A bridge device needs to be free, not configured, no ip address etc.

    Have a read here (See Solution 1 to the right for SUSE);
    https://www.linux-kvm.org/page/Networking

    I see they say to use ip link now instead of brctl...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •