Results 1 to 3 of 3

Thread: Install on MacPro 6,1

  1. #1

    Default Install on MacPro 6,1

    Hello OpenSuse Community,

    I have decided to give Tumbleweed a try on a 2013 MacPro 6,1 aka Cylinder Mac Pro I got from my job. I have read many good things about the rolling release methodology. The majority of components on the Mac are working post install, but I did noticed some components have issues or may not be working properly. I have listed what is working and what is not working below. I would appreciate any help in getting some or all not working components below fixed.


    Working
    Thunderbolt 2 /Display ports - I have only used dongles for video so far
    Dual AMD D300 GPU - Mostly Working, except items called out as not working. Card is made for MacPro but is similar to AMD FirePro W7000
    Code:
    02:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X] [1002:6810]
    Code:
    06:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X] [1002:6810]
    Dual Screen - working via DVI and VGA dongles, and also onboard HDMI. Must specify boot loader kernel parameter radeon.modeset=0
    Single screen - DVI, VGA, Onboard HDMI
    Built in speakers
    Ethernet
    USB
    Hibernate - probably need to test more
    Bluetooth

    Not Working
    Wi-Fi - Broadcom BCM4360. I tried the sudo zypper install b43-fwcutter & sudo /usr/sbin/install_bcm43xx_firmware, Packman repository Broadcom-wl, and switching to NetworkManager from Wicked and it did not work
    Headphone jack - jack was illuminated red for some reason when I login into dekstop
    Microphone jack
    Suspend - screen comes back after hitting power button, but system crashes
    Dual VGA Dongles - will not wake up from display sleep

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,775

    Default Re: Install on MacPro 6,1

    Hello and welcome here.

    It is much more efficient to start different threads for your different problems in the best fitting sub-forums. Remember that Wireless gurus will probably check the Wireless forum and maybe not here. Same for the others.

    Also having different subjects in the same thread will often lead to a very confused discussion (what answer belongs to what question, etc).

    Also you can then have the appropriate keywords in your thread title to draw the attention of those who know.

    This is my advice if you want to have the best experience with the openSUSE forums.
    Henk van Velden

  3. #3

    Default Re: Install on MacPro 6,1

    After recent update the system was no longer booting due to issue with AMD driver. Adding the following Kernel parameter fixed the issue for me. This is cause by new functionality in kernel 4.13 per post on Phoronix


    Code:
    radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 showopts

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •