Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

  1. #1

    Default No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    It seems that tumbleweed regularly updated the kernel from 4.11 to 4.12; when I ran zypper dup today, 4.12.7-1.2 packages were installed. I am running tumbleweed on a HP Elitebook 8440p with NVidia graphics, and I am using standard Nouveau drivers.

    During reboot, the screen graphics corrpted and no login screen was recognisable. ctrl-alt-f1...f12 did not work. Neither did ctrl-alt-backspace help. I could not reach any mode where I could use the display.

    I can only reboot by pressing the power button, and have to boot with kernel 4.11 which works fine.

    Any help or ideas? If there are any logs I could provide I need help (which logs ...).

    Thanks!

    Eriol

  2. #2
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    Log in with the working kernel> go to Yast> look for> nvidia> update all installed packages unconditionally.
    And even in the terminal> sudo mkinitrd
    Restart
    Try like this
    loyalty returns to those who practice it

  3. #3

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    Quote Originally Posted by V_idocq View Post
    Log in with the working kernel> go to Yast> look for> nvidia> update all installed packages unconditionally.
    And even in the terminal> sudo mkinitrd
    Restart
    Try like this
    Did both. Actually, re-installing all nvidia and nouveau packages was what I tried first.

    Now I also did a mkinitrd - but it did not work. New kernel still corrupts the GUI/xserver.

    Any other ideas? Can anyone with NVidia graphics confirm it works?

    Cheers

    Eriol

  4. #4

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    I have the same issue on my Dell Inspriron. but I have intel integrated graphics and it is doing the same thing

  5. #5

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    Quote Originally Posted by drtaber2 View Post
    I have the same issue on my Dell Inspriron. but I have intel integrated graphics and it is doing the same thing
    Thanks drtaber2 - so it is probably not related to nouveau as I initially thought. Probably something else.

  6. #6
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    I just updated the new Kernel with Nvidia's Own Driver from File.run and it goes well

    loyalty returns to those who practice it

  7. #7

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    Quote Originally Posted by V_idocq View Post
    I just updated the new Kernel with Nvidia's Own Driver from File.run and it goes well

    I thought of doing this, too. But I am unsure because I read that nvidia's proprietary drivers make problems under tumbleweed. How dod you install the driver - from repos? It seems you have downloaded it from nvidia. But then I wouldn't know how to remove it if it does not work properly ... (helpless ...)

    Using Nouveau with most recent kernels instead of NVidia driver has been one of my main motivations to use tumpleweed instead of Leap ... :-(

    Eriol

  8. #8
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    A matter of habit with the Nvidia.run drivers, putting blacklist nouveau, I never stay with the black monitor, I part with the Vesa drivers after updating the kernel, uninstall reboot and reinstall Nvidia.run, a few minutes and done
    https://en.opensuse.org/SDB:NVIDIA_the_hard_way
    Once you've installed the compilers
    Everything is done with three commands
    loyalty returns to those who practice it

  9. #9

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    For the time being I will wait for a fix before I install nvidia drivers ... I might try kernel 4.12.8 which is already available in factory repos. Did anyone try that one already - does it fix the issue?

    Eriol

  10. #10
    Join Date
    Oct 2009
    Location
    Germany
    Posts
    518

    Default Re: No GUI/Nouveau issues after upgrade to kernel 4.12.7-1.2

    Since beginning of august there is now an official nvidia opensuse repository for opensuse tumbleweed. This should finally end the annoying manual reinstallations of the nvidia driver when using tumbleweed. It is described here: https://lists.opensuse.org/opensuse-.../msg00281.html

    i am using it and it works great, i am totally exalted.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •