Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: GNOME crashing from while to while

  1. #1

    Default GNOME crashing from while to while

    Title.

    From time to time GNOME (or openSUSE itself, not sure...) hangs or crashes, though second one less often. Generally happens when doing any kind of "graphical" activity, such as opening any app, or even just GNOME menu itself, opening Settings, minimizing/maximizing windows, etc.

    If hanging it does for a couple of seconds then returns; if crashing it closes session itself, I have then to log in again, finding all previously opened programs closed.
    Though once already, a session crashing also took with it kernel itself. I had to electrically force shutdown.

  2. #2
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: GNOME crashing from while to while

    Hardware of your computer
    loyalty returns to those who practice it

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,505
    Blog Entries
    3

    Default Re: GNOME crashing from while to while

    Is this possibly bug 1050256?

    If it is, then updates released today are supposed to fix it.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: GNOME crashing from while to while

    Just did a zypper up right now, rebooted, and a brief hang still occurred. Yes, must be the freaking d**n hardware...

  5. #5
    Join Date
    Aug 2017
    Posts
    5

    Default Re: GNOME crashing from while to while

    I have, what it seems to be the same problem as you. I'm also running Gnome and this happens quite often, just as you say during more "graphical" activity. It could happen when viewing maps in Firefox. Or right now as I typed this.

    It freezes, Gnome seems to be "recovering" itself, and sometimes it can "restart" itself a couple of time in a row, and then log out instead, if it fails to recover.

    My computer is quite old. Dell Vostro 1500 with integrated intel graphics (intel 965 gm) and 4 gb of ram. I've never had this problem in any earlier opensuse versions, including 42.2, 42.1, 13, 12 etc etc, with Gnome. And 42.2 and 42.3 runs the same version of Gnome (3.20)? So it's hard to understand what the problem is... I don't think this is a hardware malfunction. I have run zypper dup and it does not help.

    Do you perhaps have Intel 965 as well?

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,677
    Blog Entries
    15

    Default Re: GNOME crashing from while to while

    Quote Originally Posted by aos View Post
    I have, what it seems to be the same problem as you. I'm also running Gnome and this happens quite often, just as you say during more "graphical" activity. It could happen when viewing maps in Firefox. Or right now as I typed this.

    It freezes, Gnome seems to be "recovering" itself, and sometimes it can "restart" itself a couple of time in a row, and then log out instead, if it fails to recover.

    My computer is quite old. Dell Vostro 1500 with integrated intel graphics (intel 965 gm) and 4 gb of ram. I've never had this problem in any earlier opensuse versions, including 42.2, 42.1, 13, 12 etc etc, with Gnome. And 42.2 and 42.3 runs the same version of Gnome (3.20)? So it's hard to understand what the problem is... I don't think this is a hardware malfunction. I have run zypper dup and it does not help.

    Do you perhaps have Intel 965 as well?
    Hi
    Perhaps looking at using uxa instead of sna?
    Code:
    cat /var/log/Xorg.0.log |grep SNA
    You would need to create a /etc/X11/xorg.conf.d/20-intel.conf file with;
    Code:
    Section "Device"
      Identifier  "Intel Graphics"
      Driver      "intel"
      Option      "AccelMethod" "uxa"
    EndSection
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Aug 2017
    Posts
    5

    Smile Re: GNOME crashing from while to while

    Thanks for the advice. I have not tried it yet...

    However, I think that I might have fixed my issue. I've been using an extension for Gnome called Caffeine:
    https://extensions.gnome.org/extension/517/caffeine/
    It's used for disable "auto suspend".

    If you read the user reviews for the extension it's seems to be a lot of people that have issues connected to this extension. So I simply removed that extension and it so far it seems to be working alright, and this issue have no returned even after i tried to make the issue reappear, by opening alot of maps, applications and stuff. So think this might be the solution for my problem.

    F_style, do you have Caffeine? If you do, try to remove it.

  8. #8

    Default Re: GNOME crashing from while to while

    If that "caffeine" thing for Gnome doesn't come shipped by default from DVD install and one must install it, then no, I never installed it.
    Also I never had that coffee icon, so yet another confirmation.

  9. #9
    Join Date
    Aug 2017
    Posts
    5

    Default Re: GNOME crashing from while to while

    Quote Originally Posted by F_style View Post
    If that "caffeine" thing for Gnome doesn't come shipped by default from DVD install and one must install it, then no, I never installed it.
    Also I never had that coffee icon, so yet another confirmation.
    It seems like I was wrong, I was to quick to conclusion... It's not the Caffeine extension like i first thought... I removed it and it seemed fine for some time but then the problem reappeared again.

  10. #10
    Join Date
    Aug 2017
    Posts
    5

    Default Re: GNOME crashing from while to while

    Now i believe i fixed my issue. I hope this will help someone...

    Even the Opensuse 42.3 installer gives this advice during installation if there are problems related to the gpu. The solution is basically to remove drm-kmp-default.
    This will reverse the "graphics stack" from 4.9 to 4.4.

    zypper rm drm-kmp-default
    (then add a lock in zypper (zypper al drm-kmp-default) to keep it from reinstalling)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •