Results 1 to 5 of 5

Thread: New installation does not recognizes other SO

  1. #1
    Join Date
    Jul 2010
    Location
    Spain
    Posts
    43

    Default New installation does not recognizes other SO

    Hello,

    I just bought a few months ago a new computer that comes with Windows 10 and UEFI configured in the BIOS and I'am trying to install openSUSE 42.3 on a different device to have a dual boot.



    When I try to boot from a dvd, to install openSUSE, offers two options: use UEFI or not...



    Now:
    • if I select SATA6G_3: HL-DT-ST DVDRAM GH24N the installation and openSUSE runs great and windows is in the GRUB menu (dual boot) BUT
    • if I select UEFI: HL-DT-ST DVDRAM GH24NSD1 the installation and openSUSE runs great, but windows is not in the GRUB menu. If I check Yast, the Probe foreign OS option is marked in the Boot Loader module...


    So, my question is, does anybody know what can be happen here?


    Thank you.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: New installation does not recognizes other SO

    You probably have two EFI boot partitions one on each drive. Just set the default boot drive to the openSUSE drive and dual boot

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: New installation does not recognizes other SO

    Quote Originally Posted by Viskovitz View Post
    When I try to boot from a dvd, to install openSUSE, offers two options: use UEFI or not...
    Your choice.

    If windows is installed to use UEFI, then you should install openSUSE to also use UEFI.

    If Windows is installed to use legacy booting, then best to install openSUSE to also use legacy booting.
    Now:
    • if I select SATA6G_3: HL-DT-ST DVDRAM GH24N the installation and openSUSE runs great and windows is in the GRUB menu (dual boot) BUT
    • if I select UEFI: HL-DT-ST DVDRAM GH24NSD1 the installation and openSUSE runs great, but windows is not in the GRUB menu. If I check Yast, the Probe foreign OS option is marked in the Boot Loader module...


    So, my question is, does anybody know what can be happen here?
    Then it seems that Windows is using legacy booting. So best to do the same with openSUSE.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4
    Join Date
    Jul 2010
    Location
    Spain
    Posts
    43

    Default Re: New installation does not recognizes other SO

    Hello, thanks for the answers.

    Then I will install openSUSE using legacy.

    Now just a doubt (for the future). Can I suppose Windows is installed using legacy booting? I did not know that is possibly to install Windows in legacy if it is UEFI configured in BIOS.

  5. #5

    Default Re: New installation does not recognizes other SO

    Two years ago I bought a Lenovo desktop with Win 10. I copied the HD to a Samsung 850 SSD using the software that comes with the drive, and verified it works. I then installed a second SSD for Linux installs.

    No matter what Linux I tried - Mint 17.3 and SuSE Tumbleweed, I could not get the computer to boot anything but Win 10. I reinstalled Tumbleweed - UEFI mode and secure boot disabled - with its boot partition on the second SSD - sdb - and reset the computer's BIOS to boot from the second SSD - sdb. That works; the Tumbleweed GRUB splash screen appears when I start the computer.

    As a side note: I cannot start Mint 17.3 unless I run Win 10 first. For some reason the computer's hardware needs Win 10 to "arouse" some of its devices. And yes, I made sure Win 10 completely shuts down i.e. no "quick boot." However, I can boot into a fully functional Tumbleweed without starting Win 10 first. When I multiboot with other Linuces, i like to use SuSE as the boot OS since its GRUB2 provides both a more attractive splash screen as well as ease of configuring the boot order with YAST.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •