Results 1 to 7 of 7

Thread: NVIDIA 384.59 4k default

  1. #1
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    297

    Default NVIDIA 384.59 4k default

    Hi,

    I am running Leap 42.2 on an Alienware laptop with a NVIDIA GTX 1080 and the latest Linux driver, 384.59

    As soon as the driver was installed it sets the resolution to 4k (3840x2160), but a lot of applications (Citrix Receiver I.E.) and games can't handle 4k that well yet so I want to set it to 2k (2560x1440).

    Now in the Gnome settings I only can choose for 4k. The NVIDIA driver has 4k listed as a normal resolution and all others have (scaled) behind it. When I set it to 2560x1440 and I press Apply everything looks normal and this is basically the resolution I want until all applications I use can handle 4k. But this setting doesn't get remembered.

    If you click Quit in the NVIDIA driver settings it says it will save your settings to .nvidia-settings-rc and this is true. But, your resolution is not saved in this file. So basically when ever I log in it's back to 4k.

    There is no xorg.conf but the NVIDIA settings does create a XF86Config file. X doesn't listen to anything you put in here, but you can use whatever the driver puts in it in the xorg files in xorg.conf.d/50-screen.conf and 50-monitor.conf and so on.

    Everything you put in those files are being set by X, except for the resolution settings. These are ignored. My 50-screen.conf looks like this:

    Code:
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "CustomEDID" "/home/ricardo/Desktop/Meuk/AlienWare-R4/AUO109B.bin"
        SubSection     "Display"
            Depth       24
            Modes      "3840x2160_60" "2560x1440" "1920x1080"
        EndSubSection
    EndSection
    What else can I do to force X to go 2k by default?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,353
    Blog Entries
    15

    Default Re: NVIDIA 384.59 4k default

    On Tue 15 Aug 2017 06:56:01 PM CDT, Ricochet wrote:

    Hi,

    I am running Leap 42.2 on an Alienware laptop with a NVIDIA GTX 1080 and
    the latest Linux driver, 384.59

    As soon as the driver was installed it sets the resolution to 4k
    (3840x2160), but a lot of applications (Citrix Receiver I.E.) and games
    can't handle 4k that well yet so I want to set it to 2k (2560x1440).

    Now in the Gnome settings I only can choose for 4k. The NVIDIA driver
    has 4k listed as a normal resolution and all others have (scaled) behind
    it. When I set it to 2560x1440 and I press Apply everything looks normal
    and this is basically the resolution I want until all applications I use
    can handle 4k. But this setting doesn't get remembered.

    If you click Quit in the NVIDIA driver settings it says it will save
    your settings to .nvidia-settings-rc and this is true. But, your
    resolution is not saved in this file. So basically when ever I log in
    it's back to 4k.

    There is no xorg.conf but the NVIDIA settings does create a XF86Config
    file. X doesn't listen to anything you put in here, but you can use
    whatever the driver puts in it in the xorg files in
    xorg.conf.d/50-screen.conf and 50-monitor.conf and so on.

    Everything you put in those files are being set by X, except for the
    resolution settings. These are ignored. My 50-screen.conf looks like
    this:


    Code:
    --------------------
    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "CustomEDID"
    "/home/ricardo/Desktop/Meuk/AlienWare-R4/AUO109B.bin" SubSection
    "Display" Depth 24
    Modes "3840x2160_60" "2560x1440" "1920x1080"
    EndSubSection
    EndSection
    --------------------


    What else can I do to force X to go 2k by default?


    Hi
    The resolution settings are controlled via monitors.xml file down in
    ~/.config so check this file for the preferred width and height is
    being set.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.74-18.20-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    297

    Default Re: NVIDIA 384.59 4k default

    Thanks for your reply.

    I edited the file to reflect the resolution I want, but nothing changes. I did a reboot to be sure, the file remains untouched and the resolution is still on 4k.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,353
    Blog Entries
    15

    Default Re: NVIDIA 384.59 4k default

    Quote Originally Posted by Ricochet View Post
    Thanks for your reply.

    I edited the file to reflect the resolution I want, but nothing changes. I did a reboot to be sure, the file remains untouched and the resolution is still on 4k.
    Hi
    Remove the file and login/logout and/or reboot the go into the GNOME System Settings Display and set the resolution and check the file changes.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    297

    Default Re: NVIDIA 384.59 4k default

    I removed the .config/monitors.xml file and logged out and back in. The resolution still was 4k, the Gnome system settings Display still only showed 3840x2160 and no new monitors.xml was created.

  6. #6
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    297

    Default Re: NVIDIA 384.59 4k default

    https://ibb.co/jjsBUv

    Look at the hover text. I think Gnome doesn't know there are more resolutions other then 4k. According to the NVIDIA settings, 4k is the only resolution that is not scaled.

  7. #7
    Join Date
    Jun 2008
    Location
    The Netherlands
    Posts
    297

    Default Re: NVIDIA 384.59 4k default

    I booted to windows I have on an USB drive. It also has 1 resolution, and as for scaled resolutions even less than Linux.

    The difference is that on windows all applications seem to listen to the windows scaling settings. Windows puts that on 200% where 1k is 100%

    Now in the Tweak panel in Gnome you can set scalling on 2 (the NVIDIA driver does this for you) but a lot of applications on Linux do not listen to it. This makes 4k pretty much suck in Gnome. I'll just have to wait for applications to update and respect the Gnome scaling settings I guess...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •