Results 1 to 2 of 2

Thread: Zypper / Yast not refreshing the repos due to curl error (8) [404 Error] but works fine in browser

  1. #1

    Unhappy Zypper / Yast not refreshing the repos due to curl error (8) [404 Error] but works fine in browser



    The site opens just fine in browser but neither yast nor zypper is able to refresh it. I've tried disabling ipv6 and many other things without any success. I tried editing the address (download.opensuse.org) to ip address and it worked fine for a day. But, then it stopped working all of a sudden. The non-oss one still works though.



    [Opensuse Tumbleweed, KDE Plasma 5].
    ]

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Zypper / Yast not refreshing the repos due to curl error (8) [404 Error] but works fine in brows

    Your repo configuration looks fine.
    Not sure why your update is trying to access a different URL.

    A possible solution is to re-enable and insert your DVD an disable the problem repo since they're equivalent.
    You can do that with the following commands...

    Enable your DVD
    Code:
    zypper mr --enable 1
    Then disable your problem repo
    Code:
    zypper mr --disable 5
    And, if you want to undo the above, of course just re-run the commands substituting "enable" and "disable" for each command

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •