Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

  1. #1

    Default OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    Никак не могу поставить родной драйвер от NVIDIA в Leap 42.3. Вернее ставится то он без проблем, но при загрузке KDE появляется небольшое окошко с текстом в заголовке "Не удалось запустить Plasma" (или что-то похожее, дословно не запомнил). Содержимое в окошке отсутствует.
    С Mesa для nouveau все очень нестабильно, хотелось, как обычно, использовать родные драйвера от NVIDIA.
    Железо конечно не новое - GTX 650 на одном компе и 650Ti на другом. Предыдущие версии OpenSUSE, включая 42.2 работали и работают сейчас вполне себе исправно.
    drm-kmp-default сносил, как и рекомендовано, но результат вот таков.

  2. #2

    Default Re : OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    Поправка - проблема с дровами из репозитория. С дровами непосредственно с сайта NVIDIA вроде все в порядке

  3. #3
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    692

    Default Re: OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    всё ли поставилось?

    rpm -qa|grep nvidia

    модуль подгружается?

    lsmod|grep nvidia

    ошибки в логах х-сервера есть?

    grep EE /var/log/Xorg.0.log

    Плазма может не запускаться если нет OpenGL библиотек.

  4. #4

    Default Re : OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    Извиняюсь за задержку с ответом - не было времени переустановить 42.3. Все, кстати, осталось в том же состоянии, хотя и вышел новый драйвер.
    Вот что имеем:

    1. rpm -qa|grep nvidia
    nvidia-computeG04-384.69-25.1.x86_64
    x11-video-nvidiaG04-384.69-25.1.x86_64
    nvidia-gfxG04-kmp-default-384.69_k4.4.76_1-25.1.x86_64
    nvidia-glG04-384.69-25.1.x86_64


    2. lsmod|grep nvidia
    nvidia_drm 53248 1
    nvidia_modeset 843776 3 nvidia_drm
    nvidia_uvm 724992 0
    nvidia 12996608 67 nvidia_modeset,nvidia_uvm
    drm_kms_helper 155648 1 nvidia_drm
    drm 393216 4 drm_kms_helper,nvidia_drm


    3. grep EE /var/log/Xorg.0.log
    [ 39.429] (EE) Failed to load module "nv" (module does not exist, 0)

  5. #5
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    692

    Default Re: OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    [ 39.429] (EE) Failed to load module "nv" (module does not exist, 0)
    в конфиге иксов указан открытый драйвер, надо поменять nv на nvidia
    это либо в /etc/xorg.conf либо в /etc/X11/xorg.conf.d/50-device.conf

  6. #6

    Default Re : OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    50-device.conf пуст
    Судя по логу, модуль nvidia нормально загружен.
    Судя по всему, такая проблема не только у меня.
    https://forums.opensuse.org/showthread.php/526192-Installing-NVIDIA-drivers

    https://bugzilla.opensuse.org/show_bug.cgi?id=1053934

    https://bugzilla.suse.com/show_bug.cgi?id=1044816

  7. #7
    Join Date
    Jun 2010
    Location
    Кропоткин, Краснодарский край
    Posts
    215

    Default Re: OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    Попробуйте установить 340-й драйвер, у меня только он и работает нормально. (У меня GT640)

  8. #8
    Join Date
    Jan 2011
    Location
    Vladivostok
    Posts
    692

    Default Re: Re : OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    Quote Originally Posted by solandrew View Post
    50-device.conf пуст
    /etc/X11/xorg.conf отстутствует?

    впишите руками в 50-device.conf
    у меня он такой:
    Code:
    # Having multiple "Device" sections is known to be problematic. Make
    # sure you don't have in use another one laying around e.g. in another
    # xorg.conf.d file or even a generic xorg.conf file. More details can
    # be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
    #
    Section "Device"
      Identifier "Default Device"
    #
    Driver "nvidia"
    Option "TripleBuffer" "True"
    #
    #  ## Required magic for radeon/radeonhd drivers; output name
    #  ## (here: "DVI-0") can be figured out via 'xrandr -q'
    #  #Option "monitor-DVI-0" "Default Monitor"
    #
    EndSection

  9. #9
    Join Date
    Aug 2009
    Location
    Russia
    Posts
    2,247

    Default Re: OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    /etc/X11/xorg.conf отстутствует?
    впишите руками в 50-device.conf
    Видимо присутствует, иначе сложно представить, как оно все работает И xorg.conf имеет наивысший приоритет.

    Я вроде создавал начальный xorg.conf с помощью nvidia-xconfig а потом допиливал до приемлемого результата.

  10. #10

    Default Re : Re: OpenSUSE 42.3 Не запускается Plasma при установке драйвера от NVIDIA

    Quote Originally Posted by e_dimas View Post
    Попробуйте установить 340-й драйвер, у меня только он и работает нормально. (У меня GT640)
    В 42.2 и нескольких предыдущих у меня прекрасно работает последний драйвер, устанавливается "простым способом" и никакой ручной "подкрутки" больше и не требуется. Проблема только в 42.3

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •