Results 1 to 7 of 7

Thread: Upgrade from 13.1 to 42.3 .... my experience

  1. #1

    Default Upgrade from 13.1 to 42.3 .... my experience

    I have three computers with 13.1 I have to upgrade to 42.3.
    The first one is a home computer with a very simple configuration and almost no important information.
    The second a home server with some services (nfs, samba, smtp+pop, web) and lvm over software raid 1
    The third one is a department server with several services and software raid10.

    I'm going to test the upgrade on the first system and postpone the decision on how to upgrade the other two systems.
    The system has 4 partitions: windows, swap, / and /home, so even in the worst case scenario I can recover it with a fresh install.
    the other two systems have only standar repos and packman, but this one has some other repos too.

    Code:
    abraracurcix:~ # cat repos.list
    #  | Alias                     | Name                               | Enabled | Refresh | Priority | Type   | URI                                                                       | Service
    ---+---------------------------+------------------------------------+---------+---------+----------+--------+---------------------------------------------------------------------------+--------
     1 | AMD-FGLRX                 | AMD-FGLRX                          | Yes     | Yes     |   99     | rpm-md | http://geeko.ioda.net/mirror/amd-fglrx/openSUSE_13.1/                     |        
     2 | Application:Geo           | Application:Geo                    | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Application:/Geo/openSUSE_13.1/ |        
     3 | graphics                  | graphics                           | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/graphics/openSUSE_13.1/         |        
     4 | libdvdcss                 | libdvdcss                          | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/13.1/                                      |        
     5 | mozilla                   | mozilla                            | Yes     | Yes     |   95     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_13.1/          |        
     6 | openSUSE-13.1-1.10        | openSUSE-13.1-1.10                 | No      | No      |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                  |        
     7 | openSUSE:13.1             | openSUSE:13.1                      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/oss/                  |        
     8 | openSUSE_13.1-1.10_1      | openSUSE 13.1-1.10                 | No      | No      |   99     | yast2  | dvd:///                                                                   |        
     9 | packman                   | packman                            | Yes     | Yes     |   98     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_13.1/             |        
    10 | repo-debug                | openSUSE-13.1-Debug                | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/13.1/repo/oss/            |        
    11 | repo-debug-update         | openSUSE-13.1-Update-Debug         | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/update/13.1/                           |        
    12 | repo-debug-update-non-oss | openSUSE-13.1-Update-Debug-Non-Oss | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/update/13.1-non-oss/                   |        
    13 | repo-non-oss              | openSUSE-13.1-Non-Oss              | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/13.1/repo/non-oss/              |                                                                                                                                                                               
    14 | repo-source               | openSUSE-13.1-Source               | No      | No      |   99     | NONE   | http://download.opensuse.org/source/distribution/13.1/repo/oss/           |                                                                                                                                                                               
    15 | repo-update               | openSUSE-13.1-Update               | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1/                                 |                                                                                                                                                                               
    16 | repo-update-non-oss       | openSUSE-13.1-Update-Non-Oss       | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/update/13.1-non-oss/                         |                                                                                                                                                                               
    abraracurcix:~ #
    As Opensuse SDB recommends offline upgrade, this is the approach I will take. I have burned the Opensuse full DVD of versions 13.2, 42.1, 42.2 and 42.3 and test them in order to be sure they are OK.

    As my first system is in a place with no wideband connection, I have to connect to internet through a 3G stick so I can't afford to use the online repos for every step in the process.

    First of all I have done a zypper ref+zypper up with the 13.1 running version.

    Then I have tried a direct upgrade to 42.3 using the DVD. I Booted with the 42.3 DVD and select upgrade.
    The system did recognize my installed 13.1 system / (ext4) and allow me to continue with the upgrade process. I enabled the internet connection and all went fine until I got a message (I was installing in spanish, so the message is my translation) "The installed product is not compatible with the product in the installation media- If you try to upgrade with the current installation media the system may not boot or some applications may not work correctly" continue/cancel.

    I selected CANCEL and then It showed another message: "Installed product (Opensuse 13.1) is not compatible with the product in the installation media (Opensuse Leap 42.3)".

    So it recognices the system and I could have continued with the upgrade, but it seems it not supported... So, first question, I did well or I should have continued with the upgrade?

    Then I rebooted the system without upgrading and begun again with 13.2 DVD. As it is possible that I have to do the upgrade in several steps and I can't afford so many GB of 3G data, I disabled internet connection and proceeded with the upgrade using exclusively the DVD.
    The process went smoothly, it deleted all the repos and used only the standar repos in the DVD.
    When the process finished it rebooted and I saw that the grub menu did list still "Opensuse 13.1" but the system booted and there was a 13.2 running system. But It was not all working OK. I got a text login. I logged as root and I run startx ....... I got a crash.

    Code:
    ..........
    [    65.903] (II) "glx" will be loaded by default.
    [    65.903] (II) LoadModule: "glx"
    [    65.903] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
    [    65.904] (II) Module glx: vendor="X.Org Foundation"
    [    65.904]    compiled for 1.16.1, module version = 1.0.0
    [    65.904]    ABI class: X.Org Server Extension, version 8.0
    [    65.904] (==) AIGLX enabled
    [    65.904] (II) LoadModule: "fglrx"
    [    65.905] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
    [    65.928] (II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
    [    65.928]    compiled for 1.4.99.906, module version = 15.30.3
    [    65.928]    Module class: X.Org Video Driver
    [    65.928] (II) Loading sub module "fglrxdrm"
    [    65.928] (II) LoadModule: "fglrxdrm"
    [    65.928] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
    [    65.928] (II) Module fglrxdrm: vendor="FireGL - AMD Technologies Inc."
    [    65.928]    compiled for 1.4.99.906, module version = 15.30.3
    [    65.928] (II) AMD Proprietary Linux Driver Version Identifier:15.30.3
    [    65.928] (II) AMD Proprietary Linux Driver Release Identifier: 15.30.1025                           
    [    65.928] (II) AMD Proprietary Linux Driver Build Date: Nov 17 2015 22:40:55
    [    65.928] (--) using VT number 2
    
    [    65.931] (WW) Falling back to old probe method for fglrx
    [    65.943] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
    [    65.945] ukiDynamicMajor: found major device number 250
    [    65.945] ukiDynamicMajor: found major device number 250
    [    65.945] ukiOpenByBusid: Searching for BusID PCI:0:1:0
    [    65.945] ukiOpenDevice: node name is /dev/ati/card0
    [    65.945] ukiOpenDevice: open result is 9, (OK)
    [    65.945] (EE) 
    [    65.945] (EE) Backtrace:
    [    65.946] (EE) 0: X (xorg_backtrace+0x48) [0x58c1e8]
    [    65.946] (EE) 1: X (0x400000+0x190229) [0x590229]
    [    65.946] (EE) 2: /lib64/libc.so.6 (0x7fcef0c28000+0x35200) [0x7fcef0c5d200]
    [    65.946] (EE) 3: /usr/lib64/libatiuki.so.1 (0x7fceed9d0000+0xaef0) [0x7fceed9daef0]
    [    65.946] (EE) 4: /usr/lib64/libatiuki.so.1 (ukiPcsLoadToKernel+0x67) [0x7fceed9dade7]
    [    65.946] (EE) 5: /usr/lib64/libatiuki.so.1 (0x7fceed9d0000+0xa05c) [0x7fceed9da05c]
    [    65.946] (EE) 6: /usr/lib64/libatiuki.so.1 (0x7fceed9d0000+0x9088) [0x7fceed9d9088]
    [    65.946] (EE) 7: /usr/lib64/libatiuki.so.1 (ukiOpen+0x45) [0x7fceed9d55e5]
    [    65.946] (EE) 8: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs116_atiddxPxEarlyCheck+0x51) [0x7fceee223541]
    [    65.946] (EE) 9: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_xs116_atiddxProbe+0xd7f) [0x7fceee2026bf]
    [    65.946] (EE) 10: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (atiddxProbe+0xd) [0x7fceedfe9b4d]
    [    65.946] (EE) 11: X (xf86BusConfig+0x46) [0x46ef16]
    [    65.946] (EE) 12: X (InitOutput+0x8c5) [0x47cdc5]
    [    65.947] (EE) 13: X (0x400000+0x3f36b) [0x43f36b]
    [    65.947] (EE) 14: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7fcef0c49b05]
    [    65.947] (EE) 15: X (0x400000+0x2ac2e) [0x42ac2e]
    [    65.947] (EE) 
    [    65.947] (EE) Segmentation fault at address 0x8
    [    65.947] (EE) 
    Fatal server error:
    [    65.947] (EE) Caught signal 11 (Segmentation fault). Server aborting
    [    65.947] (EE) 
    [    65.947] (EE) 
    Please consult the The X.Org Foundation support 
             at http://wiki.x.org
     for help. 
    [    65.947] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    65.947] (EE) 
    abraracurcix:~ #

    oh, well, it seems a problem with the ATI repo software. So, from yast I removed all ATI fglrx packages and problem solved.
    I have a Opensuse 13.2 running OS that seems to be all right. I guess most of the packages (if not all) have been downgraded, as I'm writing this from a firefox 33.0.


    .............................. to be continued.

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    18,376
    Blog Entries
    1

    Default Re: Upgrade from 13.1 to 42.3 .... my experience

    Quote Originally Posted by fperal View Post
    Then I have tried a direct upgrade to 42.3 using the DVD. I Booted with the 42.3 DVD and select upgrade.
    The system did recognize my installed 13.1 system / (ext4) and allow me to continue with the upgrade process. I enabled the internet connection and all went fine until I got a message (I was installing in spanish, so the message is my translation) "The installed product is not compatible with the product in the installation media- If you try to upgrade with the current installation media the system may not boot or some applications may not work correctly" continue/cancel.

    I selected CANCEL and then It showed another message: "Installed product (Opensuse 13.1) is not compatible with the product in the installation media (Opensuse Leap 42.3)".

    So it recognices the system and I could have continued with the upgrade, but it seems it not supported... So, first question, I did well or I should have continued with the upgrade?
    Well the openSUSE upgrade page you linked to mentions upgrading from openSUSE 13.2 is the earliest version supported officially, though in the end it really depends on a given system, and what was installed to begin with.
    Warning: Do not skip a release when upgrading! Example: do not upgrade from 13.1 to 42.1. Instead, from 13.1 upgrade to 13.2, then from 13.2 upgrade to 42.1.
    So, sensible to upgrade to 13.2 first as you've now done.

  3. #3

    Default Re: Upgrade from 13.1 to 42.3 .... my experience

    Once upgraded to 13.2 I tried again the upgrade to 42.3.

    I didn't do the zypper up, I tried the upgrade with the packages as in the fresh 13.2 install from the DVD.
    Like the previous time I Booted with the 42.3 DVD and select upgrade. The system did recognize my installed 13.2 system / (ext4) and allow me to continue with the upgrade process. I enabled the internet connection and all went fine too.
    This time It didn't complain about compatibility, instead it shows a message "The product opensuse will be upgraded to Opensuse Leap 42.3" and the option to continue with the upgrade.
    The upgrade was 6.6GB total of which 5GB from DVD, 175MB from NON-OSS repo, 330MB from OSS repo and 1.2GB from update repo.

    After 4 hours upgrading (using slow 3G connection) it was about to finish, but it reported an error... grub install error: No valid EFI partition ....oh, I think I selected something bad. When it finished (no more errors) and reboot, the yast menu is faulty and it does not boot.

    Maybe there was other method to solve this problem, but what I did was to boot again from the DVD (previously The computer selected the option EFI boot from DVD, now I select BIOS boot from DVD) an select again upgrade. the system recognizes the installed system as Opensuse Leap 42.3 and it complains the upgrade is not supported (in fact it is not an upgrade) but I continue. It selects for updating/installing 6 packages among them grub2 and kernel-default. I continue with the "upgrade" and all goes fine. My system is now fully updated (including online patches), grub menu is OK and it boot fine.

    After booting I have no network..... it is documented in Opensuse Leap 42.2 (not 42.3) Release Notes on upgrading from previous versions. It said it will happen because of Ethernet device name changes, so I go to yast and I configure again my network card ..... and that's all. I'm writing from my firefox 52.3 on my upgraded Leap 42.3.

    In the next episode .......... upgrading the second system ... I don't know for sure which approach to take although I think I will use the same two steps approach.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    18,376
    Blog Entries
    1

    Default Re: Upgrade from 13.1 to 42.3 .... my experience

    Good to read of your success with this.

    In the next episode .......... upgrading the second system ... I don't know for sure which approach to take although I think I will use the same two steps approach.
    Yep... a sensible idea, and what the upgrade page recommends anyway.

  5. #5
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,051

    Default Re: Upgrade from 13.1 to 42.3 .... my experience

    IMO do a fresh install keep your home backup /etc and just reinstall needed apps. It is faster then dealing with incompatibilities when trying to span so many versions.

    Note you must decide what boot method to use and stick to it when upgrading ie trying to upgrade a legacy boot using EFI booting is bound to cause problems with confusion in the installer. You can do it but you must take full control of the install process and know what you are doing.

    If you boot the installer in EFI mode it will want to do a EFI install.

  6. #6
    Join Date
    May 2017
    Posts
    9

    Default Re: Upgrade from 13.1 to 42.3 ....

    Quote Originally Posted by fperal View Post
    [..]
    Then I have tried a direct upgrade to 42.3 using the DVD.
    [..]
    "The installed product is not compatible with the product in the installation media
    [..]

    I selected CANCEL

    So it recognices the system and I could have continued with the upgrade, but it seems it not supported... So, first question, I did well or I should have continued with the upgrade?
    [..]
    In my upgrade scenario 13.1 -> 42.3 I just took the risk over the warning (using an offline method via USB-drive) and it worked fine.

  7. #7

    Default Re: Upgrade from 13.1 to 42.3 .... my experience

    I have update the second computer. It is a home server with nfs, samba, smtp+pop and lvm over software raid 1.
    I was afraid maybe the upgrade will mess with raid or lvm, but id din't

    I bootend from the 13.2 DVD and started the upgrade. It didn't recognize the previous installation, but checking the "show all partitions" it appears my two partitions:

    /dev/md/sysresccd:0
    /dev/mappaer/lvmgroup_home

    The first one is my root partition, although it was not named /dev/md/sysresccd:0 but /dev/md0 (yes I created it with system rescue, but it was never called that way)
    The second is the /home partition

    But despite the name, I can choose it and it detects there is a Opensuse 13.1 there.
    Then it ask me if I wnat to configure the network, I say yes but it can't, so I continue without network selecting pgrade from DVD which will use 6,4GB.
    Upgrade runs with no problem and It boot fine.

    /dev/md0 is on / type ext4, so is OK

    Then I try a "zypper up" to upgrade packages to their last versions previous to the second upgrade to 42.3
    It detects conflicts from kernel i686 (13.2 OSS) with kernel x86_64 (system).
    Well the system was previously upgraded from a 32 bits Opensuse without raid neither LVM (with hardware change included) and then a brief description of the process was
    -Install a x86_64 mixed with the x86 kernel
    -Boot the x86_64 kernel
    -Upgrade rpm utils to 64 bit version
    -Replace all the packages to 64 bit version.

    That's why there are two kernels with differen architecture, but in fact I'm using only the 64 bit one, so I cancel the update, remove te 32 bit kernel an try again zypper up. this time it works without conflicts
    So I have an up to date Opensuse 13.2.

    Then I check the system and I find that everything seems to be working but samba shares. It seems that samba passwords have disappeared. I cannot access samba shares from a Win10 machine.
    Well I have other error, with graphics: fglrx is causing a problem, I delete all fglrx64 packages and the problem is solved.
    I decide to continue with the upgrade to 42.3 and solve the samba issues later.

    I boot from the 42.3 DVD and select upgrade. Again it does not recognize partition, but checking "show all partitions" solve it and it recognizes again /dev/md/sysresccd:0
    I select the partition, it recognizes the 13.2 installation and I can proceed with the upgrade. this time the network config works and I can select the online repos for the upgrade, it uses 10GB ( 6GB from DVD, 2GB from OSS, 176MB from NON OSS and 1,76GB from UPDATE)

    During the upgrade I get an error with arts-1.5.10-45.25.x86_64, retry does not work so I skip it as I decide is not a critical package. the upgrade finish without more problems.
    Boot menu shows I'm booting 13.1 but in fact 42.3 is working.
    Then I check the system.

    System is working
    NTFS is working
    SMTP is working
    POP3 fails
    SAMBA is working from windows10 but not from windows XP.

    Checking POP3 in xinetd -> qpopper is not installed, so I try to install it and there is no providers. I search it and I find there is no qpopper for 42.3, but I find qpopper 4.10 from home:vodoo for openseuse 42.1, I download it and install it, and it works.


    The problem with samba is not really something not working but a change in policies, as described here. XP uses NTLMv1 for communication with samba servers, and it is disabled for default in last samba versions.

    So, everything is OK now.

    Next step the department server.

    regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •