Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Kmail address autocomplete

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Kmail address autocomplete

    fresh install of 42.3 / Plasma and I've decided to switch to using kmail instead of thunderbird.
    All is up and running well and have my google contacts syncing.
    One problem I have is that I cannot get addresses to autocomplete. I have to manually go into my contacts and select there.
    All bugs relating to this that I could find seem to suggest they were fixed back in kmail 5.4.3
    I'm using kmail 5.5.2

    edit: oops - I see I accidentally selected 42.2 instead of 42.3 as the thread prefix
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,284
    Blog Entries
    1

    Default Re: Kmail address autocomplete

    edit: oops - I see I accidentally selected 42.2 instead of 42.3 as the thread prefix
    I've corrected that for you.


    I'm not using kmail so can't offer anything other than basic advice/ideas here. Can you confirm that 'libKF5AkonadiSearch' is installed?

    Just in case the following is helpful

    For me contact completion from the address book was not working at all. It was fixed by right clicking on "Personal Contacts" in the Akonadi Console (akonadiconsole) and selecting "Clear Akonadi Cache". I'm on openSUSE Leap 42.2 with KMail 5.3.0 and KDE Frameworks 5.26.0.
    https://bugs.kde.org/show_bug.cgi?id=354400#c68

  3. #3
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Kmail address autocomplete

    Quote Originally Posted by deano_ferrari View Post
    . . . Can you confirm that 'libKF5AkonadiSearch' is installed?
    yes. checked on that in is installed

    Just in case the following is helpful



    https://bugs.kde.org/show_bug.cgi?id=354400#c68
    installed akonadiconsole and cleared the cache for google contacts but all this seemed to do was remove all the contacts from within that contact folder and I couldn't get them back. Selecting to "sync now" didn't seem to do anything. Only way to get the contacts back was to remove the account then add it in again. Still no autocomplete though
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,284
    Blog Entries
    1

    Default Re: Kmail address autocomplete

    I've read accounts of users who report that auto completion only works after typing in an initial character then backspacing and typing again to bring up search results. Is this the same for you, or it doesn't work at all?
    Last edited by deano_ferrari; 11-Aug-2017 at 17:16.

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,546

    Default Re: Kmail address autocomplete

    Quote Originally Posted by deano_ferrari View Post
    I've read accounts of users who report that auto completion only works after typing in an initial character then backspacing and typing again to bring up search results. Is this the same for you, or it doesn't work at all?
    thanks, but I've tried that.
    autocomplete just doesn't work for me at all.
    I thought it might be due to using google contacts so I imported all my contacts into the "personal" contacts and followed the instructions from post #2 but still no luck.
    Mark F.
    openSUSE Leap 15.1 / Plasma 5.12



  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,284
    Blog Entries
    1

    Default Re: Kmail address autocomplete

    Quote Originally Posted by farcusnz View Post
    thanks, but I've tried that.
    autocomplete just doesn't work for me at all.
    Well that's why I asked

    I thought it might be due to using google contacts so I imported all my contacts into the "personal" contacts and followed the instructions from post #2 but still no luck.
    A bug report might be the best course of action here then.

  7. #7
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Default Re: Kmail address autocomplete

    Exactly the same situation here as described by the TS:
    Only "Recent Addresses" will show up when I start typing into the To:, CC: or BCC: fields...

    Configuration:
    - New installation of openSUSE 42.3 Leap
    - KMail/Kontact 5.5.2
    - New address book of type "Personal Contacts"
    - "libKF5AkonadiSearch" is installed
    - Typing in an initial character then backspacing and typing again does not help

    Cheers,
    Hardy

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,802
    Blog Entries
    14

    Default Re: Kmail address autocomplete

    Are you sure the search function is active on the used address book(s):
    Kmail - Settings - Editor - Autocompletion settings
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,518

    Default Re: Kmail address autocomplete

    As a faithful, despite all the issues which have arose over the years, KMail (and Kontact) user, I can confirm that, the KMail2 on this Leap 42.2 machine (version: kmail2 5.3.0 (QtWebEngine)) only really begins to search for e-Mail addresses after at least 3 characters have been typed.
    • And, the search doesn't always pull in the KAddressbook (also version 5.3.0) entries . . .

    Only sometimes and even then, quite erratically except for my surname -- it finds my family in KAdressbook quite consistently -- others not . . .

    May, possibly, be a Qt Web Engine issue -- the Qt world is flirting with "declarative programming technology" which, IMHO, seems to be occasionally the "fly in the soup".

  10. #10
    Join Date
    Jul 2008
    Location
    Munich, Germany
    Posts
    116

    Default Re: Kmail address autocomplete

    Quote Originally Posted by Knurpht View Post
    Are you sure the search function is active on the used address book(s):
    Kmail - Settings - Editor - Autocompletion settings
    Good point!
    But: Could it be that you are referring to some older KMail version?
    KMail 5.5.2 (which comes with openSUSE 42.3 Leap) the path to the "Composer" settings
    is as follows: Settings > Configure KMail... > Composer > Tab "General".

    However, here one can check/uncheck:
    - Use addresses indexed from emails for autocompletion
    - Use recent addresses for autocompletion

    Both are/have been checked with my KMail...

    @dcurtisfra
    Also I've tested if autocompletion works after having entered 3 characters... doesn't help.
    And if typing one ore more characters, then deleting 'em, then starting over with typing... doesn't help either.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •