Results 1 to 7 of 7

Thread: Revert YaST "Do not show this warning again"

  1. #1

    Default Revert YaST "Do not show this warning again"

    Recently received a warning about an unknown signing key when refreshing a repository via YaST2, and was asked if I wanted to continue. I thought selecting "Yes" and checking "Do not show this warning again" would resolve the problem, but now I regret that course of action. Any idea how I can configure YaST2 to show those warnings again? (I'm on Tumbleweed, mostly up to date.)

    Thanks -- please let me know if I've left out anything important.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,790
    Blog Entries
    3

    Default Re: Revert YaST "Do not show this warning again"

    I'm not sure, but I will guess:

    First become root in a terminal.
    Code:
    cd /root/.config
    rm -rf YaST2
    That should clear Yast settings.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3

    Default Re: Revert YaST "Do not show this warning again"

    That seems like a reasonable course of action, although I don't see any mention of ignoring keys or warnings in the included files. Perhaps it was a session-only kind of thing, rather than global?

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,790
    Blog Entries
    3

    Default Re: Revert YaST "Do not show this warning again"

    I'm not sure whether it will solve your specific problems.

    Some settings come from zypp "/etc/zypp/*.conf", but I don't think those are set automatically. Some settings might be in the RPM database. I'm not sure how you change those. And perhaps that's where the key warnings go.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,937

    Default Re: Revert YaST "Do not show this warning again"

    I think this setting apply to the specific repo, not to all. So perhaps removing and adding (maybe with a repo refresh in between) the repo will bring the message back?

    Just guessing, mind you.

  6. #6

    Default Re: Revert YaST "Do not show this warning again"

    I haven't yet deleted any of the referenced configuration files, but I _have_ now deleted and recreated the repo, so I'll check back in if I manage to regenerate the warning/error message.

    For background, I put myself in this situation while trying to diagnose what is apparently an issue with zypper's inability to handle subkeys, and Google's recent switch to signing chrome with a subkey; also there seems to be an issue with the post-installation script no longer creating a Google repository entry under Tumbleweed. See below for some reference:
    https://bugzilla.opensuse.org/show_bug.cgi?id=1008325
    https://bugs.chromium.org/p/chromium...tail?id=750481
    https://forums.opensuse.org/showthre...on-Error/page2

    In the course of stumbling around this issue, I've re-imported their public key, which may or may not have resolved the missing key issue, so I might not be able to generate the original warning anymore. I've also manually recreated the repo. Nonetheless, the Software Update applet still seems to choke on lack of trust. I seem to be able to update from within zypper now, though. Go figure.

  7. #7

    Default Re: Revert YaST "Do not show this warning again"

    Forgot to mention, thanks for the help.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •