Results 1 to 7 of 7

Thread: problem with openSSH

  1. #1

    Default problem with openSSH

    Ever since I installed Leap 42.3 on two LAN connected PCs,
    I am not able to log into the other computer:

    ssh 192.168.0.8
    ssh: connect to host 192.168.0.8 port 22: Connection refused

    I have no problem to log into other machines that run older versions of
    openSUSE.

    openSSH is installed on both computers, port 22 is open, and the
    firewall has been temporarily disabled. Login name and password are
    identical on both server and client.

    in my struggle to get this working I have created new keys by means
    of ssh_keygen.

    On the client the ~/.ssh/id_rsa
    -----BEGIN RSA PRIVATE KEY-----
    Proc-Type: 4,ENCRYPTED
    DEK-Info: AES-128-CBC,664AA73DE28CB9A38B4DF04AEE033D3D

    rBk3E97j4sNmakaaIdJ7Yh4UVCivp9oBXzg+sgDaGGHGAzLiXlLPYdYDdYQz5Ic1
    e7S0MP3WVEhS5WSq5sU0mTTu6AKRF2lTiGlj0eATrT4FGeikOkO4j5dLzaxNgz4o
    stHnWCXJvoNA1C5nsxDkGezm9HK3nncurbEuUAZCdQavQ8l9Je3IX5Nf7Iqzlc/l
    sKfitTec1QbPU2Q/PQu4p8HNX1NOPZIcuHh1oKj77EOqpQTW5ZEG1c47FqVp/qFX
    HNF4nzLkNWDKNtedrSVm846DBL9bgjPr1WroLEGkVNCXNR0KnsmeQzOMJ48CwO+G
    3eT1y5NWAMcOVYwfeM7pfDFC9Ly91yNgnf93chp8cxISyZHqU1eEaA+IPdfNE3a/
    kSahHSjB+A4J+eOkcoDaLUTWwnrOXSqM+lSe+kCIGpz3scwKedOuZi+6be7S6FRJ
    H8VKsj75d6MMPmhyp4b9knf+XkbjhXeRheau2sqqx238eyxHvV0ib+ii8L5uG7Ce
    Zg4C4pUkPn166+vQfu+x0Tz9/lLpauaxmlM/SxNmVoIIjhvaLbIxG2r0omeygjie
    Twxxkusfp/rw08jbrD8+0nKewY2xFENMazh2efXpnKKFDs4TOEmXNZTZy4m7OMJO
    WtjvuKPrNcTHGxlp1SDbt/co4vLMEPvhRtn4VKDEbiElVoDJU/Vz4DbhLo4y9QVJ
    wd1GYmFDSt5dKpNEv5NM3/R/y+TfO6sq7LnpOFynX8cLUEiwaJUDGlJAZaYp/o9+
    XkiKLIK3fokVhJvuD0uY2z0hvn+y0OnrGSxTOnqZCoVBpWHRiWHSP4oRAsDCgcnC
    GVhvR8WWRASfFR73MgIAKxLqRQcMtYFPMK/jAWiUu+Zl6duYX8Hv/RtEK9nV6boj
    XjeYwwXNvB2ROwDPLLuLTGwW1zmGCbKLBBzPgJZf705GP9SUkNJEkbRqpb678oPL
    8ZNvn50UauVXazkQrKGTh6RpKIYrGxI2PLvGKWhfJplGY/LlKAhERXBKL6TlmcZm
    oYC58aJb5+HsAotun0PQmCkMhugxkSghEon2AJh0rY1CcKtSuDENbhgt/lCSkF30
    Z91u3WPNRvbLhh29ibYiI0+2IYsaVvd/Sl+P007K9Z9Wu/EB0Vh5VXBvMgCf0QpP
    w9ikhCKPBikppuvow9miyzIRSZAl4N4S1NVpje38U8i3NFZg45oNQ3S5MkUZ3qZA
    UhcqQ+0gnEZsu8lUQpJ7kbR6rXNOAUlxTPSZBXdIB6iN3rJN2kgIGqxy60S3mH5s
    33EkrK5mT1BTeRqua4TwI6F0uQXhhLs45VrT1RoXoNO2f48xZXijjU2zuI3/Rwfe
    c04aCPFW++B/ERBSflcxZeARwTlYASIwRkFb18p6lflWNFcyYyYFUXIMJk/CCrIJ
    trlcuslfCIMqoNCdo9cAkLylB7+ry3n5/7yfZjgYkBdtChxasaMu52Ljpm96hCEb
    hTM4PT5ifH9SlsuX/W5O3Mfzyo57JMWaFwcCEMWH5Kv90bO0Chq2iaQgVHqI37lj
    JJk/F3W2bPAmi9sIHLOaY2epD0cwKkFlNgDkMM4CIPyZKNli3QeE0SztD/1iUnFT
    -----END RSA PRIVATE KEY-----
    on the server ~/.ssh/authorized_keys
    the pubic key is as follows:
    ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQDTSMPn7EO5oCeYp4YSd+OVQV6m1vtQvowXuaA6UFuqqNlTSaCRNxLm0T79VHHBTpeGbFdvIr6/9o5WLbVvLDvepyHawTxhImEuK31Ir1l1yijTZWkN7cX5kQ7jv+191cQ95M374AnNsxTCQzpLwv5FXb6If3t21Vw1XM/PbTaVc8bdSypVDKx16X5UvqUcm29PRHUWvkRVO1G0xH4YO7aq5K6QeNucDODtbFC59XFfltziVWjLcV1BJCnDjmzBELH0pkoel7hRp321rTstJZ2zahic0g4Ffq9DJfQ05WVCtlWgUVf8KdgTll4JxVzfrvKyNzzgCQBAAe3DVFqkbsVf egbert@egbert
    There seems to be something different on Leap 42.3 than on older
    versions, but I don't know what.

    I hope someone can help me with this prblem.
    Thanks for helping.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,788

    Default Re: problem with openSSH

    The computer (ssh) says: "Connection refused".
    You say: "it is listening on port 22". I think you must prove that that is the case. E .g. by
    Code:
    netstat -tulpn | grep :22
    (the idea behind it being that we do not trust what people say, but what computers show ).

    And please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.
    Henk van Velden

  3. #3

    Default Re: problem with openSSH

    Hello Henk
    Thanks for your timely answer.
    I didn't mean to say "port 22 is open", but rather I wanted to indicate that I
    opened (tried to open) port 22 through the YAST/Firewall settings.

    But the computer said this:
    Code:
    egbert:/home/egbert # netstat -tulpn | grep :22
    egbert:/home/egbert #
    i.e. nothing. Port is obviously not open.
    Now, what can I do to create and open it?
    Hope you can help me with that also.

    I have the same problem with port 3306 to connect to mySQL database.
    Hoping that this will also be solved in the same manner.
    Egbert.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: problem with openSSH

    Quote Originally Posted by nicari View Post
    But the computer said this:
    Code:
    egbert:/home/egbert # netstat -tulpn | grep :22
    egbert:/home/egbert #
    i.e. nothing. Port is obviously not open.
    Now, what can I do to create and open it?
    Hope you can help me with that also.
    So sshd is not running on the server?
    Code:
    systemctl status sshd

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,788

    Default Re: problem with openSSH

    Quote Originally Posted by nicari View Post
    i.e. nothing. Port is obviously not open.
    .
    As @deano_ferrari concludes, there is no program listening on port 22. If it is open or not (on the firewall) is of no importance as long as nothing is listening.

    So, like he suggests, check if sshd is running.
    Henk van Velden

  6. #6

    Default Re: problem with openSSH

    Thanks for all your help. ssh is working now.
    There are still 2 problems with Leap 42.3, but I will open new threads for them, as they are different.

    Regards from Manila
    Egbert

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: problem with openSSH

    Quote Originally Posted by nicari View Post
    Thanks for all your help. ssh is working now.
    There are still 2 problems with Leap 42.3, but I will open new threads for them, as they are different.

    Regards from Manila
    Egbert
    Thanks for the update.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •