Results 1 to 8 of 8

Thread: Repeated kwin crashes

  1. #1

    Default Repeated kwin crashes

    Since the upgrade to Leap42.3/KDE I had several GUI (kwin) crashes. They normally happen when I have several browsers open and e.g. at the same time copy large files to USB stick. The first symptoms are that the cursor freezes for approx up to half a minute, later the whole GUI freezes and the taskbar/menu button, etc. disappear and when the mouse moves again I have no right click facility. First I thought it might be an earlier reported problem and I created the file
    Code:
    linux-tl1r:/etc/X11/xorg.conf.d # more 20-intel.conf 
    Section "Device"
               Identifier  "Intel Graphics"
               Driver      "intel"
               Option      "AccelMethod"  "uxa"
    EndSection
    linux-tl1r:/etc/X11/xorg.conf.d #
    But the crashes still kept coming so I filled in the KDE bug report with their backtrace feature see https://bugs.kde.org/show_bug.cgi?id=383335
    Now I received the answer: "Crash in Intel driver triggered from QtQuick. Not a crash in our code, nothing we can do. Please report to Intel."
    Has this crash happened to someone else - is there a solution? It didn't happen at Leap42.2
    Cheers
    Uli

  2. #2

    Default Re: Repeated kwin crashes

    Now 68 views and on page 2 - is there nobody who has similar problems or who know possible reasons?

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Repeated kwin crashes

    It's likely to be hardware specific. Maybe you should post you graphics card details here for others to see...
    Code:
    /usr/sbin/hwinfo --gfxcard
    Pure speculation here but have you tried changing the compositor settings? In particular the rendering backend. Does turning of the compositing with Shift+Alt+F12 help?

  4. #4

    Default Re: Repeated kwin crashes

    Thanks you, deano_ferrari, here is the result.
    Code:
    /usr/sbin/hwinfo --gfxcard
    07: PCI 02.0: 0300 VGA compatible controller (VGA)              
      [Created at pci.378]
      Unique ID: _Znp.p1gz93toWl1
      SysFS ID: /devices/pci0000:00/0000:00:02.0
      SysFS BusID: 0000:00:02.0
      Hardware Class: graphics card
      Model: "Intel Core Processor Integrated Graphics Controller"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x0046 "Core Processor Integrated Graphics Controller"
      SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
      SubDevice: pci 0x1be2 
      Revision: 0x18
      Driver: "i915"
      Driver Modules: "i915"
      Memory Range: 0xd0000000-0xd03fffff (rw,non-prefetchable)
      Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
      I/O Ports: 0xe080-0xe087 (rw)
      IRQ: 29 (38487 events)
      I/O Ports: 0x3c0-0x3df (rw)
      Module Alias: "pci:v00008086d00000046sv00001043sd00001BE2bc03sc00i00"
      Driver Info #0:
        Driver Status: i915 is active
        Driver Activation Cmd: "modprobe i915"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
    Primary display adapter: #7
    Does turning of the compositing with Shift+Alt+F12 help?
    I don't know this key sequence and what it should do, but most of the time no key function was available. A few times I could logout with ctrl+alt+Backspace but most of the time I had to use the power button. In the reply of the bug report to KDE (https://bugs.kde.org/show_bug.cgi?id=383335) I was told: "Crash in Intel driver triggered from QtQuick. Not a crash in our code...." but I don't understand the details from the bug report. Since it didn't happen in Leap42.2 I wondered if I could use the old (or another) intel driver?

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Repeated kwin crashes

    It toggle's the compositor (desktop effects) on and off in KDE. You can't use it if the the DE has crashed though - it was more a suggestion to see whether crashes still occurred when it is turned off. It isn't a solution, just a workaround that may be acceptable to you for now. Anyway, it can be turned off permanently via

    System Settings > Hardware > Display and Monitor > Compositor > Enable compositor on startup, uncheck it

    *It will take effect on next login.

    There may well be a regression with the intel driver (and some hardware) impacting here, but no it is not possible to use an older driver - that's tied to the kernel you're using in any case. I have a laptop with intel hardware and running oenSUSE 42.3, but don't appear to be impacted by the issue you're describing.
    Last edited by deano_ferrari; 11-Aug-2017 at 20:31.

  6. #6

    Default Re: Repeated kwin crashes

    Thank you, deano_ferrari, I had a look at system settings and the tick box for the enabling of the compositor at startup is unchecked now, however just above is the following message:

    "OpenGL compositing (the default) has crashed KWin in the past.

    This was most likely due to a driver bug.

    If you think that you have meanwhile upgraded to a stable driver,
    you can reset this protection but be aware that this might result in an immediate crash!
    Alternatively, you might want to use the XRender backend instead."

    So I have now changed to XRender and will see how this is going.
    Cheers
    Uli

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Repeated kwin crashes

    Yes, all good. See how that goes. Maybe you can live with these settings (=less eye-candy) for now.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,704
    Blog Entries
    1

    Default Re: Repeated kwin crashes

    Quote Originally Posted by fuerstu View Post

    So I have now changed to XRender and will see how this is going.
    Cheers
    Uli
    PS You may find that is all that is needed, and that the compositor can be left enabled. Some experimentation needed on your part..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •