Results 1 to 9 of 9

Thread: Pulseaudio problem after upgrading to Leap 42.3

  1. #1
    Join Date
    Jun 2008
    Location
    Gainesville, FL, USA
    Posts
    45

    Default Pulseaudio problem after upgrading to Leap 42.3

    After upgrading from Leap 42.2, I lost sound for regular users. Only root had sound. Thinking this was a permission problem, I added audio,pulse to the regular users groups to no avail.

    Digging a little further, I noticed that root was sending audio output to a "Default Device" in KDE Multimedia whereas for a regular user, it was attempting to send the output to HDMI Audio Output. Since I only had Analog Stereo Output, I fired up Pulse Audio Control (pavucontrol) and attempted to change the output device to Analog Stereo. This was not possible since there was no such option.

    So, to temporarily get audio working for a regular user, I disabled pulseaudio in Yast -> Sound. Now, audio works for a regular user.

    But, I'd like to get pulseaudio working again. How do I get pulseaudio to allow me to direct output to Analog Stereo Speakers if that option does not exist in the GUI? Do I have to change a pulseaudio or modprobe/sound configuration file?

    Here's the output of aplay -l:

    anand@agape-server:~> aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
    Subdevices: 0/1
    Subdevice #0: subdevice #0
    card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

    Detailed alsa info has been uploaded to http://www.alsa-project.org/db/?f=7c...b750c34850a987

    Thanks for any help! My kid looked at what I was doing to get audio working and said "You linux people are crazy" :-(

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Pulseaudio problem after upgrading to Leap 42.3

    After upgrading from Leap 42.2, I lost sound for regular users. Only root had sound. Thinking this was a permission problem, I added audio,pulse to the regular users groups to no avail.

    Digging a little further, I noticed that root was sending audio output to a "Default Device" in KDE Multimedia whereas for a regular user, it was attempting to send the output to HDMI Audio Output. Since I only had Analog Stereo Output, I fired up Pulse Audio Control (pavucontrol) and attempted to change the output device to Analog Stereo. This was not possible since there was no such option.
    This might useful as well
    Code:
    aplay -L
    Perhaps start by cleaning out the PA user config (or rename it). It will get recreated when PA next starts anyway.
    Code:
    rm -rf ~/.config/pulse/
    Then do
    Code:
    sudo setup-pulseaudio --enable
    Code:
    pulseaudio -Dv
    What is reported by the following?
    Code:
    pactl list
    Thanks for any help! My kid looked at what I was doing to get audio working and said "You linux people are crazy" :-(
    What's his/her point?

  3. #3
    Join Date
    Jun 2008
    Location
    Gainesville, FL, USA
    Posts
    45

    Default Re: Pulseaudio problem after upgrading to Leap 42.3

    Results of aplay -L

    anand@agape-server:~> aplay -L
    null
    Discard all samples (playback) or generate zero samples (capture)
    default
    Default ALSA Output (currently PulseAudio Sound Server)
    sysdefault:CARD=PCH
    HDA Intel PCH, ALC892 Analog
    Default Audio Device
    front:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    Front speakers
    surround21:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    2.1 Surround output to Front and Subwoofer speakers
    surround40:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    4.0 Surround output to Front and Rear speakers
    surround41:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=PCH,DEV=0
    HDA Intel PCH, ALC892 Analog
    7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    hdmi:CARD=HDMI,DEV=0
    HDA ATI HDMI, HDMI 0
    HDMI Audio Output

    ---------------------------------------------

    Re-enabled pulseaudio after deleting the .config/pulse directory. Rebooted.
    Checked the default sink in .config/pulse

    anand@agape-server:~/.config/pulse> more 74fc18841ff54a7f8e09f6b58d4bad53-default-sink
    alsa_output.pci-0000_01_00.1.hdmi-stereo

    It still gives me just one hdmi option (as does the pavucontrol GUI). No Analog Stereo. Is pulseaudio getting the wrong info from alsa somehow? Can I hardcode the analog stereo output as the default somewhere for pulseaudio to pick up?

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Pulseaudio problem after upgrading to Leap 42.3

    What about the following?
    Code:
    pactl list sinks
    BTW, please use [CODE][/CO..] tags when posting output. Refer to the '#' button in the forum editor.

  5. #5
    Join Date
    Jun 2008
    Location
    Gainesville, FL, USA
    Posts
    45

    Default Re: Pulseaudio problem after upgrading to Leap 42.3

    Quote Originally Posted by deano_ferrari View Post
    What about the following?
    Code:
    pactl list sinks
    BTW, please use [CODE][/CO..] tags when posting output. Refer to the '#' button in the forum editor.
    Sorry, here you go.

    Code:
    pactl list sinks
    Sink #2
            State: SUSPENDED
            Name: alsa_output.pci-0000_01_00.1.hdmi-stereo
            Description: Caicos HDMI Audio [Radeon HD 6400 Series] Digital Stereo (HDMI)
            Driver: module-alsa-card.c
            Sample Specification: s16le 2ch 48000Hz
            Channel Map: front-left,front-right
            Owner Module: 6
            Mute: no
            Volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                    balance 0.00
            Base Volume: 65536 / 100% / 0.00 dB
            Monitor Source: alsa_output.pci-0000_01_00.1.hdmi-stereo.monitor
            Latency: 0 usec, configured 0 usec
            Flags: HARDWARE DECIBEL_VOLUME LATENCY SET_FORMATS 
            Properties:
                    alsa.resolution_bits = "16"
                    device.api = "alsa"
                    device.class = "sound"
                    alsa.class = "generic"
                    alsa.subclass = "generic-mix"
                    alsa.name = "HDMI 0"
                    alsa.id = "HDMI 0"
                    alsa.subdevice = "0"
                    alsa.subdevice_name = "subdevice #0"
                    alsa.device = "3"
                    alsa.card = "1"
                    alsa.card_name = "HDA ATI HDMI"
                    alsa.long_card_name = "HDA ATI HDMI at 0xfe640000 irq 32"
                    alsa.driver_name = "snd_hda_intel"
                    device.bus_path = "pci-0000:01:00.1"
                    sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
                    device.bus = "pci"
                    device.vendor.id = "1002"
                    device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
                    device.product.id = "aa98"
                    device.product.name = "Caicos HDMI Audio [Radeon HD 6400 Series]"
                    device.string = "hdmi:1"
                    device.buffering.buffer_size = "352768"
                    device.buffering.fragment_size = "176384"
                    device.access_mode = "mmap+timer"
                    device.profile.name = "hdmi-stereo"
                    device.profile.description = "Digital Stereo (HDMI)"
                    device.description = "Caicos HDMI Audio [Radeon HD 6400 Series] Digital Stereo (HDMI)"
                    alsa.mixer_name = "ATI R6xx HDMI"
                    alsa.components = "HDA:1002aa01,00aa0100,00100200"
                    module-udev-detect.discovered = "1"
                    device.icon_name = "audio-card-pci"
            Ports:
                    hdmi-output-0: HDMI / DisplayPort (priority: 5900, not available)
            Active Port: hdmi-output-0
            Formats:
                    pcm

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Pulseaudio problem after upgrading to Leap 42.3

    Ok, that looks as expected with respect to your HDMI device anyway.

    Are both cards (Analog and HDMI) shown via the following?
    Code:
    pactl list cards

  7. #7
    Join Date
    Jun 2008
    Location
    Gainesville, FL, USA
    Posts
    45

    Default Re: Pulseaudio problem after upgrading to Leap 42.3

    Quote Originally Posted by deano_ferrari View Post
    Ok, that looks as expected with respect to your HDMI device anyway.

    Are both cards (Analog and HDMI) shown via the following?
    Code:
    pactl list cards
    I don't think so. Think only the HDMI output is shown. Don't understand why the Analog Stereo Output doesn't show up. I get sound on my analog audio speakers for root (and users when not using pulseaudio).

    Code:
    pactl list cards
    
    Card #0
            Name: alsa_card.pci-0000_01_00.1
            Driver: module-alsa-card.c
            Owner Module: 6
            Properties:
                    alsa.card = "1"
                    alsa.card_name = "HDA ATI HDMI"
                    alsa.long_card_name = "HDA ATI HDMI at 0xfe640000 irq 32"
                    alsa.driver_name = "snd_hda_intel"
                    device.bus_path = "pci-0000:01:00.1"
                    sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
                    device.bus = "pci"
                    device.vendor.id = "1002"
                    device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
                    device.product.id = "aa98"
                    device.product.name = "Caicos HDMI Audio [Radeon HD 6400 Series]"
                    device.string = "1"
                    device.description = "Caicos HDMI Audio [Radeon HD 6400 Series]"
                    module-udev-detect.discovered = "1"
                    device.icon_name = "audio-card-pci"
            Profiles:
                    output:hdmi-stereo: Digital Stereo (HDMI) Output (sinks: 1, sources: 0, priority: 5400, available: yes)
                    output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (sinks: 1, sources: 0, priority: 300, available: yes)
                    output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (sinks: 1, sources: 0, priority: 300, available: yes)
                    off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
            Active Profile: output:hdmi-stereo
            Ports:
                    hdmi-output-0: HDMI / DisplayPort (priority: 5900, latency offset: 0 usec, not available)
                            Properties:
                                    device.icon_name = "video-display"
                            Part of profile(s): output:hdmi-stereo, output:hdmi-surround, output:hdmi-surround71

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Pulseaudio problem after upgrading to Leap 42.3

    Hmmm...let's try forcing the sound card order, so that first sound card is the analog one. I'm basing this on your alsa diagnostic info you shared
    Code:
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6400 Series]
    
    
    !!Advanced information - PCI Vendor/Device/Subsystem ID's
    !!-------------------------------------------------------
    
    00:1b.0 0403: 8086:1c20 (rev 05)
        Subsystem: 17aa:3611
    --
    01:00.1 0403: 1002:aa98
        Subsystem: 1462:aa98

    You'll need to make a custom edit (as root) to /etc/modprobe.d/50-sound.conf so that it contains the following

    Code:
    options snd-hda-intel index=0 vid=8086 pid=1c20 
    options snd-hda-intel index=1 vid=1002 pid=aa98
    Then restart alsa with
    Code:
    sudo systemctl restart alsasound
    You might need to logout and back in again, or else restart PA with
    Code:
    pulseaudio -k;pulseaudio -D
    Let's see if that makes a difference.

  9. #9
    Join Date
    Jun 2008
    Location
    Gainesville, FL, USA
    Posts
    45

    Default Re: Pulseaudio problem after upgrading to Leap 42.3

    Quote Originally Posted by deano_ferrari View Post
    Hmmm...let's try forcing the sound card order, so that first sound card is the analog one. I'm basing this on your alsa diagnostic info you shared
    Code:
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Caicos HDMI Audio [Radeon HD 6400 Series]
    OK, I tried making the Intel device primary and the Caicos device secondary, rebooted and restarted pulseaudio. No dice. (I did the edits in 50-sound.conf as well.)

    Sorry, but I have to give up because of real world pressures. I've disabled pulseaudio, removed the Caicos card from Yast -> Sound and I get sound as a regular user now. (I understand I'll be giving up per application sound control but the extra configuration headache just doesn't seem worth it. FWIW, I still see the Caicos card HDMI output as an option in KDE Settings -> Multimedia when I enable pulseaudio, despite the fact that I disabled it in Yast. IMHO, this is confusing and should not be allowed.)

    Thanks for all your help. It's amazing to see this much commitment to make open source desktops work in 2017, so thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •