Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Login language stuck to English

  1. #1
    Join Date
    Nov 2016
    Location
    Corsica
    Posts
    12

    Default Login language stuck to English

    Hi,

    My system main and only language is set to "French fr_FR", and since upgrade to 42.3, the login screen shows up in english, login menu too. Never had that problem on this system, set up as 13.1 in 2013 and successively upgraded as new versions are available.

    How to fix this ?

    thx,

    Daniel

  2. #2

    Default Re: Login language stuck to English

    Try to set the language in YaST->System->Language.

    If that doesn't help, please tell what displaymanager and/or desktop you are using.

  3. #3
    Join Date
    Nov 2016
    Location
    Corsica
    Posts
    12

    Default Re: Login language stuck to English

    Quote Originally Posted by wolfi323 View Post
    Try to set the language in YaST->System->Language.
    language is already set this way


    Quote Originally Posted by wolfi323 View Post
    If that doesn't help, please tell what displaymanager and/or desktop you are using.
    kdm and kde, as set by the installer.

    Thx

  4. #4

    Default Re: Login language stuck to English

    try to switch to a different language in yast>language, confirm, let yast delete the rpms of your language and install those of the other lang. Then do it again, this time switching back to your preferred language. I had this problem after a network install of tumbleweed.

  5. #5

    Default Re: Login language stuck to English

    Quote Originally Posted by zartha View Post
    kdm and kde, as set by the installer.
    Well, kdm is not set by the installer... But if you upgraded, it wouldn't be changed either.

    What does /usr/share/kde4/config/kdm/kdmrc contain then?

  6. #6
    Join Date
    Nov 2016
    Location
    Corsica
    Posts
    12

    Default Re: Login language stuck to English

    Quote Originally Posted by wolfi323 View Post
    Well, kdm is not set by the installer... But if you upgraded, it wouldn't be changed either.

    What does /usr/share/kde4/config/kdm/kdmrc contain then?
    Code:
    # Language and locale to use in the greeter, encoded like $LANGUAGE.
    # If empty, the settings from the environment are used.
    # Default is ""
    Language=fr

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Login language stuck to English

    Quote Originally Posted by zartha View Post
    Code:
    # Language and locale to use in the greeter, encoded like $LANGUAGE.
    # If empty, the settings from the environment are used.
    # Default is ""
    Language=fr
    Can you confirm that kdm really is your display manager?
    Code:
    systemctl status display-manager

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Login language stuck to English

    What does the $LANGUAGE variable setting look like?
    Code:
    echo $LANGUAGE
    I'm just wondering if 'Language=' format should be more like fr_FR for example.

  9. #9
    Join Date
    Nov 2016
    Location
    Corsica
    Posts
    12

    Default Re: Login language stuck to English

    Sorry, we don't live on the same time zone

    Code:
    daniel@jina-portable:~> systemctl status display-manager
    ● display-manager.service - X Display Manager
       Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
       Active: active (running) since jeu. 2017-08-10 21:22:28 CEST; 3min 1s ago
      Process: 2586 ExecStart=/usr/lib/X11/display-manager start (code=exited, status=0/SUCCESS)
     Main PID: 2655 (kdm)
        Tasks: 6 (limit: 512)
       CGroup: /system.slice/display-manager.service
               ├─2655 /usr/bin/kdm
               └─2691 /usr/bin/Xorg -br :0 vt7 -nolisten tcp -seat seat0 -auth /var/lib/kdm/AuthFiles/A:0-Wn0pGb
    daniel@jina-portable:~>echo $LANGUAGE
    fr
    As a clue, I noticed that /usr/share/kde4/config/kdm/kdmrc was last modified by the time I did the upgrade on last saturday... Maybe a bug in a script ?

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Login language stuck to English

    Quote Originally Posted by zartha View Post
    Sorry, we don't live on the same time zone
    That's no problem. People post and others reply when they can, wherever they may be located.

    Anyway, thanks for confirming the requested details. I still wonder if 'Languge=fr' shouldn't be more like 'Language=fr_FR' but that's just speculation on my part.

    As a clue, I noticed that /usr/share/kde4/config/kdm/kdmrc was last modified by the time I did the upgrade on last saturday... Maybe a bug in a script ?
    I'm sure wolfie323 will be be able to assist further here.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •