Results 1 to 6 of 6

Thread: best way I have found to disable laptop touchpad

  1. #1

    Default best way I have found to disable laptop touchpad

    This is what I looked for and finally found. If you are like me and dislike the touchpad creating havoc when you are typing and you have a mouse that you use instead of the touchpad.

    Go here:
    https://www.maketecheasier.com/disab...startup-linux/

  2. #2

    Default Re: best way I have found to disable laptop touchpad

    Errm, there are config options in KDE Plasma systemsettings to that end. Startup desktop files do have their uses, though. I mute audio, trigger autofs, and move browser cache to ramdisk this way.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,192
    Blog Entries
    1

    Default Re: best way I have found to disable laptop touchpad

    Quote Originally Posted by hwms View Post
    This is what I looked for and finally found. If you are like me and dislike the touchpad creating havoc when you are typing and you have a mouse that you use instead of the touchpad.

    Go here:
    https://www.maketecheasier.com/disab...startup-linux/
    That assumes the use of the synaptics driver. For the most-part, libinput has replaced both evdev and synaptics Xorg input drivers, and DEs typically have options to inhibit touchpads anyway.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: best way I have found to disable laptop touchpad

    Quote Originally Posted by hwms View Post
    If you are like me and dislike the touchpad creating havoc when you are typing and you have a mouse that you use instead of the touchpad.
    There's an explicit setting for this in KDE.

    Configure Desktop --> Input Devices --> Touchpad --> Enable/Disable Touchpad

    Set it to disable the touchpad when a mouse is plugged in.

    It works great. The existence of that setting is the main reason that I use KDE.
    openSUSE Leap 15.1; KDE Plasma 5;

  5. #5

    Default Re: best way I have found to disable laptop touchpad

    Quote Originally Posted by nrickert View Post
    There's an explicit setting for this in KDE.

    Configure Desktop --> Input Devices --> Touchpad --> Enable/Disable Touchpad

    Set it to disable the touchpad when a mouse is plugged in.

    It works great. The existence of that setting is the main reason that I use KDE.
    Thanks for the info. My find doesn't seem to work but for a little while. Now a question.. Do I have to do this enable/disable touchpad every time I boot my laptop or just once?

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,363
    Blog Entries
    3

    Default Re: best way I have found to disable laptop touchpad

    Quote Originally Posted by hwms View Post
    Thanks for the info. My find doesn't seem to work but for a little while. Now a question.. Do I have to do this enable/disable touchpad every time I boot my laptop or just once?
    Just once.

    And yes, it is a bit hard to find the setting.

    When you get into the touchpad settings, it isn't visible. Or, at least, it isn't visible for me. I have to click a ">" to move further to the right. I usually just maximize that settings window to make it easier to find.

    I did that setting when I first installed 42.3. I have not had to touch it since. And if I really want to use the touchpad, I can just unplug the mouse (or the mouse wireless receiver). I guess I would do that if traveling, and the mouse battery ran out.
    openSUSE Leap 15.1; KDE Plasma 5;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •