Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: GIMP 2.9.5

  1. #1

    Default GIMP 2.9.5

    This isn't the supported release but I have heard that it supports greater colour depth so thought I would have a look at it. The version I tried came from this repo

    https://build.opensuse.org/package/s...Sauerland/gimp

    The same repo also provided an updated GIMP python interface.

    When I launch it I get this error message
    Code:
     
    gimp
    gimp: symbol lookup error: gimp: undefined symbol: gimp_convert_dither_type_compat_get_type
    Can anyone suggest a fix?

    John
    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  2. #2

    Default Re: GIMP 2.9.5

    Still hoping some one knows a way round this but just in case some one tries to compile 2.9.4 it looks like that is a no can do as well. A more recent version of gegl is needed along with it's dev files. I found one from the same repo. Config ok but make gets into a loop.

    Us poor photo people have been waiting for a deeper colour depth version of the GIMP for a long long time.

    John
    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,977

    Default AW: GIMP 2.9.5

    This is, what I get:
    Code:
    gimp
    This is a development version of GIMP.  Debug messages may appear here.
    
    Missing fast-path babl conversion detected, Implementing missing babl fast paths
    accelerates GEGL, GIMP and other software using babl, warnings are printed on
    first occurance of formats used where a conversion has to be synthesized
    programmatically by babl based on format description
    
    *WARNING*: missing babl fast path(s) between formats "CIE LCH(ab) double" and "R'G'B' double"
    
    (gimp:15940): Gtk-WARNING **: Theme directory base/ of theme oxygen has no size field
    
    [file-darktable.c] trying to call 'darktable'
    [file-darktable.c] g_spawn_sync failed
    [file-darktable.c] error: Kindprozess »darktable« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
    [file-darktable.c] have_darktable: 0

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: GIMP 2.9.5

    Quote Originally Posted by ajohnw View Post
    This isn't the supported release but I have heard that it supports greater colour depth so thought I would have a look at it. The version I tried came from this repo

    https://build.opensuse.org/package/s...Sauerland/gimp

    The same repo also provided an updated GIMP python interface.

    When I launch it I get this error message
    Code:
     
    gimp
    gimp: symbol lookup error: gimp: undefined symbol: gimp_convert_dither_type_compat_get_type
    Can anyone suggest a fix?

    John
    -
    you probobly need to do a full vendor change to that reposetory
    http://download.opensuse.org/reposit...USE_Leap_42.2/
    tell us your repo list
    Code:
    zypper lr -d

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,977

    Default AW: GIMP 2.9.5

    you probobly need to do a full vendor change to that reposetory
    Better not......

    Better is to install all packages by Hand.

  6. #6

    Default Re: GIMP 2.9.5

    I am experiencing the exact same issue as the OP.
    I switched gegl to Sauerland repo too but that didn't fix the problem.

  7. #7

    Default Re: GIMP 2.9.5

    Fixed:

    I had to switch libgimp, lcms and babl to the other repo and now gimp works.

  8. #8

    Default Re: AW: GIMP 2.9.5

    Quote Originally Posted by Sauerland View Post
    This is, what I get:
    Code:
    gimp
    This is a development version of GIMP.  Debug messages may appear here.
    
    Missing fast-path babl conversion detected, Implementing missing babl fast paths
    accelerates GEGL, GIMP and other software using babl, warnings are printed on
    first occurance of formats used where a conversion has to be synthesized
    programmatically by babl based on format description
    
    *WARNING*: missing babl fast path(s) between formats "CIE LCH(ab) double" and "R'G'B' double"
    
    (gimp:15940): Gtk-WARNING **: Theme directory base/ of theme oxygen has no size field
    
    [file-darktable.c] trying to call 'darktable'
    [file-darktable.c] g_spawn_sync failed
    [file-darktable.c] error: Kindprozess »darktable« konnte nicht ausgeführt werden (Datei oder Verzeichnis nicht gefunden)
    [file-darktable.c] have_darktable: 0
    I managed to mend the configure dependencies with YAST. Some vendor changes. I concluded that this should be safe as they only seemed to relate to the GIMP. That might be because I am running KDE. My install is a clean 42,2 apart from Rawtherapee, Fotoxx and VLC. VLC is a beta from Packman. Codec's from the community site. I also installed LXDE via YAST so I have a mix of that and KDE on the desktop. I decided not to try and fix that but wait for 42.3 to come out. Currently it's too much trouble to get a clean LXDE and KDE desktops.

    Code:
    #  | Alias                               | Name                              | Enabled | GPG Check | Refresh
    ---+-------------------------------------+-----------------------------------+---------+-----------+--------
     1 | Perl_Development                    | Perl Development                  | No      | ----      | ----   
     2 | Varrious_files_systems              | Varrious files systems            | Yes     | (r ) Yes  | Yes    
     3 | download.nvidia.com-leap            | nVidia Graphics Drivers           | Yes     | (r ) Yes  | Yes    
     4 | http-download.opensuse.org-178b527f | openSUSE:Leap:42.2:Ports          | No      | ----      | ----   
     5 | http-download.opensuse.org-248bd027 | graphics                          | Yes     | (r ) Yes  | Yes    
     6 | http-download.opensuse.org-7b61e500 | multimedia:photo ######## Fotoxx  | No      | ----      | ----   
     7 | http-download.opensuse.org-87633179 | home:rawtherapee ############     | No      | ----      | ----   
     8 | openSUSE-42.2-0                     | openSUSE-42.2-0                   | No      | ----      | ----   
     9 | packman.inode.at-suse               | Packman Repository                | No      | ----      | ----   
    10 | repo-non-oss                        | openSUSE-Leap-42.2-Non-Oss        | Yes     | (r ) Yes  | Yes    
    11 | repo-oss                            | openSUSE-Leap-42.2-Oss            | Yes     | (r ) Yes  | Yes    
    12 | repo-source                         | openSUSE-Leap-42.2-Source         | No      | ----      | ----   
    13 | repo-update                         | openSUSE-Leap-42.2-Update         | Yes     | (r ) Yes  | Yes    
    14 | repo-update-non-oss                 | openSUSE-Leap-42.2-Update-Non-Oss | Yes     | (r ) Yes  | Yes
    Both Rawtherapee and Fotoxx updated from the graphics repo recently. Previously I have obtained them from the ones marked ########. YAST threw in various file systems when I removed swap.

    I'm not really capable of going any further than I have. I thought it might be worth trying 2.9.4 source from GIMP's site.

    Thanks for your efforts by the way.

    John
    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  9. #9

    Default Re: GIMP 2.9.5

    Quote Originally Posted by heyjoe View Post
    Fixed:

    I had to switch libgimp, lcms and babl to the other repo and now gimp works.
    I that a 2.9.4 compile or 2.9.5 from the software search? Also assume it's Sauerland's repo?

    John
    -
    Leap 42.2 KDE 5.26
    3.6gig Xeon, 64bit SATA Raid home - Linux Raid 1
    All software on a flash drive, SATA swap & Temp files,

  10. #10

    Default Re: GIMP 2.9.5

    Quote Originally Posted by ajohnw View Post
    I that a 2.9.4 compile or 2.9.5 from the software search? Also assume it's Sauerland's repo?

    John
    -
    I installed from here:

    https://software.opensuse.org/package/gimp

    then manually switched the mentioned packages to Sauerland.

    For some reason the zoom in/out and panning in the program are quite laggy btw. No idea why. Using GTX680 with nvidia drivers.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •