Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Leap 42.3 does not start with graphical environment

Hybrid View

  1. #1

    Default Leap 42.3 does not start with graphical environment

    Hello,

    I recently upgraded to Leap 42.3 and everything worked fine until the 1st (i think) time i shut down and started again. Graphical environment does not start, it only gets to Konsole and tty1. Not sure what this tty1 is. Any idea how to get the graphical enviroment back?

    Best,
    Vasilis

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    4,320

    Default AW: Leap 42.3 does not start with graphical environment

    What Graphic Card?

    What Driver for that?

    Is drm-kmp-default installed:
    as root:
    Code:
    rpm -q drm-kmp-default

  3. #3

    Default Re: AW: Leap 42.3 does not start with graphical environment

    Quote Originally Posted by Sauerland View Post
    What Graphic Card?

    What Driver for that?

    Is drm-kmp-default installed:
    as root:
    Code:
    rpm -q drm-kmp-default
    package drm-kmp-default is not installed

  4. #4

    Default Re: AW: Leap 42.3 does not start with graphical environment

    Quote Originally Posted by vpappasmet View Post
    package drm-kmp-default is not installed
    how can i install this?

  5. #5

    Default Re: AW: Leap 42.3 does not start with graphical environment

    Quote Originally Posted by vpappasmet View Post
    how can i install this?
    Hello, anyone?

  6. #6

    Default Re: Leap 42.3 does not start with graphical environment

    Code:
    sudo zypper in drm-kmp-default


    But better provide more information, like what graphics card you are using, as you were being asked already.
    Last edited by wolfi323; 09-Aug-2017 at 13:28.

  7. #7
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: Leap 42.3 does not start with graphical environment

    Code:
    sudo hwinfo --gfxcard
    loyalty returns to those who practice it

  8. #8

    Default Re: Leap 42.3 does not start with graphical environment

    Quote Originally Posted by V_idocq View Post
    Code:
    sudo hwinfo --gfxcard
    Onboard IGD
    Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
    Vendor: pci 0x8086 "Intel Corporation"
    Subvendor: pci 0x1043 "ASUSTek Computer Inc"
    Driver: i915
    Driver info #0:
    Driver Status: i915 is active

  9. #9

    Default Re: Leap 42.3 does not start with graphical environment

    Ok, so it is intel.

    Are you really sure that drm-kmp-default was not installed?
    How did you check?

    Did you try to install it?
    (although if it worked in 42.2, that's not really going to help...)

    Can you please post the file /var/log/Xorg.0.log?

  10. #10

    Default Re: Leap 42.3 does not start with graphical environment

    Quote Originally Posted by wolfi323 View Post
    Ok, so it is intel.

    Are you really sure that drm-kmp-default was not installed?
    How did you check?

    Did you try to install it?
    (although if it worked in 42.2, that's not really going to help...)

    Can you please post the file /var/log/Xorg.0.log?
    Re-activating this old thread, since I face the same problem andI find it hard to remember how I solved it (or partially solved it) last time. The problem started when I got an error of "Failed to load Kernel Modules".
    Following the discussion from above, the result from the command
    Code:
    rpm-q drm-kmp-default
    is
    Code:
    drm-kmp-default-4.9.33_k4.4.79_4-5.2x86_64
    drm-kmp-default-4.9.33_k4.4.120_45-10.2.x86_64

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •