Results 1 to 7 of 7

Thread: Problem installing Texmaker 5.0.1

Hybrid View

  1. #1

    Default Problem installing Texmaker 5.0.1

    Hello, everyone.

    I have quite a bit of a problem, whenever I try to install texmaker, it asks me to have qt 5.7 or greater on the system. I installed the qt 5.9.1 from the web installer given at qt page, and re-tried the installation process. Nothing happened, same error. After that I tried adding the directory where it got installed to the PATH environment, but then again, nothing happened.
    I've been searching for answers on how to get it to work, but I cant find anything. This was my last resource, since I think it's something easy, but I haven't figured out yet how to get it to work.

    In case anyone is wondering why I want the latest version of texmaker, it's due to the fact that I'm constantly writing, and the Live-preview would be helpful.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,807
    Blog Entries
    15

    Default Re: Problem installing Texmaker 5.0.1

    Hi and welcome to the Forum
    So openSUSE Leap 42.3 comes with version 4.5, I'm guessing you want version 5.0.1?

    As can be seen it's just been updated in the development repository (Publishing), but even here it's failing with the same issue....
    https://build.opensuse.org/package/s...shing/texmaker

    Where did you get the qt version from? The openSUSE Build Service?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Problem installing Texmaker 5.0.1

    Quote Originally Posted by malcolmlewis View Post
    Hi and welcome to the Forum
    So openSUSE Leap 42.3 comes with version 4.5, I'm guessing you want version 5.0.1?

    As can be seen it's just been updated in the development repository (Publishing), but even here it's failing with the same issue....
    https://build.opensuse.org/package/s...shing/texmaker

    Where did you get the qt version from? The openSUSE Build Service?
    Thanks for replying.
    I got the qt version from qt.io/downloads. And I followed the steps in there, also. But it didn't work at all. I've been trying for quite a while, but everything I do, doesn't seem to help.

  4. #4
    Join Date
    Mar 2015
    Location
    Viçosa, Brasil
    Posts
    263

    Default Re: Problem installing Texmaker 5.0.1

    Quote Originally Posted by CrashK View Post
    Thanks for replying.
    I got the qt version from qt.io/downloads. And I followed the steps in there, also. But it didn't work at all. I've been trying for quite a while, but everything I do, doesn't seem to help.
    I had the same problem once (but with another software). I suggest you take an look here:


    https://forums.opensuse.org/showthre...ersion-problem
    --
    Biostatistics and Data Science
    https://bio-data.github.io/

  5. #5
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Problem installing Texmaker 5.0.1

    Quote Originally Posted by CrashK View Post
    Thanks for replying.
    I got the qt version from qt.io/downloads. And I followed the steps in there, also. But it didn't work at all. I've been trying for quite a while, but everything I do, doesn't seem to help.
    you really shouldn't use Qt from qt.io as you might break something, you can get the latest qt from the kde:qt5 reposetory
    http://download.opensuse.org/reposit...USE_Leap_42.3/
    but that might require you to update plasma 5 too the latest 5.10.x version

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,262
    Blog Entries
    2

    Default Re: Problem installing Texmaker 5.0.1

    You're going to have to be more precise about, preferably providing links.
    - Where you're downloading from
    - What guide you're following.

    qt.io does not contain any links to apps built on qt. It only has links and documentation about the qt framework.

    If you go to the texmaker website, the following is the download page for Fedora RPM package which should likely work on openSUSE as well.
    http://www.xm1math.net/texmaker/download.html

    I can't imagine what guide you're following to install, but YaST or zypper should step you through installing this package letting you know what dependencies might be missing, and then you can use various methods to add repos which can provide packages for those dependencies.

    Or, if you don't mind using v4.5, it's immediately available which should install without extra work.
    You can also submit a "feature request" to https://bugzilla.opensuse.org asking the maintainer for Texmaker to update packages to the latest version from the Project.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,807
    Blog Entries
    15

    Default Re: Problem installing Texmaker 5.0.1

    Quote Originally Posted by tsu2 View Post
    Or, if you don't mind using v4.5, it's immediately available which should install without extra work.
    You can also submit a "feature request" to https://bugzilla.opensuse.org asking the maintainer for Texmaker to update packages to the latest version from the Project.

    TSU
    Hi
    Already spoke to one of the Maintainers on IRC, it has been updated to 5.0.1, but only builds for QT 5.7 (Tumbleweed/Factory) and later now;
    https://build.opensuse.org/package/s...shing/texmaker

    Or gets into a KDE build repo...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •