Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: yast>kernel settings will not open

  1. #1
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default yast>kernel settings will not open

    [im on plasma] if i click yast>kernel-settings it starts reading system settings, then the window just closes. I assume i have a malformed config file or such like? I did a start-menu search for 'kernel settings' which gives command shortcut xdg-su -c "/sbin/yast2 system_settings", but run from terminal gives no information. Thanks for any help.

  2. #2
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: yast>kernel settings will not open

    then i engaged my brain and tried again as root (both su and su-)
    Code:
    #su
    #/sbin/yast2 system_settings
    /usr/share/YaST2/include/hwinfo/routines.rb:43: warning: key "cache" is duplicated and overwritten on line 592 
    /usr/share/YaST2/include/hwinfo/routines.rb:343: warning: key "vendor_id" is duplicated and overwritten on lin
    e 652 
    /usr/share/YaST2/modules/StorageInit.rb:77: warning: constant ::Fixnum is deprecated
    [the window closed again]
    i then tried:
    Code:
    #su -
    #/sbin/yast2 system_settings
    /usr/share/YaST2/include/hwinfo/routines.rb:43: warning: key "cache" is duplicated and overwritten on line 592
    /usr/share/YaST2/include/hwinfo/routines.rb:343: warning: key "vendor_id" is duplicated and overwritten on line 652
    /usr/share/YaST2/modules/StorageInit.rb:77: warning: constant ::Fixnum is deprecated
    but this time the window opened?

  3. #3
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: yast>kernel settings will not open

    to bump my own thread, nobody has any ideas/intuitions?

  4. #4

    Default Re: yast>kernel settings will not open

    /var/log/YaST2/y2log should tell more about the crash.
    And there may be a signal file too in the same directory, IIRC.

    You may want to file a bug report though, see here for the required information:
    https://en.opensuse.org/openSUSE:Report_a_YaST_bug

    FWIW, it seems to work fine here on Leap 42.3...

  5. #5
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: yast>kernel settings will not open

    Quote Originally Posted by ndc33 View Post
    [im on plasma] if i click yast>kernel-settings it starts reading system settings, then the window just closes. I assume i have a malformed config file or such like? I did a start-menu search for 'kernel settings' which gives command shortcut xdg-su -c "/sbin/yast2 system_settings", but run from terminal gives no information. Thanks for any help.
    Having just read https://forums.opensuse.org/showthre...58#post2833158, i thought i'd have a look at that same YaST section. To my shock the identical misbehaviour you described also happens to mine. At that point i had not seen this current thread, so i laughed at the serendipity of me then reading your thread on the same problem. My TW [KDE] is 20170802.

  6. #6
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: yast>kernel settings will not open

    > To my shock the identical misbehaviour you described also happens to mine.
    thanks for feedback, so it looks like it might be a systematic rather than individual problem.

  7. #7
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: yast>kernel settings will not open

    Three more data points FYI... TW [KDE] versions 20170806 & 20170808 still / also don't solve it -- the same misbehaviour occurs. Conversely, in one of my older VMs, 20170725 does work properly. So, somewhere between 20170725 & 20170802, the problem arose.

    Oh, groan. I found another old VM, also 20170725, & it does not work properly. The YaST2 Kernel Settings window sometimes actually gets to 100%, other times only 50%, but either way then closes abruptly. So, this really only muddies the waters...

  8. #8
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: yast>kernel settings will not open

    Another data point: In TW [KDE] 20170730 it does open correctly, every time.

  9. #9
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: yast>kernel settings will not open

    since you have bisected and investigated the issue more than i, perhaps submit a bug report? (be sure to include (check) it works from terminal "su -" if you do)

  10. #10
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: yast>kernel settings will not open

    Quote Originally Posted by ndc33 View Post
    since you have bisected and investigated the issue more than i, perhaps submit a bug report? (be sure to include (check) it works from terminal "su -" if you do)
    I haven't ignored or forgotten this, but have been too busy to advance this... am still planning on doing it though, once i have time to. In the meantime, more info... every TW snapshot since my previous note, up to & including the current 20170821, continues to bomb out on that YaST module. However tonight when i did try it in said latest snapshot, it gave some new info prior to then aborting:


Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •