Results 1 to 5 of 5

Thread: Install 32bit libraries Leap 42.2 HELP

  1. #1

    Default Install 32bit libraries Leap 42.2 HELP

    Hi Guys,

    Am a newbie to linux fresh from windows, I chose opensuse beacuse it seems to work well on my PC. Long story short, I am trying to run MPLAX but it needs 32 bit libraries. It outputs the following :-

    bash: ./MPLAB.sh: No such file or directory
    gtool@linux-7wi8:~/Documents> sudo bash ./MPLABX.sh
    64 Bit, check libraries
    Check for 32 Bit libraries
    These 32 bit libraries were not found and are needed for MPLAB X to run:
    libexpat.so
    libX11.so
    libXext.so


    So guys how can I get the libexpat.so , libX11.so and libXext on my machine.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,616
    Blog Entries
    3

    Default Re: Install 32bit libraries Leap 42.2 HELP

    I'm currently running 42.3 Beta, so I cannot check if this works in 42.2.

    Open Yast Software Management.

    Select the "Patterns" view.

    I am seeing a pattern for "x86 runtime environment".

    Install that. It should give you the 32bit libraries.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: Install 32bit libraries Leap 42.2 HELP

    Otherwise search Yast's Softwaremanager for the mentioned libs. Or use zypper:
    Code:
    zypper se libexpat
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

    Unhappy Re: Install 32bit libraries Leap 42.2 HELP

    Quote Originally Posted by nrickert View Post
    I'm currently running 42.3 Beta, so I cannot check if this works in 42.2.

    Open Yast Software Management.

    Select the "Patterns" view.

    I am seeing a pattern for "x86 runtime environment".

    Install that. It should give you the 32bit libraries.
    I checked the box, but to no avail. It doesn't seem to install 32bit libraries.

    Please tell me how to do it right.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,273
    Blog Entries
    2

    Default Re: Install 32bit libraries Leap 42.2 HELP

    The following works...

    On a LEAP, first run the following in an elevated console, it'll install all your 32-bit libraries
    Code:
    zypper in compat-32bit libX11-6-32bit libX11-devel-32bit gcc-32bit libexpat1-32bit libXext6-32bit
    Then,
    Download the install binary, uncompress it and run the install script per the instructions on this page (no need to apply executable permissions)
    http://microchipdeveloper.com/mplabx:installation

    I don't expect that a simple 32-bit runtime environment is sufficient, this is a Development app so you need development libraries which aren't usually included in a simple runtime environment.

    Enjoy.
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •