Results 1 to 5 of 5

Thread: Cannot complete MyPhoneExplorer WinePrefix creation ONLY in my Tower.

  1. #1
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Cannot complete MyPhoneExplorer WinePrefix creation ONLY in my Tower.

    Hi

    This new thread is partly similar to, but importantly different than, my earlier thread https://forums.opensuse.org/showthre...nePrefix-in-TW which applies only to my Laptop, & is a different problem to the new problem in this new thread.

    As per the other thread, this command sequence successfully installed a complete & functional MyPhoneExplorer WinePrefix in Tumbleweed... on my Lappy's SSD, & in multiple VMs in my Tower.
    Code:
    1.   sudo zypper install --no-recommends wine   
    
    2.   WINEPREFIX=~/.wine-myphoneexplorer WINEARCH='win32' winecfg
    
    
            <<Two consecutive windows / dialogue boxes will appear after this command initially seems to have completed, each offering to download & install a missing component [Mono & Gecko respectively] - let them do this. Afterwards, close each window if still present.>>
    
    
    3.   WINEPREFIX=~/.wine-myphoneexplorer WINEARCH='win32' winetricks vb6run
    
    
    4.   WINEPREFIX=~/.wine-myphoneexplorer WINEARCH='win32' wine MyPhoneExplorer_Setup_v1.8.8.exe
             [before running that command, cd to directory holding the EXE]
             
    
    
            <<MPE should now be installed & runnable.>>

    In all those good installation examples [six of them], by the end of the procedure per my codebox above, each TW instance has a functional MPE installation that correctly launches from desktop icon or Application Menu launcher, & successfully displays my historical MPE data [stored in my /home... here i am NOT referring to the new data still on the phone].

    However for several days i have been, & still am, unable to also mimic those successes with a correct MPE WinePrefix installation directly in my Tower's SSD [ie, not a VM this time]. I have very carefully compared the Konsole zypper transcripts from the successful installations with the failed installation attempts in my Tower. I identified two points of departure, but i have no idea how to solve the fault.

    The first departure occurs during Step 2 [of the above codebox]. Here is the suspected problem [red highlight], followed by the good result from one of the VM installs:
    Code:
    linux-Tower:~> WINEPREFIX=~/.wine-myphoneexplorer WINEARCH='win32' winecfg
    wine: created the configuration directory '/home/gooeygirl/.wine-myphoneexplorer'
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
    err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
    err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
    err:ole:get_local_server_stream Failed: 80004002
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
    err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
    err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
    err:ole:get_local_server_stream Failed: 80004002
    fixme:ntdll:NtLockFile I/O completion on lock not implemented yet       <--- This is WRONG, & Mono+Gecko installs don't initiate.
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
    fixme:dwmapi:DwmIsCompositionEnabled 0x6d5d3018
    fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x6a0cb608, context 0x958690, init_notify 0, handle 0x118e794): stub
    wine: configuration in '/home/gooeygirl/.wine-myphoneexplorer' has been updated.
    Code:
    gooeygirl@linux-2zer:~> WINEPREFIX=~/.wine-myphoneexplorer WINEARCH='win32' winecfg
    wine: created the configuration directory '/home/gooeygirl/.wine-myphoneexplorer'
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
    err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
    err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
    err:ole:get_local_server_stream Failed: 80004002
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {00000131-0000-0000-c000-000000000046}
    err:ole:marshal_object couldn't get IPSFactory buffer for interface {6d5140c1-7436-11ce-8034-00aa006009fa}
    err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hres=0x80004002
    err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, 80004002
    err:ole:get_local_server_stream Failed: 80004002
    fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
    err:process:__wine_kernel_init boot event wait timed out
    gooeygirl@linux-2zer:~> fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    fixme:urlmon:InternetBindInfo_GetBindString not supported string type 20
    fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
    fixme:dwmapi:DwmIsCompositionEnabled 0x6d5d3018
    fixme:iphlpapi:NotifyIpInterfaceChange (family 0, callback 0x6a0cb608, context 0x9586a8, init_notify 0, handle 0x118e794): stub
    wine: configuration in '/home/gooeygirl/.wine-myphoneexplorer' has been updated.
    I know that both those outputs look ugly, but the second ["green"] one DOES eventually result in a good MPE installation. Hence i assess it to be significant that the first one ["red"] departs from the "good" output.


    The second departure i found occurs during Step 3 [of the initial codebox in this post]. Here is the suspected problem [red highlight], followed by the good result from one of the VM installs:
    Code:
    gooeygirl@linux-Tower:~> WINEPREFIX=~/.wine-myphoneexplorer WINEARCH='win32' winetricks vb6run
    Using winetricks 20170614-next - sha256sum: cf3126ae45052eba3a2586da03dd65bf2b38a8193da8f27ff3878cc23be77f07 with wine-2.13
    Parent pid 18140, child pid 18145
    
    Parent is shutting down, bye... and WINEARCH=win32
    installed_file1="C:\Program Files\Common Files
    Parent pid 17870, child pid 17875
    ------------------------------------------------------
    bug: w_metadata adobeair corrupt, might need forward slashes?
    ------------------------------------------------------
    gooeygirl@linux-Tower:~>
    Code:
    gooeygirl@linux-2zer:~> WINEPREFIX=~/.wine-myphoneexplorer WINEARCH='win32' winetricks vb6run
    Using winetricks 20170614-next - sha256sum: cf3126ae45052eba3a2586da03dd65bf2b38a8193da8f27ff3878cc23be77f07 with wine-2.13 and WINEARCH=win32
    Executing w_do_call vb6run
    Executing load_vb6run 
    Executing mkdir -p /home/gooeygirl/.cache/winetricks/vb6run
    Executing cd /home/gooeygirl/.cache/winetricks/vb6run
    Downloading https://download.microsoft.com/download/5/a/d/5ad868a0-8ecd-4bb0-a882-fe53eb7ef348/VB6.0-KB290887-X86.exe to /home/gooeygirl/.cache/winetricks/vb6run
    --2017-08-02 21:38:36--  https://download.microsoft.com/download/5/a/d/5ad868a0-8ecd-4bb0-a882-fe53eb7ef348/VB6.0-KB290887-X86.exe
    Resolving download.microsoft.com (download.microsoft.com)... 23.53.157.21, 2001:8006:3510:790::e59, 2001:8006:3510:791::e59
    Connecting to download.microsoft.com (download.microsoft.com)|23.53.157.21|:443... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 1064736 (1.0M) [application/octet-stream]
    Saving to: ‘VB6.0-KB290887-X86.exe’
    
    
    VB6.0-KB290887-X86.exe                          100%[====================================================================================================>]   1.01M   820KB/s    in 1.3s    
    
    
    2017-08-02 21:38:38 (820 KB/s) - ‘VB6.0-KB290887-X86.exe’ saved [1064736/1064736]
    
    
    Executing cd /home/gooeygirl
    Executing wine /home/gooeygirl/.cache/winetricks/vb6run/VB6.0-KB290887-X86.exe /T:C:\windows\Temp\_vb6run /c
    fixme:advapi:DecryptFileA ("C:\\windows\\Temp\\_vb6run\\", 00000000): stub
    Executing mv /home/gooeygirl/.wine-myphoneexplorer/dosdevices/c:/windows/temp/_vb6run/vbrun60sp6.exe /home/gooeygirl/.cache/winetricks/vb6run
    Executing cd /home/gooeygirl/.cache/winetricks/vb6run
    fixme:ole:DllRegisterServer stub
    gooeygirl@linux-2zer:~>


    My head is completely spinning. I cannot grasp how executing the identical commands in five TW VMs [in Tower], & one "real" SSD installation [=Lappy] succeed & give me a working MPE pgm, but following the identical procedure "for real" in Tower's SSD TW repeatedly fails. Does anyone have any insights please?

  2. #2
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Cannot complete MyPhoneExplorer WinePrefix creation ONLY in my Tower.

    Head still spinning. Have continued researching [useless]. Have continued trying to create this WP in my Tower's "real" TW across now several TW versions [in the hope that one might have fixed whatever is broken] - still no good; identical failure mode as above. Today there was a Wine update available in the repos -- still no improvement to the outcome.

    All this time my MPE WPs continue to work well in multiple oS TW VMs, in other Linux VMs, & in Lappy's "real" TW. I cannot fathom at all why my Tower's TW is allergic to it.

    In ongoing exasperation tonight i thought i'd try, once again, forgetting about creating the WinePrefix [which IS my preferred way] & instead installing PlayOnLinux from the repos & then try to install MPE within that [this method also used to work fine for me in Maui Linux, before i discovered the superiority of the WinePrefix method, & before i migrated to openSUSE].
    Code:
    gooeygirl@linux-Tower:~> sudo zypper in PlayOnLinux
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    The following NEW package is going to be installed:
      PlayOnLinux
    
    
    1 new package to install.
    Overall download size: 2.3 MiB. Already cached: 0 B. After the operation, additional 6.3 MiB will be used.
    Continue? [y/n/...? shows all options] (y): 
    Retrieving package PlayOnLinux-4.2.12-1.1.noarch                                                                            (1/1),   2.3 MiB (  6.3 MiB unpacked)
    Retrieving: PlayOnLinux-4.2.12-1.1.noarch.rpm ...............................................................................................[done (485.8 KiB/s)]
    Checking for file conflicts: ..............................................................................................................................[done]
    (1/1) Installing: PlayOnLinux-4.2.12-1.1.noarch ...........................................................................................................[done]
    gooeygirl@linux-Tower:~>
    Upon launch of PoL, this msg popped up:
    Code:
    PlayOnLinux is unable to find 32bits OpenGL libraries.
    
    
    You might encounter problem with your games
    As MPE is a 32 bit pgm, i assume that this error might be a problem. Does anyone know how to find those libraries pls?

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,814
    Blog Entries
    15

    Default Re: Cannot complete MyPhoneExplorer WinePrefix creation ONLY in my Tower.

    Quote Originally Posted by GooeyGirl View Post
    Head still spinning. Have continued researching [useless]. Have continued trying to create this WP in my Tower's "real" TW across now several TW versions [in the hope that one might have fixed whatever is broken] - still no good; identical failure mode as above. Today there was a Wine update available in the repos -- still no improvement to the outcome.

    All this time my MPE WPs continue to work well in multiple oS TW VMs, in other Linux VMs, & in Lappy's "real" TW. I cannot fathom at all why my Tower's TW is allergic to it.

    In ongoing exasperation tonight i thought i'd try, once again, forgetting about creating the WinePrefix [which IS my preferred way] & instead installing PlayOnLinux from the repos & then try to install MPE within that [this method also used to work fine for me in Maui Linux, before i discovered the superiority of the WinePrefix method, & before i migrated to openSUSE].
    Code:
    gooeygirl@linux-Tower:~> sudo zypper in PlayOnLinux
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    The following NEW package is going to be installed:
      PlayOnLinux
    
    
    1 new package to install.
    Overall download size: 2.3 MiB. Already cached: 0 B. After the operation, additional 6.3 MiB will be used.
    Continue? [y/n/...? shows all options] (y): 
    Retrieving package PlayOnLinux-4.2.12-1.1.noarch                                                                            (1/1),   2.3 MiB (  6.3 MiB unpacked)
    Retrieving: PlayOnLinux-4.2.12-1.1.noarch.rpm ...............................................................................................[done (485.8 KiB/s)]
    Checking for file conflicts: ..............................................................................................................................[done]
    (1/1) Installing: PlayOnLinux-4.2.12-1.1.noarch ...........................................................................................................[done]
    gooeygirl@linux-Tower:~>
    Upon launch of PoL, this msg popped up:
    Code:
    PlayOnLinux is unable to find 32bits OpenGL libraries.
    
    
    You might encounter problem with your games
    As MPE is a 32 bit pgm, i assume that this error might be a problem. Does anyone know how to find those libraries pls?
    Hi
    See what ones are installed on a working system vs a non-working one...
    Code:
    zypper se -i *-32bit
    Same video cards and drivers on a working vs non-working?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Cannot complete MyPhoneExplorer WinePrefix creation ONLY in my Tower.

    Not unexpectedly, given that error msg, the installation failed ... the installer locked up here:




    On a second attempt, it locked-up here:




    On the third & final attempt it locked up as per the first pic.

    And yet MPE WPs work well in all Tower's VMs, + Lappy's real TW. This is just bewildering.

  5. #5
    Join Date
    Jun 2017
    Location
    Australia
    Posts
    582

    Default Re: Cannot complete MyPhoneExplorer WinePrefix creation ONLY in my Tower.

    Thank you very much Malcolm. I began investigating your suggestions when... drumroll... i suddenly had a new idea of something else to investigate, & ... this serendipitous new idea enabled me to solve the problem completely. I'm genuinely thrilled about this!

    I use FireJail, which i deliberately did not mention in my original posts coz it never occurred to me that it might be a causal factor. I use dedicated FJ profiles for each of my primary pgms, but additionally there is a subsidiary function in FireJail, which is optional:
    Code:
    sudo firecfg
    https://firejail.wordpress.com/features-3/man-firecfg/
    DESCRIPTION Firecfg is the desktop configuration utility for Firejail software. The
    utility creates several symbolic links to firejail executable. This
    allows the user to sandbox applications automatically, just by clicking
    on a regular desktop menus and icons.

    The symbolic links are placed in /usr/local/bin. For more information, see DESKTOP INTEGRATION section in man 1 firejail.
    Unrealised by me until today, this subsidiary function was interfering with Wine. It was not blocking it in toto [coz in that case i'd have realised what was going on many weeks ago], but it was blocking certain functions of Wine. This invisible sabotage was what was causing PoL to stall when trying to install MPE in it, AND was what was causing that incomprehensible failure mode every time i tried to create Tower's MPE WinePrefix.

    The solution was unbelievably easy... simply remove the Wine entry from /usr/local/bin. With that done, PoL then happily completed the MPE installation, & better yet [given it's my preferred method] the WinePrefix was properly created. In PoL thereafter, MPE crashes on launch due to some missing dependencies... i probably could track each one down & solve them, but i didn't bother once i discovered my MyPhoneExplorer WinePrefix is now happy.

    The best news of all: not only can i now launch MPE natively within my oS TW, but to my delight... it successfully Syncs with my Android phone. No longer will i need to use one of my VMs when i need to Sync.

    It's been painful getting here, but i'm so pleased that it's finally all good*.


    *Paradoxically, in my slightly older parallel thread https://forums.opensuse.org/showthre...nePrefix-in-TW for my Lappy, Synch still fails. However given that my Tower is my primary pc, today's success is a major step forward.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •