Results 1 to 7 of 7

Thread: Installing NVIDIA drivers

  1. #1
    Join Date
    Jun 2016
    Posts
    26

    Question Installing NVIDIA drivers

    Hello,
    I just installed Leap 42.3 and want to install appropriate NVIDIA drivers. I tried the nouveau driver on Tumbleweed on the exact same hardware before and had screen tearing that I could fix by installing NVIDIA drivers. Now with Leap I wanted to try out the easy way to install the driver and had a look at the NVIDIA drivers entry on our wiki[0]. I followed the procedure up to the point where I should install new recommended packages. Instead of getting offered NVIDIA drivers, only nouveau drivers were recommended.

    Graphics card:
    Code:
    linux-9twv:~ # lspci -nn | grep VGA 
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK104 [GeForce GTX 670] [10de:1189] (rev a1)
    What I have done:
    Code:
    linux-9twv:~ # zypper addrepo --refresh http://http.download.nvidia.com/opensuse/leap/42.3 NVIDIA
    Adding repository 'NVIDIA' .............................................................[done]
    Repository 'NVIDIA' successfully added
    
    URI         : http://http.download.nvidia.com/opensuse/leap/42.3
    Enabled     : Yes                                               
    GPG Check   : Yes                                               
    Autorefresh : Yes                                               
    Priority    : 99 (default priority)                             
    
    Repository priorities are without effect. All enabled repositories share the same priority.
    linux-9twv:~ # zypper ref
    Retrieving repository 'NVIDIA' metadata ---------------------------------------------------[\]
    
    New repository or package signing key received:
    
      Repository:       NVIDIA                                      
      Key Name:         NVIDIA Corporation <linux-bugs@nvidia.com>  
      Key Fingerprint:  9B763D49 D8A5C892 FC178BAC F5113243 C66B6EAE
      Key Created:      Thu Jun 15 18:13:18 2006                    
      Key Expires:      (does not expire)                           
      Rpm Name:         gpg-pubkey-c66b6eae-4491871e                
    
    
    Do you want to reject the key, trust temporarily, or trust always? [r/t/a/? shows all options] (r): a
    Retrieving repository 'NVIDIA' metadata ................................................[done]
    Building repository 'NVIDIA' cache .....................................................[done]
    Repository 'openSUSE-Leap-42.3-Non-Oss' is up to date.                                        
    Repository 'openSUSE-Leap-42.3-Oss' is up to date.                                            
    Retrieving repository 'openSUSE-Leap-42.3-Update' metadata .............................[done]
    Building repository 'openSUSE-Leap-42.3-Update' cache ..................................[done]
    Repository 'openSUSE-Leap-42.3-Update-Non-Oss' is up to date.                                 
    All repositories have been refreshed.
    linux-9twv:~ # zypper install-new-recommends
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    The following 6 NEW packages are going to be installed:
      Mesa-dri-nouveau gimp-help-en_GB libvdpau_nouveau poppler-data unrar xf86-video-nouveau
    
    6 new packages to install.
    Overall download size: 28.4 MiB. Already cached: 6.6 MiB. After the operation, additional 67.1
    MiB will be used.
    Continue? [y/n/...? shows all options] (y): n
    I know I could manually install nvidia drivers from the new repo, but I wonder why those were not recommended. Anyway, this is not how it is supposed to go according to the wiki. Any idea where the problem lies?


    [0] - https://en.opensuse.org/SDB:NVIDIA_drivers

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    1,202

    Default Re: Installing NVIDIA drivers

    Maybe you stumbled on https://bugzilla.suse.com/show_bug.cgi?id=1044816 ?
    Try uninstalling drm-kmp-default, reboot and run mkinitrd as suggested in comment #13 on that bug report; then manually install the nvidia driver from the Nvidia repo.
    The problem was highlighted in the Release Notes (see par. 1.4 at https://doc.opensuse.org/release-not...USE/Leap/42.3/ )
    Main: Leap 42.2 Gnome on i7 4720HQ + Geforce GTX960M
    Test: Leap 42.3 (& others) on Core2Duo + GM965

  3. #3
    Join Date
    Jun 2016
    Posts
    26

    Default Re: Installing NVIDIA drivers

    The release notes say that is only needed for installation via the nvidia*.run file. I don't want to go that route.
    If you install the RPMs provided by Nvidia, you will not be affected by this issue, because in that case the package drm-kmp-default is replaced during the driver installation automatically.
    This is what I want to do and I will do it by manually selecting the packages if needed. However, the wiki entry says the correct driver should be automatically be pulled via
    Code:
    zypper install-new-recommends
    which does not seem to be the case for me (see zypper output in post 1). I wonder if that is true for other NVIDIA users and if so we should edit the wiki accordingly.
    I guess my question actually is if this is "normal" behaviour.

  4. #4

    Default Re: Installing NVIDIA drivers

    All I can add is that you're not the only one. I had the same behavior- the "easy" way to install Nvidia drivers described at the link you gave above (https://en.opensuse.org/SDB:NVIDIA_drivers) worked fine in 42.2, but not in 42.3 (and like you I prefer to use that method if possible as opposed to installing the drivers direct from Nvidia).

    It seems surprising to me that others have not also reported having this problem. Maybe most others are just using Nouveau, or installing the drivers direct from Nvidia. But this isn't "normal" behavior according to the wiki, and it's not the same behavior as 42.2. I would think that at least some others at some point would be confused that the wiki instructions don't work.

  5. #5

    Default Re: Installing NVIDIA drivers

    Quote Originally Posted by larryherman View Post
    All I can add is that you're not the only one. I had the same behavior- the "easy" way to install Nvidia drivers described at the link you gave above (https://en.opensuse.org/SDB:NVIDIA_drivers) worked fine in 42.2, but not in 42.3 (and like you I prefer to use that method if possible as opposed to installing the drivers direct from Nvidia).

    It seems surprising to me that others have not also reported having this problem. Maybe most others are just using Nouveau, or installing the drivers direct from Nvidia. But this isn't "normal" behavior according to the wiki, and it's not the same behavior as 42.2. I would think that at least some others at some point would be confused that the wiki instructions don't work.
    I have not updated from Leap 42.2 to 42.3 yet. I'm still using 42.2 but I am having trouble with installing the latest driver from Nvidia (384.59) using the 'easy way' (which is the way I always use). After reboot I just get a black screen. I've had to boot from a historical snapshot of the system when it was using 375.66 and then do a snapper rollback. For the time being I've locked down the working 375.66 driver (installed the easy way) and I am holding off moving to Leap 42.3 until there is some resolution of the issue with Nvidia driver 384.59 - at least with the version in the repositories for 'easy' installation.

  6. #6

    Default Re: Installing NVIDIA drivers

    Quote Originally Posted by PingooseCovert View Post
    I have not updated from Leap 42.2 to 42.3 yet. I'm still using 42.2 but I am having trouble with installing the latest driver from Nvidia (384.59) using the 'easy way' (which is the way I always use). After reboot I just get a black screen. I've had to boot from a historical snapshot of the system when it was using 375.66 and then do a snapper rollback. For the time being I've locked down the working 375.66 driver (installed the easy way) and I am holding off moving to Leap 42.3 until there is some resolution of the issue with Nvidia driver 384.59 - at least with the version in the repositories for 'easy' installation.
    Just to report that 384.59-31.1 now available from the nvidia repository installs OK (the easy way).

  7. #7
    Join Date
    Nov 2014
    Location
    Argentina
    Posts
    111

    Default Re: Installing NVIDIA drivers

    I had the similar problem after a fresh install of NVIDIA RPMs from the official openSUSE repository (https://download.nvidia.com/opensuse/leap/42.3).

    After installing x11-video-nvidiaG04, nvidia-gfxG04-kmp-default ,nvidia-computeG04, nvidia-glG04, and rebooting, I had a black screen (mouse worked but SDDM crashed).

    I fixed this by reverting to a previous snapshot (without NVIDIA installed) and uninstalling drm-kmp-default + running mkinitrd first, then reboot.

    After this I installed the NVIDIA driver and after a second reboot everything was OK.

    I added this comments in https://bugzilla.suse.com/show_bug.cgi?id=1044816

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •