Results 1 to 4 of 4

Thread: kde update causes CPU overheating: plasmashell hogging resources

  1. #1
    Join Date
    Jul 2013
    Location
    Whitley Bay, Tyne & Wear, United Kingdom.
    Posts
    182

    Default kde update causes CPU overheating: plasmashell hogging resources

    Using KDE after updating tumbleweed recently, I noticed the CPU in overdrive and plasmashell using 90% of it. also temperature reaching 80C and above.
    I've used the system monitor to see what process was using so much, and it's plasmashell.

    Any idea what I should do?

    GNOME 3.24 is working really fine and resource usage and cpu temps are completely normal. However, I prefer KDE to GNOME and would like to continue using it.

    details of process are:
    Code:
    Process 1850 - plasmashell
    
    Summary
    
    The process plasmashell (with pid 1850) is using approximately 165.4 MB of memory.
    It is using 153.9 MB privately, 56.0 KB for pixmaps, and a further 81.2 MB that is, or could be, shared with other programs.
    Dividing up the shared memory between all the processes sharing that memory we get a reduced shared memory usage of 11.4 MB. Adding that to the private and pixmap usage, we get the above mentioned total memory footprint of 165.4 MB.
    Library Usage
    
    The memory usage of a process is found by adding up the memory usage of each of its libraries, plus the process's own heap, stack and any other mappings, plus the stack of its 7 threads. 
    Private
    more
    119428 KB    [heap]
    16828 KB    /drm mm object (deleted)
    844 KB    /home/john/.cache/plasma_theme_Breath-Aurora_v0.2.0.kcache
    576 KB    /usr/bin/plasmashell
    492 KB    /usr/lib64/qt5/qml/org/kde/plasma/private/kicker/libkickerplugin.so
    Shared
    more
    5444 KB    /usr/lib64/dri/i965_dri.so
    4560 KB    /usr/lib64/libQt5Gui.so.5.9.1
    4196 KB    /usr/lib64/libQt5Core.so.5.9.1
    3372 KB    /usr/lib64/libQt5Qml.so.5.9.1
    3216 KB    /usr/lib64/libQt5Quick.so.5.9.1
    Totals
    
    Pixmap    56 KB    (Might be stored in the graphics card's memory)
    Private    157636 KB    (= 15604 KB clean + 142032 KB dirty)
    Shared    83156 KB    (= 80796 KB clean + 2360 KB dirty)
    Rss    240792 KB    (= Private + Shared)
    Pss    169312 KB    (= Private + Shared/Number of Processes)
    Swap    0 KB
    Full Details
    
    Information about the complete virtual space for the process is available, with sortable columns. An empty filename means that it is an anonymous mapping.
    Both the MMU page size and the kernel page size are 4 KB.
    For years already, happily using
    Tumbleweed - Plasma 5, GNOME, i3

  2. #2

    Default Re: kde update causes CPU overheating: plasmashell hogging resources

    Are you using a wallpaper "slideshow" maybe?
    That's known to cause such problems, set a static wallpaper to "fix" it.

    Other than that, try on a fresh user account if it has the same problem, and if yes, try to remove Plasmoids on the old account one by one to find the culprit.

  3. #3
    Join Date
    Jul 2013
    Location
    Whitley Bay, Tyne & Wear, United Kingdom.
    Posts
    182

    Default Re: kde update causes CPU overheating: plasmashell hogging resources

    Quote Originally Posted by wolfi323 View Post
    Are you using a wallpaper "slideshow" maybe?
    That's known to cause such problems, set a static wallpaper to "fix" it.
    yeah, I knew about that one already... No I'm using static wallpaper

    Quote Originally Posted by wolfi323 View Post
    Other than that, try on a fresh user account if it has the same problem, and if yes, try to remove Plasmoids on the old account one by one to find the culprit.
    OK, I'll try that and let you know
    For years already, happily using
    Tumbleweed - Plasma 5, GNOME, i3

  4. #4
    Join Date
    Jul 2013
    Location
    Whitley Bay, Tyne & Wear, United Kingdom.
    Posts
    182

    Default Re: kde update causes CPU overheating: plasmashell hogging resources

    Quote Originally Posted by johnoshock View Post
    yeah, I knew about that one already... No I'm using static wallpaper


    OK, I'll try that and let you know
    I tried all that and it was indeed a plasmoid.! .... strangely enough, the digital clock did it!!
    It was probably some custom setting, but I don't know which. I simply removed it and added a fresh one using the default settings. Everything back to normal again. Thanks Wolfi.
    For years already, happily using
    Tumbleweed - Plasma 5, GNOME, i3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •