Results 1 to 6 of 6

Thread: wondershaper start

  1. #1

    Default wondershaper start

    I downloaded wondershaper because i want limit my wifi card to 600/30kb/s. In debian OS i type only: wondershaper wlan0 4800 300 and all works. In opensuse this not works this way.
    I know that there are 2 files
    /etc/init.d/wondershaper
    /etc/sysconfig/wondershaper

    First is initialize file and 2 configuration for wondershaper.
    Changed this to:
    WSHAPER_DEV="wlp2s0f0"
    WSHAPER_DOWNLINK="4800"
    WSHAPER_UPLINK="300"
    ...

    and now i have problem with start wondershaper service.
    ja@ja-pc:~> sudo /etc/init.d/wondershaper start
    [sudo] password for root:
    redirecting to systemctl start wondershaper.service
    Failed to start wondershaper.service: Unit wondershaper.service not found.
    ja@ja-pc:~>

    Can you help me ?

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: wondershaper start

    Wondershaper does not have a .service file, you need to start it either with; ​sudo rcwondershaper start or sudo /etc/init.d/wondershaper start

    Looking at the SysV init file, it should be trivial to convert it to a service file but I'm guessing it's not that popular of a script so it's on low priority.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: wondershaper start

    Well, I was curious about this and tested myself - it seems that the script only works if you su to root, enter /etc/init.d with cd and then run ./wondershaper start

    Prolly the script has some issues and hasn't been updated in eons.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  4. #4

    Default Re: wondershaper start

    thanks for reply.

    Yast helped me.
    Yast -> Service-Manager -> enable and start wondershaper
    Now works and if i want change download upload then i need only edit /etc/sysconfig/wondersharper file
    WSHAPER_DOWNLINK="1000" = 1000 kbps = 125kB/s = 125 * 8
    WSHAPER_UPLINK="300" = 300 kbps = 37,5kB/s = 37,5*8

    All you need to do is:
    1. download wondersharper
    2. edit configuration file: /etc/sysconfig/wondersharper
    3. start service: Yast -> Service-Manager -> enable and start wondershaper

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,855
    Blog Entries
    15

    Default Re: wondershaper start

    Quote Originally Posted by Miuku View Post
    Well, I was curious about this and tested myself - it seems that the script only works if you su to root, enter /etc/init.d with cd and then run ./wondershaper start

    Prolly the script has some issues and hasn't been updated in eons.
    Hi
    Just configure and start stop as a systemd service....
    Code:
    systemctl status wondershaper.service
    
    systemctl start wondershaper.service
    ● wondershaper.service - LSB: wondershaper providing QOS
       Loaded: loaded (/etc/init.d/wondershaper; generated; vendor preset: disabled)
       Active: inactive (dead)
         Docs: man:systemd-sysv-generator(8)
    
    systemctl status wondershaper.service
    ● wondershaper.service - LSB: wondershaper providing QOS
       Loaded: loaded (/etc/init.d/wondershaper; generated; vendor preset: disabled)
       Active: active (exited) since Wed 2017-07-19 10:05:10 CDT; 1s ago
         Docs: man:systemd-sysv-generator(8)
      Process: 11252 ExecStart=/etc/init.d/wondershaper start (code=exited, status=0/SUCCESS)
    
    systemctl enable wondershaper.service
    Last edited by malcolmlewis; 19-Jul-2017 at 08:11. Reason: fix typo from status to start
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,004

    Default Re: wondershaper start

    For reasons unknown, that didn't seem to work for me and it also complained about the lack of a .service file until I uninstalled, reinstalled and systemctl'd it once.

    Oh rightie then :/
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •