I have had a problem for months using XFCE workspace switcher with four workspaces on my laptop with an external monitor connected.The basic operation is fine, with the external screen set up to be beside the laptop screen, and me able to switch between them using the switcher. The problem has been that the content of both screens intermittently changes to reflect the content of previously open windows. I have had to move to another workspace and then back to see the correct content of the workspace on the screens. Sometimes the correct content persists for only a few seconds before changing to incorrect windows. Moving or dragging the mouse over a window will usually restore at least part of the window to its correct content.

I have not known how to describe the problem and previous searches have not found anyone else experiencing the problem, until yesterday when I found a reference in a forum for a different Linux version where the writer suggested these steps:
Settings -> Settings Manager -> Window Manager Tweaks -> Compositor
where I turned off "Enable display compositing"

This work-around has solved my problem.

My computer is running an up-to-date version of Leap 42.2. It is a Toshiba Satellite S50D-A. The problem is found on my other much older Toshiba laptop as well, and it was present in 42.1.

I have been unable to isolate any state of the machine which brings the fault on. The machine can be heavily or lightly loaded, have many or few windows open in different workspaces. Running "top" does not indicate any process consuming many resources. The only certain way of bringing the fault on has been to run a website in Firefox where there are scrolling images being displayed. This is sufficient to bring the fault on but not necessary.