Results 1 to 6 of 6

Thread: Problem mit MP4 im HTML5 Media-Element in Firefox

  1. #1

    Default Problem mit MP4 im HTML5 Media-Element in Firefox

    Hallo,
    auf dem PC kann ich MP4 Videos problemlos abspielen. Dazu habe ich den Fluendo Codec Pack gekauft und installiert. Leider kann ich aber keine MP4-Videos abspielen, die im HTML5 Media-Element eingebettet sind. Das kann ich wie folgt feststellen:
    • Auf die Testseite gehen: https://www.w3schools.com/html/tryit...tryhtml5_video
    • Das Video spielt problemlos.
    • Nun die Zeile <source src="mov_bbb.ogg" type="video/ogg"> entfernen, sodass nur noch MP4 eingebunden ist und den Code mit dem Run Button starten.
    • Ich bekomme folgenden Fehler angezeigt: Kein Video mit unterstütztem Format oder MIME-Typ gefunden

    Ich habe bereits den Fluendo Support angeschrieben. Der hat mich darauf hingewiesen, dass gstreamer in Firefox nicht mehr unterstützt wird.

    Hat jemand vielleicht Erfahrung damit? Ich kann es mir nicht ganz erklären warum das nicht funktioniert. Der MP4-Codec ist ja ordnungsgemäß installiert, da ich alle MP4-Dateien abspielen kann. Und wenn Firefox tatsächlich nicht mehr gstreamer unterstützt, wurde tatsächlich keine Alternative geschaffen?

  2. #2

    Default Re: Problem mit MP4 im HTML5 Media-Element in Firefox

    Ich habe die Frage auch mal in das offizielle Firefox Forum eingestellt. Vielleicht gibt es dort Ideen.

    https://www.camp-firefox.de/forum/vi...p?f=1&t=121094

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,892

    Default AW: Problem mit MP4 im HTML5 Media-Element in Firefox

    Hast du alle Codecs beschrieben wie in den ersten Beiträgen im englischsprachigen Forum ----Multimedia installiert?

    Hier funktioniert das alles ohne gekaufte fluendo-Codecs....
    Code:
    zypper se -si fluendo
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                  | Typ   | Version | Arch   | Repository                       
    ---+-----------------------+-------+---------+--------+----------------------------------
    i+ | gstreamer-fluendo-mp3 | Paket | 21-2.1  | x86_64 | openSUSE-Leap-42.2-Update-Non-Oss

  4. #4

    Default Re: AW: Problem mit MP4 im HTML5 Media-Element in Firefox

    Quote Originally Posted by Sauerland View Post
    Hast du alle Codecs beschrieben wie in den ersten Beiträgen im englischsprachigen Forum ----Multimedia installiert?

    Hier funktioniert das alles ohne gekaufte fluendo-Codecs....
    Vielen Dank für den Hinweis! Vor etwa 2 Jahren habe etwas ähnliches versucht. Da hatte ich aber dann massiv Probleme mit jeglichen MP4 Dateien.
    Gerade habe ich mal diese Anleitung befolgt, und siehe da, es funktioniert! Ich habe zuvor die zugekauften Fluendo Codecs aber nicht entfernt, ich hoffe das macht keine Probleme.

    Ich hätte noch 2 Fragen bezüglich der Anleitung:
    • Bei dem Installationsprozess wurde mir angezeigt, dass ein (Anzahl 1) Fehler aufgetreten ist. Leider fehlte die Angabe wo. Kann man das irgendwie herausfinden?
    • Den Schritt open Yast > Software Management and Apply the Package Switcher on Packman konnte ich nicht ganz nachvollziehen. Die Einstellung dazu habe ich nicht gefunden. Der dort angeführte Link für weitere Informationen ist leider abgelaufen. Wie ist das gemeint?

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,892

    Default AW: Problem mit MP4 im HTML5 Media-Element in Firefox

    Den Schritt open Yast > Software Management and Apply the Package Switcher on Packman konnte ich nicht ganz nachvollziehen. Die Einstellung dazu habe ich nicht gefunden. Der dort angeführte Link für weitere Informationen ist leider abgelaufen. Wie ist das gemeint?

  6. #6

    Default Re: Problem mit MP4 im HTML5 Media-Element in Firefox

    Vielen Dank!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •