Results 1 to 8 of 8

Thread: XFCE Directory Menu plugin "open in terminal" fails

  1. #1

    Default XFCE Directory Menu plugin "open in terminal" fails

    I am a new user of Tumbleweed, coming from XUbuntu and I must say that I am quite pleased with all this very recent software just working.

    One problem that I have found though is that when I try to open a folder in a terminal from the Directory Menu plugin I get a "Failed to execute child" dialog. When I close the dialog an empty, unusable terminal opens.

    The Places plugin works correctly, opening a terminal in the correct folder.

    Mike

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,924
    Blog Entries
    2

    Default Re: XFCE Directory Menu plugin "open in terminal" fails

    Just checked my fully updated XFCE/Tumbleweed,

    Using the Thunar File Manager,
    I can rt-click on any directory icon and open a Terminal at that location without a problem.

    Are you using some other File Manager (Thunar is the default installed)?

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: XFCE Directory Menu plugin "open in terminal" fails

    Thank you for trying to verify my issue.

    You can add items to your panels. There are two items which you can add which navigate your filesystem.

    One is called Places, which when clicked shows shortcuts. You can right-click on any of your shortcuts and have the option of either opening a Thunar window there or a terminal. I believe that this one is in the default panel. It works properly.

    The other is called Directory Menu, which you have to add and allows you to navigate via a tree. This one is giving me the problem, which appears to be a permissions issue.

    A Thunar window, as you said, also works flawlessly.

    Actually, you can select "Open Folder" instead of "Open in Terminal" in Directory Menu and it will open a Thunar window which you can use to open a terminal just fine. It's just the "Open in Terminal" option which fails.

    I have also tried temporarily disabling AppArmor to see if that was causing the problem, but no, there is no change in behavior.

    Mike

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,924
    Blog Entries
    2

    Default Re: XFCE Directory Menu plugin "open in terminal" fails

    I've been able to open a Terminal using Thunar in all locations, not just Places.
    And, just in case there was a permissions issue I also tested locations outside /home... Those locations opened read-only without any problem.

    Have you upgraded your TW?
    You should do it at least once after installation, and I would generally recommend without the "no-vendor-change" option, then after that with that option if you wish.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5

    Default Re: XFCE Directory Menu plugin "open in terminal" fails

    Yes, tsu2, I have updated frequently using "sudo zypper -vvv dup --no-allow-vendor-change", which I understand is the recommended way to update.

    I'm not sure that I'm explaining myself properly. Thunar works as expected regardless of where I try to open either a terminal or a folder. My issue is opening a terminal in any folder using the Directory Menu plugin in the taskbar. When I attempt to open a terminal in any given folder, even my home folder. The popup says "Failed to execute child process". Opening a terminal in the same folder using other methods, for example Thunar or the Places plugin, works.

    I suspect that it's some minor bug in the plugin, but would like to have it verified before filing a bug report. Could you verify for me please that you are successful in opening a terminal using the Directory Menu plugin of the taskbar rather than from Thunar? If you can, then it would indicate a problem in my setup rather than a bug in the plugin.

    Mike

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,924
    Blog Entries
    2

    Default Re: XFCE Directory Menu plugin "open in terminal" fails

    Maybe different, maybe not.
    I rt-clicked on a directory icon, then selected the "Open Terminal" option.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Default Re: XFCE Directory Menu plugin "open in terminal" fails

    If you're right-clicking then you're not in the "Directory Menu" plugin.

    To load the plugin you have to right-click on your taskbar, select "Panel" and "Add New Items". "Directory Menu" should be one of the options. Highlight it and click "Add". This will add it to your taskbar.

    Left clicking on it will show the "Open Folder" and "Open in Terminal" options followed by a seperator and list of the folders in your home folder with a right arrow to the right of each subfolder. Hovering over a subfolder will give you the same menu for that subfolder.

    You can remove it at anytime by right-clicking on that icon and selecting "Remove".

    Mike

  8. #8

    Default Re: XFCE Directory Menu plugin "open in terminal" fails

    Doing a little more digging shows that a similar bug happened in Fedora a while back. https://bugzilla.redhat.com/show_bug.cgi?id=748226

    In this case, changing the Preferred Terminal app to gtkiterm lets it work, although XTerm doesn't.

    I think I'll file a bug report.

    Thanks for the help.

    Mike

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •