Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: No ethernet after upgrade from 42.1

  1. #1
    Join Date
    Aug 2008
    Location
    Reykjavik, Iceland
    Posts
    75

    Default No ethernet after upgrade from 42.1

    After removing all repos other than the OSS and Update, I ran the upgrade. After a reboot I can't get the ethernet to work again. I have a (sorry, typing by hand):

    Code:
    lspci -nnk
    Enthernet controller [0200]: Qualcomm Atheros AR8161 Gigabit Ethernet [1969:1091] (rev 10)
    .
    Kernel driver in use: alx
    Kernel modules: alx
    and

    Code:
    modinfo alx
    filename:  /lib/modules/4.4.74-18.20-default/kernel/drivers/net/ethernet/atheros/alx/alx.ko
    .
    .
    .
    depends: mdio
    intree:     Y
    vermagic: 4.4.74-18.20-default SMP mod_unload modversions
    .
    .
    So I think all this is fine. If I check

    Code:
    systemctl status network
    NetworkManager.service - Network Manager
    Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor or preset: disabled)
    Active: active (running) since ...
    Main PID : 968 ...
    .
    .
    CGroup: /system.slice/NetworkManager.service
                 968 /usr/bin/NetworkManager --no-daemon
    .
    .
    Then there is bunch indicating that eth1 has been found and linked. This seems to be the right card (right MAC) but it used to be called eth0 before the upgrade.

    If I try to ping
    Code:
    ping 192.168.191.1
    connect: Network is unreachable
    So, all this is a little bit out of my league. If anyone has any good ideas they will be most appreciated!

    Cheers!

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,820

    Default AW: No ethernet after upgrade from 42.1

    As root:
    Code:
    journalctl -b | grep -Ei 'network|alx|eth'
    Code:
    ifconfig -a

  3. #3
    Join Date
    Aug 2008
    Location
    Reykjavik, Iceland
    Posts
    75

    Default Re: No ethernet after upgrade from 42.1

    Not really sure what all this means, is it my windows mounted drives that are somehow causing this?

    Code:
    journalctl -b | grep -Ei 'network|alx|eth'
    
    Jul 11 15:49:49 skrofa systemd-udevd[204]: Network interface NamePolicy= disabled by default.
    Jul 11 15:49:49 skrofa systemd-udevd[204]: Network interface NamePolicy= disabled by default.
    Jul 11 15:49:50 skrofa kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT1._GTF] (Node ffff88018fccc388), AE_NOT_FOUND (20150930/psparse-542)
    Jul 11 15:49:50 skrofa kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT1._GTF] (Node ffff88018fccc388), AE_NOT_FOUND (20150930/psparse-542)
    Jul 11 15:49:50 skrofa kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT0._GTF] (Node ffff88018fccc400), AE_NOT_FOUND (20150930/psparse-542)
    Jul 11 15:49:50 skrofa kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT3._GTF] (Node ffff88018fccc298), AE_NOT_FOUND (20150930/psparse-542)
    Jul 11 15:49:50 skrofa kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT0._GTF] (Node ffff88018fccc400), AE_NOT_FOUND (20150930/psparse-542)
    Jul 11 15:49:50 skrofa kernel: ACPI Error: Method parse/execution failed [\_SB.PCI0.SAT0.SPT3._GTF] (Node ffff88018fccc298), AE_NOT_FOUND (20150930/psparse-542)
    Jul 11 15:50:01 skrofa kernel: FUJITSU Extended Socket Network Device Driver - version 1.0 - Copyright (c) 2015 FUJITSU LIMITED
    Jul 11 15:50:01 skrofa kernel: alx 0000:03:00.0 eth0: Qualcomm Atheros AR816x/AR817x Ethernet [90:2b:34:ad:d7:d3]
    Jul 11 15:50:01 skrofa kernel: alx 0000:03:00.0 eth1: renamed from eth0
    Jul 11 15:49:56 skrofa systemd-udevd[495]: Network interface NamePolicy= disabled by default.
    Jul 11 15:50:03 skrofa avahi-daemon[944]: Network interface enumeration completed.
    Jul 11 15:50:03 skrofa systemd[1]: Starting Network Manager...
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  NetworkManager (version 1.0.12) is starting...
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Read config: /etc/NetworkManager/NetworkManager.conf
    Jul 11 15:50:04 skrofa systemd[1]: Started Network Manager.
    Jul 11 15:50:04 skrofa systemd[1]: Starting Network Manager Wait Online...
    Jul 11 15:50:04 skrofa systemd[1]: Started Network Manager Wait Online.
    Jul 11 15:50:04 skrofa systemd[1]: Reached target Network.
    Jul 11 15:50:04 skrofa systemd[1]: Reached target Network is Online.
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded settings plugin ifcfg-suse: (C) 2008 Novell, Inc.  To report bugs please use the NetworkManager mailing list. (/usr/lib64/NetworkManager/libnm-settings-plugin-ifcfg-suse.so)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded settings plugin keyfile: (c) 2007 - 2015 Red Hat, Inc.  To report bugs please use the NetworkManager mailing list.
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  keyfile: ipv4.addresses: deprecated semicolon at the end of value addresses1: '192.168.191.131;24;192.168.191.1;'
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  keyfile: new connection /etc/NetworkManager/system-connections/Vatnaskil (494da871-d8a2-4121-bab3-f8b463c88a32,"Vatnaskil")
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  VPN: loaded org.freedesktop.NetworkManager.pptp
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  VPN: loaded org.freedesktop.NetworkManager.vpnc
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  VPN: loaded org.freedesktop.NetworkManager.openconnect
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  VPN: loaded org.freedesktop.NetworkManager.openvpn
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  monitoring kernel firmware directory '/lib/firmware'.
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMVxlanFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMVlanFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMVethFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMTunFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMMacvlanFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMInfinibandFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMGreFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMEthernetFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMBridgeFactory (internal)
    Jul 11 15:50:04 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMBondFactory (internal)
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/libnm-device-plugin-wifi.so)
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMTeamFactory (/usr/lib64/NetworkManager/libnm-device-plugin-team.so)
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMBluezManager (/usr/lib64/NetworkManager/libnm-device-plugin-bluetooth.so)
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMWwanFactory (/usr/lib64/NetworkManager/libnm-device-plugin-wwan.so)
    Jul 11 15:50:05 skrofa kernel: alx 0000:03:00.0 eth1: NIC Up: 1 Gbps Full
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  Loaded device plugin: NMAtmManager (/usr/lib64/NetworkManager/libnm-device-plugin-adsl.so)
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  WiFi enabled by radio killswitch; enabled by state file
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  WWAN enabled by radio killswitch; enabled by state file
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  WiMAX enabled by radio killswitch; enabled by state file
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  Networking is enabled by state file
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  (lo): link connected
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  (lo): new Generic device (carrier: ON, driver: 'unknown', ifindex: 1)
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  (eth1): new Ethernet device (carrier: OFF, driver: 'alx', ifindex: 2)
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  (eth1): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  (eth1): link connected
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  (eth1): device state change: unavailable -> disconnected (reason 'carrier-changed') [20 30 40]
    Jul 11 15:50:05 skrofa NetworkManager[970]: <info>  startup complete
    Jul 11 15:50:12 skrofa start-ntpd[1013]: Starting network time protocol daemon (NTPD)
    Jul 11 15:51:35 skrofa cifs[1096]: from /etc/fstab .mount error(101): Network is unreachable
    Jul 11 15:51:35 skrofa cifs[1096]: mount error(101): Network is unreachable
    Jul 11 15:51:35 skrofa cifs[1096]: mount error(101): Network is unreachable
    Jul 11 15:51:35 skrofa cifs[1096]: mount error(101): Network is unreachable
    Jul 11 15:51:36 skrofa mount[1147]: mount error(101): Network is unreachable
    Jul 11 15:51:36 skrofa mount[1150]: mount error(101): Network is unreachable
    Jul 11 15:51:36 skrofa mount[1154]: mount error(101): Network is unreachable
    Jul 11 15:51:36 skrofa mount[1158]: mount error(101): Network is unreachable
    Code:
    ifconfig -a
    eth1      Link encap:Ethernet  HWaddr 90:2B:34:AD:D7:D3  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:453 errors:0 dropped:2 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:37360 (36.4 Kb)  TX bytes:0 (0.0 b)
              Interrupt:16 
    
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:208 errors:0 dropped:0 overruns:0 frame:0
              TX packets:208 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1 
              RX bytes:17680 (17.2 Kb)  TX bytes:17680 (17.2 Kb)

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,820

    Default AW: No ethernet after upgrade from 42.1

    Do you set up a new Konfiguration with this Card in the Networkmanager?
    I would try to delete the old one.

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: No ethernet after upgrade from 42.1

    What I see is that the system is trying to mount some shares as well. But does this before the network starts. In situations like this it's better to use wicked. Configure a static ip, set 8.8.8.8 and 8.8.4.4 as the DNS's en your router's internal IP as the gateway.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Aug 2008
    Location
    Reykjavik, Iceland
    Posts
    75

    Default Re: No ethernet after upgrade from 42.1

    Progress! I stripped out for now the mounted drives from fstab. Fired up yast2 and changed the network config to "wicked" with a static IP. After that I got an internal internet! But I can't access outside the local network, not even ping. Ping results in "Network is unreachable".

    Steady as she goes ...

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,820

    Default AW: No ethernet after upgrade from 42.1

    Routing and DNS is set to your Router?
    Or try the google-DNS 8.8.8.8

  8. #8
    Join Date
    Aug 2008
    Location
    Reykjavik, Iceland
    Posts
    75

    Default Re: No ethernet after upgrade from 42.1

    Well, that is what I'm trying to figure out. I don't have any GUI as is (need to install the proper nvidia driver) so I'm stumbling around the terminal. I'm pretty sure I got the DNS correct (since I can ping machine on the local network by name) but I'm less sure about the Gateway:

    Code:
    ip route
    default via 192.168.191.1 dev eth1
    192.168.191.0/24 dev eth1 proto kernel scope link src 192.168.191.131
    192.168.191.1 is the router. I added the top line manually with
    Code:
    ip route add

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,820

    Default AW: No ethernet after upgrade from 42.1

    yast ncurses is working.
    as root:
    Code:
    yast

  10. #10
    Join Date
    Aug 2008
    Location
    Reykjavik, Iceland
    Posts
    75

    Lightbulb Re: No ethernet after upgrade from 42.1

    Ok, I think I got it. Under (Yast2) "Network Settings > Routing > Default IPv4 Gateway > Device" I had to directly specify "eth1".

    Again, I have no idea why it changed from eth0 to eth1 but at least I can ping everything now and mount my shared windows drives.

    Thank you both!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •