Results 1 to 8 of 8

Thread: Time stamp on Files on SD card read incorrectly

  1. #1

    Question Time stamp on Files on SD card read incorrectly

    I use my system to manage my photos, copying from them from SD cards to my system. I use a time zone of UTC+10 on my system.

    I have successfully done this in every version up to 13.2, but I think the current problem started with 42.2, though I can't be sure.

    When 42.2 reads the SD card eg in Dolphin, it adds +10hours to the file date/time stamp (when displayed in Dolphin and Krusader) so, eg, 08:00 becomes 20:00, but then it also set time zone on file to +10, so I have a file that now reads 20:00+10AEST, instead of 08:00+10AEST. So when I copy the files from the SD card to my system, I now have files with a time stamp 10 hours ahead of what they should be.

    The time stamp on the SD card is correct, and if I copy onto Windows system and then transfer via network to my system, the file time stamp is correctly maintained.

    Appreciate any advice as to how to resolve this.

    Thanks

    George

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: Time stamp on Files on SD card read incorrectly

    Just guessing: it might be related to how your HTC (hardware time clock) is set in BIOS/UEFI, UTC or local. It shouldn't be a problem, however, as the OS sets the session local time through ntp. If you don't get anything better you may try checking it.

    Note: when I installed oS 13.2, eons ago (2 years), it was recommended to set HTC to UTC if you were running linux only, and to local time if you were dual-booting with windows. That might have changed, thou.

  3. #3
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,043

    Default Re: Time stamp on Files on SD card read incorrectly

    On Fri, 07 Jul 2017 03:36:01 +0000, brunomcl wrote:

    > Just guessing: it might be related to how your HTC (hardware time clock)
    > is set in BIOS/UEFI, UTC or local. It shouldn't be a problem, however,
    > as the OS sets the session local time through ntp. If you don't get
    > anything better you may try checking it.
    >
    > Note: when I installed oS 13.2, eons ago (2 years), it was recommended
    > to set HTC to UTC if you were running linux only, and to local time if
    > you were dual-booting with windows. That might have changed, thou.


    I think you're on to something there. I was thinking that it might be
    how the timestamp is written (Windows using local time, Linux using UTC),
    but your post reminded me that Windows uses the HTC in local time, and
    Linux in UTC - which would cause the same kind of behavior in filesystem
    timestamps.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  4. #4

    Default Re: Time stamp on Files on SD card read incorrectly

    Thank you for your responses. Gave me some other things to look at.

    I checked the BIOS clock and it is running as UTC, assume because I have Hardware clock to UTC set.

    It's a long time since I have been in the BIOS on this system, but I would have (locgically?) set the BIOS time to my local time. With previous versions of OpenSuse, I don't recall ever considering or setting Hardware clock to UTC. Is it possible this is a default introduced in 42.2, this would explain current behaviour?

    I assume that Linux is assuming (to my mind incorrectly) that the time stamp (does not contain timezone info, not somehting I can control) on my files on SD card is UTC, and so adds 10 hours to "match" my system, whereas it should accept the "absolute" time on file.

    I see 2 solutions, do not set HWC to UTC and change BIOS time to local time or use cp --preserve. Because I am sure sure of the side effects of not setting HWC to UTC, I will try cp --preserve.

    Any additional thoughts welcome.

    Thanks

  5. #5

    Default Re: Time stamp on Files on SD card read incorrectly

    Mmm, cp --preserve is not the solution because Linux has already interpreted the date/time so I am preserving an incorrect time

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,491
    Blog Entries
    15

    Default Re: Time stamp on Files on SD card read incorrectly

    On Sat 08 Jul 2017 12:26:02 AM CDT, georgejw wrote:

    Mmm, cp --preserve is not the solution because Linux has already
    interpreted the date/time so I am preserving an incorrect time


    Hi
    Set BIOS to UTC and all OSes to UTC/Locale time.... (windows use
    RealTimeIsUniversal reg setting)

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.73-18.17-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  7. #7

    Default Re: Time stamp on Files on SD card read incorrectly

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Set BIOS to UTC and all OSes to UTC/Locale time.... (windows use
    RealTimeIsUniversal reg setting)

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.73-18.17-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!
    Malcolm, thank you for your suggestion, could you pls explain UTC/Locale time. I only use LEAP on this system, I had HWC clock set to UTC via Date and Time in YAST and timezone set to my local time zone in YAST, which is what I think you are suggesting, but that gives me the problem.

    For the moment, I have disabled HWC set to UTC and set BIOS to local time, and now my dates display and transfer correctly.

    The downside, warned of when I turned off HWC to UTC, was that I will need to change BIOS clock during daylight time transitions. If that's all, can live with that.

    Thanks to all for your advice

  8. #8
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,491
    Blog Entries
    15

    Default Re: Time stamp on Files on SD card read incorrectly

    On Sat 08 Jul 2017 10:36:01 AM CDT, georgejw wrote:

    malcolmlewis;2829270 Wrote:
    > Hi
    > Set BIOS to UTC and all OSes to UTC/Locale time.... (windows use
    > RealTimeIsUniversal reg setting)
    >
    > --
    > Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    > openSUSE Leap 42.2|GNOME 3.20.2|4.4.73-18.17-default
    > If you find this post helpful and are logged into the web interface,
    > please show your appreciation and click on the star below... Thanks!


    Malcolm, thank you for your suggestion, could you pls explain UTC/Locale
    time. I only use LEAP on this system, I had HWC clock set to UTC via
    Date and Time in YAST and timezone set to my local time zone in YAST,
    which is what I think you are suggesting, but that gives me the problem.

    For the moment, I have disabled HWC set to UTC and set BIOS to local
    time, and now my dates display and transfer correctly.

    The downside, warned of when I turned off HWC to UTC, was that I will
    need to change BIOS clock during daylight time transitions. If that's
    all, can live with that.

    Thanks to all for your advice


    Hi
    Is this a dual boot machine, or you use a windows machine in the
    mix...? I have one multiboot system with windows 10, BIOS time is UTC
    and all fine with the registry tweak.

    But, yes, your summary is correct and would need to tweak the clock on
    daylight/standard time changes.... but if running ntpd as a service it
    should sort it out.

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.73-18.17-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •