I think the real question is:

How can I change the DEFAULT alsa device to NOT be pulseaudio?

And here's why I think so:

In the evening I use my laptop to play various video streams because I can position
it close enough to my recliner to reach things like pause functions and other playback
controls. The trouble is that I've never managed to get any sound output on the
laptop when the pulseaudio device is selected. The laptop is a dell inspiron with
duel 64 bit processors that originally shipped with windows 7.

I should mention that I'm not running KDE though I still use a few KDE apps.
What I do use is openbox... Anyway most of the time the problem with pulse audio
can be circumvented by opening alsamixer in a konsole and selecting the sound card
that works. Then sometimes unmuting the headphone channel that feeds my speakers.

This works when I play music with mocp (music on console) Which I usually run in a
yakuake terminal window for quick access no mater which of my 12 workspaces I'm using
at the moment. It works so that Google Chrome can play sound when I'm watching
something on Hulu. And it works when I use parole to play back a video playlist of
webm files downloaded from youtube. However I have a large collection of older mpeg4
videos that parole needs some decoder codec that doesn't appear to be available.

My first thought was to use vlc instead of parole. Which would work except that
it's audio playback device setting insists that the alsamixer default is currently
the pulseaudio device which won't play any sound. It doesn't care that I've already
opened alsamixer and selected the other sound device... And none of the other offered
devices seem to work. (I tried them all.)

So like I said my question is how can I change the DEFAULT alsa device to NOT be
pulseaudio?

Thanks in advance.

--
jtwdyp