Results 1 to 6 of 6

Thread: Glabels 3.4.0 missing GNU Barcode Support

  1. #1

    Default Glabels 3.4.0 missing GNU Barcode Support

    Can someone assist in Compiling the source with the right settings? I tried and failed.
    This problem exists since 13.2. Kubuntu still works.

    https://bugs.launchpad.net/ubuntu/+s...131/comments/3
    Code:
    Will Jordan (will-jordan) wrote on 2014-02-26: #3
    The EAN8/Code128 barcodes that were originally in glabels and are not in this build were provided by GNU Barcode. (Zint support was added in a recent version, but this barcode library does not yet have an official Ubuntu package.) Something seems to be affecting the amd64 build environment causing the autoconf line "AC_CHECK_LIB(barcode, Barcode_Create, [...]" to return false even though the "barcode" package seems to be installed correctly. Looking at the logs it seems to affect recent AMD64 but not some other builds (e.g. i386 build logs show GNU barcode support is included). I just built glabels from source off github and the barcode support was included as expected.
    Old Thread with bug:

    https://forums.opensuse.org/showthre...arcode-Support

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,118
    Blog Entries
    2

    Default Re: Glabels 3.4.0 missing GNU Barcode Support

    Have you tried to run a pre-compiled version of glabels?
    The following page includes a generic install and lists its requirements.

    http://glabels.org/pages/download

    Although the glabels version is 1 year old, if you inspect its github project no changes have been submitted within the last 10 months so I doubt compiling will help

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,657
    Blog Entries
    15

    Default Re: Glabels 3.4.0 missing GNU Barcode Support

    Hi
    Hmmm, not sure why it never got fixed.... here is a test build for 42.3 (and it will publish for you to test).
    https://build.opensuse.org/package/s...E:Apps/glabels

    glabels probably needs to move to graphics anyway...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Glabels 3.4.0 missing GNU Barcode Support

    Thank you for your help, but obs is telling me:

    Package "glabels" not found in project "home:malcolmlewis:branches:GNOME:Apps"

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,657
    Blog Entries
    15

    Default Re: Glabels 3.4.0 missing GNU Barcode Support

    Quote Originally Posted by max_spam View Post
    Thank you for your help, but obs is telling me:

    Package "glabels" not found in project "home:malcolmlewis:branches:GNOME:Apps"
    Hi
    Yes, branches disappear when packages are accepted back to the development project, so check GNOME:Apps, it made it automagically to Tumbleweed now, but needs maintenance update for 43.3 (after release).
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Glabels 3.4.0 missing GNU Barcode Support

    Ok, thank you, I upreaded to 42.3 and installed it from tumbleweed repo.
    It is working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •