Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Can't open YaST on KDE only

  1. #1

    Default Can't open YaST on KDE only

    Hello, openSUSE community.

    I'm having some problem concerning YaST on openSUSE Leap 42.2. Some time ago, after an update and a clean-up process using both Sweeper and BleachBit, YaST suddenly stopped opening exclusively on KDE, but keeps opening normally while using IceWM and on ncurses. I've seeked for a solution like reinstalling YaST, sudo, kdesu, etc. and others, but nothing works.

    What should I do to solve this issue?

  2. #2

    Default Re: Can't open YaST on KDE only

    Hi:
    I have a few ideas.
    Try executing Yast2 from the commandline and see if the konsole returns any errors.

    To open as root:
    Code:
    kdesu yast2
    Error messages may point to what is wrong or give a clue.

    Check on the Security level maybe it somehow got changed and that's why it won't launch?

  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,803
    Blog Entries
    14

    Default Re: Can't open YaST on KDE only

    A cleanup process using Sweeper (???) and Bleachbit ..... I don't know Sweeper, but I do know Bleachbit warns the user to carefully inspect what it's removing. I suggest you reinstall all the yast2 packages.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  4. #4

  5. #5

    Default Re: Can't open YaST on KDE only

    Thanks for replying. I've tried everything you suggested, but still can't open YaST on KDE.

    Quote Originally Posted by Ztcracat
    Hi:
    I have a few ideas.
    Try executing Yast2 from the commandline and see if the konsole returns any errors.

    To open as root:
    Code:
    kdesu yast2
    Error messages may point to what is wrong or give a clue.

    Check on the Security level maybe it somehow got changed and that's why it won't launch?
    I've tried that before and forgot to mention, sorry. The same thing happens, YaST doesn't open only on KDE. It also gives me no error output after executing the command, even if I use the -d (debug) option for kdesu.

    I've checked security, firewall and AppArmor levels and everything seems to be normal there.

    Quote Originally Posted by Knurpht
    A cleanup process using Sweeper (???) and Bleachbit ..... I don't know Sweeper, but I do know Bleachbit warns the user to carefully inspect what it's removing. I suggest you reinstall all the yast2 packages.
    Sweeper is a clean-up tool developed by KDE. It's a lot simpler than BleachBit, thus covering less more than the latter does, but I still like to use it along BleachBit for a better cleaning efficience.

    Yes, I know about all the warnings BleachBit gives, I've setted it up after reading them all carefully, so I'm pretty sure about what it cleans up when I request it to. Also, the same action gives me no issues in another computer with the same system and settings.

    I've reinstalled all the packages related to YaST, and also installed some that were missing, but nothing solved the issue.

  6. #6

    Default Re: Can't open YaST on KDE only

    Sorry what I suggested didn't give any errors or help.

    If reinstalling Yast didn't help (meaning that you completely removed Yast and all of it's dependencies) than I'm thinking (I'm not an expert) that the API may be broken or badly misconfigured.

    Maybe the modules are missing because Bleachbit removed them? (very possible)

    Most libraries/engines, drivers and modules are what makes applications work.

    -::-A fresh installation will most likely fix it. I know that's probably 'not your favored solution' but it's sure an option.-::-

    This may or may not help. I tried:-

    http://www.linuxquestions.org/questi...ng-4175579346/

  7. #7
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: Can't open YaST on KDE only

    Code:
    su -
    Send password and become root
    Code:
    /sbin/yast2
    Starts ?

  8. #8

    Default Re: Can't open YaST on KDE only

    The solution presented by V_idocq does give me an useful alternative, although not solving the problem.

    Quote Originally Posted by Ztcoracat
    Sorry what I suggested didn't give any errors or help.

    If reinstalling Yast didn't help (meaning that you completely removed Yast and all of it's dependencies) than I'm thinking (I'm not an expert) that the API may be broken or badly misconfigured.

    Maybe the modules are missing because Bleachbit removed them? (very possible)

    Most libraries/engines, drivers and modules are what makes applications work.

    -::-A fresh installation will most likely fix it. I know that's probably 'not your favored solution' but it's sure an option.-::-

    This may or may not help. I tried:-

    http://www.linuxquestions.org/questi...ng-4175579346/
    It's alright, you've tried your best to help me and I thank you for that. Yeah, that can be the problem here. My only non-official configured repository is Packman, but no package that is installed from there is related to the problem. As Leap 42.3 is gonna be launched on the 25th, I'm gonna wait for it and do the distro upgrade, so the issue is likely to get solved. I also have some other minor problems related to KDE, like the startup sound that stopped playing, and I hope the upgrade does solve all them.

    Quote Originally Posted by V_idocq
    Code:
    su -
    Send password and become root
    Code:
    /sbin/yast2
    Starts ?
    Yes, it starts normally. Thank you for presenting that alternative. For curiosity, I'd want to know if I could change YaST language there, since it's in English. It's not a problem for me, just a curiosity I have.

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,518

    Default Re: Can't open YaST on KDE only

    Quote Originally Posted by jgright View Post
    I'm having some problem concerning YaST on openSUSE Leap 42.2. Some time ago, after an update and a clean-up process using both Sweeper and BleachBit, YaST suddenly stopped opening exclusively on KDE, but keeps opening normally while using IceWM and on ncurses. I've seeked for a solution like reinstalling YaST, sudo, kdesu, etc. and others, but nothing works.
    To enable KDE YaST the following package needs to installed which, pulls in and installs all the dependencies need for YaST within KDE to execute as expected:
    • patterns-openSUSE-kde_yast

    Code:
     > zypper info patterns-openSUSE-kde_yast
    Loading repository data...
    Reading installed packages...
    
    
    Information for package patterns-openSUSE-kde_yast:
    ---------------------------------------------------
    Repository     : Haupt-Repository (OSS)
    Name           : patterns-openSUSE-kde_yast
    Version        : 20150918-25.1
    Arch           : x86_64
    Vendor         : openSUSE
    Installed Size : 54 B
    Installed      : Yes
    Status         : up-to-date
    Source package : patterns-openSUSE-20150918-25.1.src
    Summary        : YaST KDE User Interfaces
    Description    :
        Graphical YaST user interfaces for the KDE desktop.
    
    >
    Possibly, a "forced" install may be needed: "zypper install --force patterns-openSUSE-kde_yast".

  10. #10
    Join Date
    Apr 2017
    Location
    Piemont
    Posts
    274

    Default Re: Can't open YaST on KDE only

    And using only

    And
    Code:
    /usr/bin/xdg-su -c /sbin/yast2

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •