Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

  1. #1

    Default Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Please see the subject. KDE's Dolphin has no trouble navigating the hierarchy and displaying all characters correctly. Konsole lists the files with question marks. LibreOffice claims the files don't exist.

    Files were saved to a backup drive, and SUSE won't read that, either. Fedora 25 has no trouble.

    (Apologies if this is a double post; I thought I posted this already, but it's not showing up. Or perhaps I posted it in another SUSE forum with exactly the same forum names.)

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,793
    Blog Entries
    14

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    How did you upgrade? Doing so from 12.2 to 42.2 is not supported, and will lead to trouble due to technical differences between the systems.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Try to uninstall the KDE integration (if you are using openSUSE's packages, it's libreoffice-kde4) and see if it helps.

    There was a similar thread in the german sub forum recently (a user had problems to open files with german "umlauts") and that "fixed" it, that was with the packages from libreoffice.org though.

  4. #4

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Quote Originally Posted by wolfi323 View Post
    Try to uninstall the KDE integration (if you are using openSUSE's packages, it's libreoffice-kde4) and see if it helps.
    Thank you. Right now I'm reinstalling KDE after having uninstalled it. I had discovered that it worked just fine in Gnome, and since Konsole was also having issues I figured it must have something to do with KDE. See my other reply (which I'm about to write).

  5. #5

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Quote Originally Posted by Knurpht View Post
    How did you upgrade? Doing so from 12.2 to 42.2 is not supported, and will lead to trouble due to technical differences between the systems.
    Sorry; I thought I had written that. I reformatted / and /boot and installed directly, so it wasn't any sort of upgrade process, e.g. zypper dup. It was basically a fresh install, with only the /data partition preserved (and everything backed up on an external hard drive). The point of mentioning 12.2 is that the files worked fine on it, but don't now.

    I'm wondering if it's somehow related to having installed in English (my native language) and later switching the language to Russian (friend's language). That doesn't make sense to me but 2 or 3 weird things happened in the install (e.g., it didn't save the wireless information, so I had to re-enter all that upon first boot).

  6. #6

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Quote Originally Posted by john_perry_math View Post
    Right now I'm reinstalling KDE after having uninstalled it. I had discovered that it worked just fine in Gnome, and since Konsole was also having issues I figured it must have something to do with KDE. See my other reply (which I'm about to write).
    Reinstalling KDE did not fix the problem. In fact, Nautilus will not open the files when run from KDE; it only opens them when run from Gnome.

  7. #7

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Quote Originally Posted by john_perry_math View Post
    Reinstalling KDE did not fix the problem. In fact, Nautilus will not open the files when run from KDE; it only opens them when run from Gnome.
    Did you try to uninstall libreoffice-kde4?
    What does "locale" say (run as user in a KDE session)?
    Does opening them from within Libreoffice work (i.e. File->Open, not opening them from Nautilus)?

  8. #8

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Thank you for the reply.
    Quote Originally Posted by wolfi323 View Post
    Did you try to uninstall libreoffice-kde4?
    Yes. That does not help.
    What does "locale" say (run as user in a KDE session)?
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=cu_RU.UTF-8
    LC_CTYPE="cu_RU.UTF-8"
    ...
    LC_IDENTIFICATION="cu_RU.UTF-8"
    LC_ALL=
    Does opening them from within Libreoffice work (i.e. File->Open, not opening them from Nautilus)?
    No.

    Here's another data point, if if helps. Even though the preferred language is English in KDE's settings, and the language is set to Russian under YaST, and everything YaST and Gnome show up in Russian, KDE presents everything in English.

  9. #9

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Quote Originally Posted by john_perry_math View Post
    Code:
    locale: Cannot set LC_CTYPE to default locale: No such file or directory
    locale: Cannot set LC_MESSAGES to default locale: No such file or directory
    locale: Cannot set LC_ALL to default locale: No such file or directory
    LANG=cu_RU.UTF-8
    I noticed that that seemed odd. If I change the locale to ru_RU.utf8 some things start to work better; e.g., Dolphin actually presents Russian menus.

    However, Plasma is somehow stuck with this cu_RU.UTF-8 as the default. There's something called plasma-locale-settings.sh that I think controls it. It's supposed to be "generated from kcmshell5 formats" but kcmshell5 has bad documentation. For instance, it says that --lang <language> is an option, but if you try and use that option it says "--lang is deprecated. Please set the LANGUAGE environment variable instead."

    Naturally, doing that changes nothing in plasma-locale-settings.sh, so I'm still stuck.

  10. #10

    Default Re: Upgraded from 12.2 to 42.2, now cannot open files w/Cyrillic names

    Quote Originally Posted by john_perry_math View Post
    However, Plasma is somehow stuck with this cu_RU.UTF-8 as the default. There's something called plasma-locale-settings.sh that I think controls it. It's supposed to be "generated from kcmshell5 formats" but kcmshell5 has bad documentation. For instance, it says that --lang <language> is an option, but if you try and use that option it says "--lang is deprecated. Please set the LANGUAGE environment variable instead."

    Naturally, doing that changes nothing in plasma-locale-settings.sh, so I'm still stuck.
    Finally got it. I'm not sure how it got stuck on the wrong thing (probably my fault: tinkered somewhere w/the wrong value) nor why it didn't work after I first installed it, but apparently I had to do
    Code:
    localectl set-locale LANG=ru_RU.utf8
    and maybe
    Code:
    export LC_ALL=ru_RU.utf8
    as well. The former required me to enter the root user's password (odd) but now I seem to be able to navigate in Russian as well as open files in LibreOffice.

    Thank you for listening! or, as my friend might say, спасибо за помощь!

    PS: Is there no way to mark this as "Solved"? I can't even seem to change the thread's title.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •