Results 1 to 9 of 9

Thread: texlive is broken in tumbleweed 20170626

  1. #1

    Default texlive is broken in tumbleweed 20170626

    Since Tumbleweed 20172025, texlive appears to be broken.
    When pdflatex or latex is run, I get

    ====================
    This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/TeX Live for SUSE Linux) (preloaded format=pdflatex)
    restricted \write18 enabled.
    ---! /var/lib/texmf/web2c/pdftex/pdflatex.fmt made by different executable version
    (Fatal format file error; I'm stymied)
    ====================

    When will this problem get resolved?

  2. #2

    Default AW: texlive is broken in tumbleweed 20170626

    Quote Originally Posted by kbsisnopbs View Post
    When will this problem get resolved?
    Depends on when a bug report (i.e. YOUR bug report on this issue) will be dealt with.

    (I hope you get the hint.)

    AK

    P.S. https://bugzilla.opensuse.org/

    You can use the same login credentials you use for this forum.

  3. #3

    Default Re: texlive is broken in tumbleweed 20170626

    Not the new updates, but the software in my machine got corrupted somehow.
    I fresh-installed tumbleweed. Now, pdflatex works flawlessly.

    Sorry for the misplaced posting.

    I think we can close this thread.

  4. #4

    Default Re: texlive is broken in tumbleweed 20170626

    Same problem on two different machines running openSUSE Tumbleweed following the latest update.


    This is pdfTeX, Version 3.14159265-2.6-1.40.18 (TeX Live 2017/TeX Live for SUSE Linux) (preloaded format=latex)
    restricted \write18 enabled.
    ---! /var/lib/texmf/web2c/pdftex/latex.fmt made by different executable version
    (Fatal format file error; I'm stymied)

    fmtutil --all

    won't fix it.

    What if I do NOT want to re-install?
    File a bug report?
    Aldo

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,507
    Blog Entries
    3

    Default Re: texlive is broken in tumbleweed 20170626

    Quote Originally Posted by abonfi View Post
    fmtutil --all

    won't fix it.

    What if I do NOT want to re-install?
    File a bug report?
    Aldo
    I suggest that you reopen the existing bug report:
    Bug 1046277

    Click on the link. You should be able to login with the same credentials that you use for opensuse forums. And you might already be logged in.

    Look for the edit box "Additional comments". Put your comment there. Mention that you tried "fmtutil --all". Just below that edit box, is a status line. Change that from "RESOLVED" to "RE-OPEN". Then submit your changes.

    It seems to be working for me. And I did not do a reinstall. Checking that "latex.fmt" file, I see that it has a date of Jun 26, which is when I installed that large update which included texlive.

    Apparently there is some problem with updating format files that is affecting you but not affecting me.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: texlive is broken in tumbleweed 20170626

    ls -l /var/lib/texmf/web2c/pdftex/latex.fmt
    -rw-rw-r-- 1 root mktex 3353580 Jun 14 15:42 /var/lib/texmf/web2c/pdftex/latex.fmt

    whereas texlive has been updated on june 28th

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,507
    Blog Entries
    3

    Default Re: texlive is broken in tumbleweed 20170626

    Quote Originally Posted by abonfi View Post
    ls -l /var/lib/texmf/web2c/pdftex/latex.fmt
    -rw-rw-r-- 1 root mktex 3353580 Jun 14 15:42 /var/lib/texmf/web2c/pdftex/latex.fmt

    whereas texlive has been updated on june 28th
    I see that you have reopened the bug report. I suggest you add the "ls" output to the report. It gives a point of information on what has gone wrong.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Default Re: texlive is broken in tumbleweed 20170626

    Hi, I have the same problem (the link to bug don't works for me). If I run the command "fmtutil-sys --all" I get:

    Local configuration file hyphen.cfg used
    ===========================================
    (/usr/share/texmf/tex/generic/babel/hyphen.cfg
    (/usr/share/texmf/tex/generic/babel/switch.def)
    (/usr/share/texmf/tex/generic/hyphen/hyphen.tex)
    (/usr/share/texmf/tex/generic/hyphen/dumyhyph.tex)
    (/usr/share/texmf/tex/generic/hyphen/zerohyph.tex)
    (/usr/share/texmf/tex/generic/dehyph-exptl/dehypht-x-2017-03-31.tex
    dehyph-exptl: using an 8-bit TeX engine.
    (/usr/share/texmf/tex/generic/dehyph-exptl/dehypht-x-2017-03-31.pat
    German Hyphenation Patterns (Traditional Orthography) `dehypht-x' 2017-03-31 (W
    L))) (/usr/share/texmf/tex/generic/dehyph-exptl/dehyphn-x-2017-03-31.tex
    dehyph-exptl: using an 8-bit TeX engine.
    (/usr/share/texmf/tex/generic/dehyph-exptl/dehyphn-x-2017-03-31.pat
    German Hyphenation Patterns (Reformed Orthography, 2006) `dehyphn-x' 2017-03-31
    (WL)))
    ! I can't find file `loadhyph-af.tex'.
    <to be read again>
    \relax
    l.185 \repeat

    (Press Enter to retry, or Control-D to exit)
    Please type another input file name:
    ! Emergency stop.
    <to be read again>
    \relax
    l.185 \repeat

    ! ==> Fatal error occurred, no output PDF file produced!
    Transcript written on pdfxmltex.log.
    fmtutil [ERROR]: running `xetex -ini -jobname=xetex -progname=xetex -etex xetex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=pdftex -progname=pdftex -translate-file=cp227.tcx *pdfetex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=mllatex -progname=mllatex -translate-file=cp227.tcx -mltex *mllatex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=pdfjadetex -progname=pdfjadetex -translate-file=cp227.tcx *pdfjadetex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=pdflatex -progname=pdflatex -translate-file=cp227.tcx *pdflatex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=pdfetex -progname=pdfetex -translate-file=cp227.tcx *pdfetex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=etex -progname=etex -translate-file=cp227.tcx *etex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=jadetex -progname=jadetex -translate-file=cp227.tcx *jadetex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=xmltex -progname=xmltex -translate-file=cp227.tcx *xmltex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [ERROR]: running `pdftex -ini -jobname=pdfxmltex -progname=pdfxmltex -translate-file=cp227.tcx *pdfxmltex.ini </dev/null' return status 1
    fmtutil [ERROR]: return error due to options --strict
    fmtutil [INFO]: Successfully rebuilt formats: 27
    fmtutil [INFO]: Not available formats: 12
    fmtutil [INFO]: Failed to build: 12 (xetex/xetex pdftex/pdftex pdftex/latex pdftex/mllatex pdftex/pdfjadetex pdftex/pdflatex xetex/xelatex pdftex/pdfetex pdftex/etex pdftex/jadetex pdftex/xmltex pdftex/pdfxmltex)
    fmtutil [INFO]: Total formats: 51
    fmtutil [INFO]: exiting with status 12

    Some idea?
    Last edited by GermanGT; 09-Jul-2017 at 00:11. Reason: Remove HTML code

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,507
    Blog Entries
    3

    Default Re: texlive is broken in tumbleweed 20170626

    Quote Originally Posted by GermanGT View Post
    Hi, I have the same problem (the link to bug don't works for me).
    I have not been able to access bug reports since yesterday afternoon. I think something broke. Hopefully it will be available again soon.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •