Results 1 to 2 of 2

Thread: A problem between Firefox and xfreerdp

  1. #1
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default A problem between Firefox and xfreerdp

    Hello everyone,

    I found a very weird thing when using Firefox browser and xfreerdp at the same time. This is far beyond my knowledge to explain and solve.

    When I use Firefox to browse internet locally and xfreerdp to connect to my office computer at the same time, if I shift the focus of the mouse cursor from Firefox (in local) to the content in the window (remote) of xfreerdp, Firefox in local gets almost freeze and takes 25% CPU (equalling to 1 thread of the cores). At the same time, I can use mouse freely in the remote window but input of some keys (e.g. Ctrl) of the keyboard is not functioning well. While locally, the input method (I believe it is fcitx) becomes unsteady. And the selected text block in Firefox window which has a blue background gets blinking.

    These phenomena last about 10 to 15 seconds and then the CPU utilisation gets normal.

    My system is,
    Code:
    openSUSE Tumbleweed: 20170620
    KDE Plasma: 5.10.2
    Qt: 5.9.0
    KDE Frameworks: 5.34.0
    Kernel: 4.11.6-1-default
    And this happens on the default Firefox ESR 52.2 on openSUSE Tumbleweed and Firefox 54 from the factory "mozilla" repository.

    Could anyone please help explain this? I don't even know how to file a bug if necessary on this.

    Best wishes,
    CnZhx
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

  2. #2
    Join Date
    Jan 2016
    Location
    Manchester, UK
    Posts
    279

    Default Re: A problem between Firefox and xfreerdp

    Further investigation shows this only happens when `/f` parameter is used for `xfreerdp` which makes the remote desktop start in full screen mode.

    But this problem will not occur when `/size:<dimension of the screen>` is used instead of `/f` and then the window is made into fullscreen by checking the `Fullscreen` option in the right click menu of the window title bar (where `<dimension of the screen>` is something like `1920x1080`).
    openSUSE Tumbleweed (usually the latest snapshot) w/ KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •