Results 1 to 5 of 5

Thread: Application unable to run java since Kernel and glibc updates.

  1. #1

    Default Application unable to run java since Kernel and glibc updates.

    The other day (June 21) my system updated the kernel and some other packages such as glibc which were listed as security updates. Since that time, I have an application, SAS Statistical software, which cannot start its private Java module. It spawns an error message:
    Code:
    ERROR: The Java child process terminated unexpectedly: status 267.ERROR: WIFSIGNALED 1 WIFEXITED 0 WEXITSTATUS 1 WTERMSIG 11.
    ERROR: The Java proxy is not responding.
    . The private java version the app runs is
    Code:
    java version "1.7.0_141"
    Java(TM) SE Runtime Environment (build 1.7.0_141-b31)
    Java HotSpot(TM) 64-Bit Server VM (build 24.141-b31, mixed mode)
    
    I'm wondering if something in one of the updates could be responsible for this, perhaps some security setting? The application itself is unchanged and, before the updates, ran perfectly. I'm a bit at a loss as to what's happening as the application is unchanged and its setup shows as correct (which it should since nothing changed). I'm wondering if anyone has any ideas?

  2. #2

    Default Re: Application unable to run java since Kernel and glibc updates.


  3. #3

    Default Re: Application unable to run java since Kernel and glibc updates.

    Quote Originally Posted by wolfi323 View Post
    Thanks, Wolfi. That indeed is the problem. I booted with kernel 4.4.70-18.9-default instead of 4.4.72 and the problem disappeared. I hope they apply the fix to the 4.4.72 soon.

  4. #4

    Default Re: Application unable to run java since Kernel and glibc updates.

    Quote Originally Posted by bearymore View Post
    Thanks, Wolfi. That indeed is the problem. I booted with kernel 4.4.70-18.9-default instead of 4.4.72 and the problem disappeared. I hope they apply the fix to the 4.4.72 soon.
    An update has been submitted already yesterday.
    https://build.opensuse.org/patchinfo...6922/patchinfo

    It's available in the Update-Test repo if you want to try it:
    http://download.opensuse.org/update/leap/42.2-test/

    But it should get released very soon, I suppose.

  5. #5

    Default Re: Application unable to run java since Kernel and glibc updates.

    Quote Originally Posted by wolfi323 View Post
    An update has been submitted already yesterday.
    https://build.opensuse.org/patchinfo...6922/patchinfo

    It's available in the Update-Test repo if you want to try it:
    http://download.opensuse.org/update/leap/42.2-test/

    But it should get released very soon, I suppose.
    I tried the patch, and it works like a charm. I also happened to notice that before the patch, the backend of the Crashplan app was not loading. After the patch, it loads fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •