Results 1 to 5 of 5

Thread: gnome won't lock

  1. #1
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default gnome won't lock

    So, I just installed Gnome 3.20 on my main laptop. I am new to gnome,
    coming over from KDE.

    I tried to set it up so that when I close the lid, the system goes to
    suspend and the screen locks. That way, when I open the lid again later,
    I have to enter the password to get back in.

    However, no such thing occurs.

    My settings - below, the last setting on each line is what I have set:

    Settings -> Privacy -> Screen Lock -> Automatic Screen Lock -> On
    Settings -> Privacy -> Screen Lock -> Lock screen after blank for ->
    Screen Turns Off
    Settings -> Privacy -> Screen Lock -> Show Notifications -> On
    Settings -> Power -> Blank Screen -> Never

    I do not want my screen to lock or go blank unless I do it manually or
    close the lid. Is there a way to do this?


    --
    Tribe
    Box: 42.2 | KDE Plasma 5.8 | AMD Phenom IIX4 | 64 | 32GB
    Laptop #1: 42.2 | Gnome 3.20 | AMD FX 7TH GEN | 64 | 32GB
    Laptop #2: 42.2 | KDE Plasma 5.8 | Core i5 | 64 | 8GB

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: gnome won't lock

    On Fri 23 Jun 2017 04:43:45 PM CDT, SChinaSeaTribe wrote:

    So, I just installed Gnome 3.20 on my main laptop. I am new to gnome,
    coming over from KDE.

    I tried to set it up so that when I close the lid, the system goes to
    suspend and the screen locks. That way, when I open the lid again
    later, I have to enter the password to get back in.

    However, no such thing occurs.

    My settings - below, the last setting on each line is what I have set:

    Settings -> Privacy -> Screen Lock -> Automatic Screen Lock -> On
    Settings -> Privacy -> Screen Lock -> Lock screen after blank for ->
    Screen Turns Off
    Settings -> Privacy -> Screen Lock -> Show Notifications -> On
    Settings -> Power -> Blank Screen -> Never

    I do not want my screen to lock or go blank unless I do it manually or
    close the lid. Is there a way to do this?


    Hi
    Check both Privacy and Power settings, but also look at
    configuring /etc/systemd/logind.conf (man logind.conf)

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2|GNOME 3.20.2|4.4.70-18.9-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


  3. #3
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default Re: gnome won't lock

    On 06/23/2017 06:05 PM, malcolmlewis wrote:
    >
    > Hi
    > Check both Privacy and Power settings, but also look at
    > configuring /etc/systemd/logind.conf (man logind.conf)
    >
    >
    >

    Ok, thanks, that gave me some insight.
    Code:
    
    > cat /etc/systemd/logind.conf | grep HandleLid
    #HandleLidSwitch=suspend
    #HandleLidSwitchDocked=ignore
    So it is supposed to suspend. So I just tried "systemctl suspend", and I
    suspended the system. And when I hit the power button to come out of
    suspend, my pc came out of suspend, and did not ask me for a password.

    So the issue as I see it now is that somehow I need to tell gnome that
    when we go to suspend the system, I want to require a password to get
    back into my desktop.

    Does anyone know how to do that? I think that is the standard
    methodology for KDE, but I am trying to make gnome do it now.

    --
    Tribe
    Box: 42.2 | KDE Plasma 5.8 | AMD Phenom IIX4 | 64 | 32GB
    Laptop #1: 42.2 | Gnome 3.20 | AMD FX 7TH GEN | 64 | 32GB
    Laptop #2: 42.2 | KDE Plasma 5.8 | Core i5 | 64 | 8GB

  4. #4
    Join Date
    Apr 2012
    Location
    Philippines
    Posts
    218

    Default Re: gnome won't lock

    On 06/23/2017 08:04 PM, SChinaSeaTribe wrote:
    > On 06/23/2017 06:05 PM, malcolmlewis wrote:


    Well I somehow got it to work. I went to the settings -> power -> blank
    screen setting, changed it from Never to 1 minute. Then I went to
    settings -> privacy -> screen lock and set it to "lock the screen after
    blank" to 30 seconds.

    Then I went back to the power blank screen setting and set it back to
    "never", and tested it. Now when I go to suspend I have to use a
    password to get back in, as I wanted.

    But it doesn't blank out on its own after any amount of time.


    --
    Tribe
    Box: 42.2 | KDE Plasma 5.8 | AMD Phenom IIX4 | 64 | 32GB
    Laptop #1: 42.2 | Gnome 3.20 | AMD FX 7TH GEN | 64 | 32GB
    Laptop #2: 42.2 | KDE Plasma 5.8 | Core i5 | 64 | 8GB

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,824
    Blog Entries
    15

    Default Re: gnome won't lock

    Quote Originally Posted by golson765 View Post
    On 06/23/2017 08:04 PM, SChinaSeaTribe wrote:
    > On 06/23/2017 06:05 PM, malcolmlewis wrote:


    Well I somehow got it to work. I went to the settings -> power -> blank
    screen setting, changed it from Never to 1 minute. Then I went to
    settings -> privacy -> screen lock and set it to "lock the screen after
    blank" to 30 seconds.

    Then I went back to the power blank screen setting and set it back to
    "never", and tested it. Now when I go to suspend I have to use a
    password to get back in, as I wanted.

    But it doesn't blank out on its own after any amount of time.
    Hi
    When you change settings, try restarting the shell (alt+F2 enter r <press return>) and see if it changes the outcome. It may require a logout/login as an alternative.

    PS, Check your signature separator, should be dashdashspace (yours is missing the space)
    Last edited by malcolmlewis; 26-Jun-2017 at 13:34.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •