Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: plasmashell :very high usage CPU after snapshot 20170618

  1. #1
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    191

    Angry plasmashell :very high usage CPU after snapshot 20170618

    Hello,

    Since the last snapshot op tumbleweed (20170618) installed via "zypper dup", I see via top, a very high CPU usage by the Plasmashell:
    1. login + start top in konsole --> 33%
    2. starting thereafter seamonkey --> 66%
    3. starting Pysol --> 96%
    4. starting gimp --> 137%
    5. After exiting gimp --> 139%
    6 After exiting pysol --> 139%
    7. starting libreoffice writer --> 144%
    8. After closing libreoffice --> 144%

    So the usage doesn't diminish when the programs are closed

    Xorg also uses a lot of CPU: 60-68%

    hardware: HP proliant with nvidia quadro 4100P, Driver:nouveau
    the last snapshot contained also a new kernel: difficult to say if this problem is related to the nouveau driver or plasmashell itself

    I'm pretty sure that this was not the case before this snapshot and I don't remember that I changed something in the settings

    Code:
    top - 08:33:40 up 10:51,  3 users,  load average: 1.75, 1.82, 1.77
    Tasks: 290 total,   3 running, 287 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  5.4 us,  8.8 sy,  0.0 ni, 85.1 id,  0.0 wa,  0.0 hi,  0.0 si,  0.7 st
    KiB Mem : 15965580 total, 12184624 free,  1234908 used,  2546048 buff/cache
    KiB Swap: 12585980 total, 12585980 free,        0 used. 14523608 avail Mem 
    
      PID USER      PR  NI    VIRT    RES    SHR S   %CPU  %MEM     TIME+ COMMAND                                                                                 
     1172 philippe  20   0 4861476 244576 113832 R 145.02 1.532  48:46.82 plasmashell                                                                           
      968 root      20   0  438544 108620  54172 R 66.932 0.680  23:10.00 Xorg                                                                                   
     1927 philippe  20   0 2041828 486500 112792 S  3.386 3.047   4:11.24 seamonkey                                                                               
      509 root      20   0   12056   4600   1476 S  1.394 0.029   8:18.14 haveged                                                                                 
     1787 philippe  20   0  810928  87396  74076 S  1.195 0.547   0:28.82 konsole
    Do you see the same?

    Many thanks in advance
    Philippe
    Tumbleweed (x86_64) Kernel 5.3.5 with KDE plasma

  2. #2
    Join Date
    May 2015
    Location
    Italy
    Posts
    377

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    Same here, CPU usage very high!

    Code:
    top - 09:08:37 up 42 min,  2 users,  load average: 1,24, 1,28, 1,21
    Tasks: 271 total,   3 running, 268 sleeping,   0 stopped,   0 zombie
    %Cpu(s): 16,5 us, 10,0 sy,  0,0 ni, 73,5 id,  0,0 wa,  0,0 hi,  0,0 si,  0,0 st
    KiB Mem : 12003744 total,  4699288 free,  2674084 used,  4630372 buff/cache
    KiB Swap:  7014580 total,  7014580 free,        0 used.  8421340 avail Mem
    
      PID USER      PR  NI    VIRT    RES    SHR S  %CPU  %MEM     TIME+ COMMAND
     5030 cristia+  20   0 5056076 353308 145744 S 45,51 2,943  17:35.89 plasmashell
     1325 root      20   0  507432 136664 106256 R 28,57 1,139  10:32.12 X
     4056 cristia+  20   0 3257900 111024  70296 S 12,62 0,925   5:18.60 kwin_x11
     5508 cristia+  20   0 1149320 321156 207376 S 3,322 2,675   3:28.21 vivaldi-bin
     5350 cristia+  20   0 1413688 223952 124292 S 2,658 1,866   1:29.47 vivaldi-bin
     4104 cristia+  20   0  670948  67708  55960 S 2,326 0,564   0:06.51 yakuake
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  3. #3
    Join Date
    May 2015
    Location
    Italy
    Posts
    377

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    Solved the problem by changing the desktop background to a static image, after reading this thread.

    Hope this helps...
    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD FX-8350 Eight-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,271

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    It seems there are quite a few reports now of higher CPU utilisation following the Qt 5.7 -> 5.9 update. Seemingly not just the slideshow wallpaper being the cause.

    https://bugs.kde.org/show_bug.cgi?id=381280 (and it's associated duplicate reports)


    Even with all animations disabled, no desktop effects, and a static image wallpaper I'm seeing average CPU utilisation of around 8-10% at idle, compared to <1% on an old 13.2/kde4 system.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191018) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,867
    Blog Entries
    14

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    Don't see it here. TW up to date. Plasmashell uses .6 to 2 % CPU.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    191

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    Quote Originally Posted by Cris70 View Post
    Solved the problem by changing the desktop background to a static image, after reading this thread.

    Hope this helps...
    Cris
    Thanks,

    but I have no slideshow but static image as background.

    On more thing I have two display both at 1920*1080 with a desktop extended using the two display as a 3840*1080 display.

    Regards
    Philippe
    Tumbleweed (x86_64) Kernel 5.3.5 with KDE plasma

  7. #7
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    191

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    Quote Originally Posted by tannington View Post
    It seems there are quite a few reports now of higher CPU utilisation following the Qt 5.7 -> 5.9 update. Seemingly not just the slideshow wallpaper being the cause.

    https://bugs.kde.org/show_bug.cgi?id=381280 (and it's associated duplicate reports)


    Even with all animations disabled, no desktop effects, and a static image wallpaper I'm seeing average CPU utilisation of around 8-10% at idle, compared to <1% on an old 13.2/kde4 system.
    Thanks,

    what I find strange is that even if I close my browser (Seamonkey) the CPU usage remains high; just as if plasmashell start a process for each program and these remain running
    Code:
    top - 15:51:04 up 18:08,  3 users,  load average: 1.79, 1.78, 1.75
    Tasks: 288 total,   2 running, 286 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  5.1 us,  9.1 sy,  0.0 ni, 85.2 id,  0.0 wa,  0.0 hi,  0.0 si,  0.7 st
    KiB Mem : 15965580 total, 12538892 free,   865612 used,  2561076 buff/cache
    KiB Swap: 12585980 total, 12585980 free,        0 used. 14910976 avail Mem 
    
      PID USER      PR  NI    VIRT    RES    SHR S   %CPU  %MEM     TIME+ COMMAND                                                                                                               
     1172 philippe  20   0 4865572 245228 113832 R 148.11 1.536 699:50.37 plasmashell                
      968 root      20   0  423948  91512  36344 S 67.396 0.573 321:09.50 Xorg  
      509 root      20   0   12056   4600   1476 S  0.994 0.029  14:36.28 haveged  
     1787 philippe  20   0  810928  87396  74076 S  0.596 0.547   2:41.98 konsole 
     1858 root      20   0   43132   4304   3440 R  0.596 0.027   2:08.20 top        
     1566 mysql     20   0  784388 107740  19432 S  0.398 0.675   0:42.75 mysqld 
        8 root      20   0       0      0      0 S  0.199 0.000   1:29.03 rcu_preempt           
     1165 philippe  20   0 3028316  66444  54084 S  0.199 0.416   0:29.53 kwin_x11 
     1312 philippe  20   0    9968   2044   1816 S  0.199 0.013   0:30.73 ksysguardd 
        1 root      20   0   71048   8188   6112 S  0.000 0.051   0:06.19 systemd 
    My video card is a Nvidia with two displays 1920*1080 set as an extended display (3840 *1080).
    As not everybody seems to have this problem it is maybe the driver nouveau which is the culprit. I have still older kernels and I'll do a test with it

    Regards
    Philippe
    Tumbleweed (x86_64) Kernel 5.3.5 with KDE plasma

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,271

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    Quote Originally Posted by phil524 View Post
    As not everybody seems to have this problem it is maybe the driver nouveau which is the culprit. I have still older kernels and I'll do a test with it
    I'm also using the nouveau driver, but in this instance I don't believe that is of relevance as in the bug report I linked to, ( https://bugs.kde.org/show_bug.cgi?id=381280 ) user "Lukas" states he is using Intel graphics.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191018) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  9. #9
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    191

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    Quote Originally Posted by tannington View Post
    I'm also using the nouveau driver, but in this instance I don't believe that is of relevance as in the bug report I linked to, ( https://bugs.kde.org/show_bug.cgi?id=381280 ) user "Lukas" states he is using Intel graphics.
    Hello,

    with kernel 4.11.4-1 the usage is back to normal as far as I can see
    Code:
    top - 18:19:10 up 3 min,  2 users,  load average: 0,52, 0,61, 0,27
    Tasks: 278 total,   2 running, 276 sleeping,   0 stopped,   0 zombie
    %Cpu(s):  2,2 us,  1,9 sy,  0,0 ni, 95,8 id,  0,0 wa,  0,0 hi,  0,0 si,  0,0 st
    KiB Mem : 16384068 total, 14056512 free,  1258028 used,  1069528 buff/cache
    KiB Swap: 12585980 total, 12585980 free,        0 used. 14811576 avail Mem 
    
      PID USER      PR  NI    VIRT    RES    SHR S   %CPU  %MEM     TIME+ COMMAND             
     2392 philippe  20   0 3929160 176140 107088 S 30,279 1,075   0:43.17 plasmashell    
     2163 root      20   0  427112  91024  55216 S 13,944 0,556   0:20.78 Xorg                
     2587 philippe  20   0 1587460 419780 106676 S  3,586 2,562   0:35.64 seamonkey         
     2764 root      20   0       0      0      0 S  2,191 0,000   0:01.78 kworker/0:4                              
     2565 philippe  20   0  810712  86092  72712 S  1,793 0,525   0:02.63 konsole                  
       18 root      20   0       0      0      0 S  1,394 0,000   0:02.08 kworker/1:0                          
      104 root      20   0       0      0      0 S  1,394 0,000   0:01.28 kworker/8:1                              
        8 root      20   0       0      0      0 S  0,996 0,000   0:01.61 rcu_preempt               
      103 root      20   0       0      0      0 S  0,996 0,000   0:01.36 kworker/5:1             
     2366 philippe  20   0 2953524  68712  53236 S  0,996 0,419   0:01.98 kwin_x11 
      248 root      20   0       0      0      0 S  0,797 0,000   0:01.59 kworker/2:2 
    So I think that it can be related to the new kernel 4.11.5-1 and the nouveau driver.
    I'l open a bug therefor

    Regards
    Philippe
    Tumbleweed (x86_64) Kernel 5.3.5 with KDE plasma

  10. #10
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,271

    Default Re: plasmashell :very high usage CPU after snapshot 20170618

    plasmashell has dropped considerably from your earlier utilisation.

    But, at around 30% is still IMHO too high, does it drop after a few minutes or remain at that level.

    As "Knurpht" wrote earlier in post #5 he's seeing plasmashell using only .6 to 2 % CPU
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191018) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •