Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

  1. #1
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    OK, so I just updated Tumbleweed to 20170615 (zypper dup --no-allow-vendor-change) and am now seeing a substantial increase in CPU utilisation attributed to plasmashell and kwin_X11.

    This is idle, having just logged in.

    Top: http://paste.opensuse.org/4ba701cf

    Utilisation is around 60%+ and doesn't drop.

    This is running on a (now rather elderly) AMD Athlon 64 X2 Dual Core Processor 5600+ CPU.

    Prior to this snapshot utilisation would be <10%

    Googling seems to point the finger at possibly Qt 5.71 -> 5.9

    I've rebooted a couple of times, even done a cold restart, each time the utilisation is very high.

    Anyone else have their cooling fans now going into overdrive?
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  2. #2
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    Hmm... just found the cause: Slideshow Wallpaper, set a static image (or solid colour) and all is "normal" again with CPU utilisation.

    A little more Googling led me to this: https://bugs.kde.org/show_bug.cgi?id=381000
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  3. #3
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    Just for information:

    Setting "cache: true" in "/usr/share/plasma/wallpapers/org.kde.image/contents/ui/main.qml" as per comment #8 in the bug report ( https://bugs.kde.org/show_bug.cgi?id=381000#c8 ) has returned CPU utilisation to normal in my own case.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    Hmm...

    After using the machine normally, at the next image change an hour later the CPU utilisation went up to 70%+ and remained there. So, wrong, setting "cache: true" hasn't solved it.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  5. #5

    Default Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    I'm having the same problem on tumbleweed.
    Using static image as desktop background and "cache: true" didn't help.
    A temporary fix is to set xrender as kwin backend instead of opengl* and desktop becomes usable again.

  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    Quote Originally Posted by ntasos View Post
    ... and "cache: true" didn't help...
    Try setting "asynchronous:false" in the same section of "/usr/share/plasma/wallpapers/org.kde.image/contents/ui/main.qml", ( as per this post https://bugs.kde.org/show_bug.cgi?id=381000#c22 ).

    This seems (for the moment) to have "fixed" the problem on my system.
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  7. #7

    Default Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    Quote Originally Posted by tannington View Post
    Try setting "asynchronous:false" in the same section of "/usr/share/plasma/wallpapers/org.kde.image/contents/ui/main.qml", ( as per this post https://bugs.kde.org/show_bug.cgi?id=381000#c22 ).

    This seems (for the moment) to have "fixed" the problem on my system.
    It turns out that my trouble had nothing to do with plasma/kwin, it probably was a Mesa update that messed up prop. nvidia driver.
    After I reinstaled nvidia everything came back to normal.

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    Quote Originally Posted by ntasos View Post
    It turns out that my trouble had nothing to do with plasma/kwin, it probably was a Mesa update that messed up prop. nvidia driver.
    After I reinstaled nvidia everything came back to normal.
    Yes, TW and the proprietary nvidia drivers are, perhaps, not an ideal combination

    I expect you already know, but take a look at the TW section: https://en.opensuse.org/SDB:NVIDIA_drivers
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  9. #9
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    1,254

    Default Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    Quote Originally Posted by tannington View Post
    Try setting "asynchronous:false" in the same section of "/usr/share/plasma/wallpapers/org.kde.image/contents/ui/main.qml", ( as per this post https://bugs.kde.org/show_bug.cgi?id=381000#c22 ).

    This seems (for the moment) to have "fixed" the problem on my system.
    Well... it worked OK for around a couple of hours after which I switched off the machine.

    Then, on the next start I was back to:

    67% plasmashell
    60% kwin_X11
    39% X

    Reverting back to a static image and restarting plasmashell:

    0.8% plasmashell
    9% kwin_X11
    5% X

    Until the underlying cause of this is found I'll be keeping a static image...
    Regards, Paul

    2x Tumbleweed (Snapshot: 20191011) KDE Plasma 5
    2x Leap 15.1 KDE Plasma 5

  10. #10

    Lightbulb Re: plasmashell / kwin_X11 substantial increase in CPU utilisation after 20170615 snapshot.

    I hit 100% CPU on KDE 5.8 process "plasmashell" after upgrading to Leap 42.3 from 42.2 (and probably 42.1 before that, and who knows what before that). My system has a root partition and a home partition, so on each upgrade the home partition retained KDE plasma configuration and cache files, even though the system/root partition was wiped out with definitely the most recent upgrade, and probably upgrades before that.

    Anyway, I tried several of the troubleshooting steps you see in the forums to stop KDE from pegging the CPU at 100%: deleting 'animated' widgets, disabling compositor, disabling search (baloo and tracker-miner) but it did not solve the problem

    After troubleshooting by creating an entirely new user and logging in with that and using with no problem, I surmised that the true resolution was to delete all of the KDE, Plasma, and QT configuration files in the ~ or home directory. It was necessary to be aggressive and go beyond the usual suspects, deleted from `/.config`, `/cache` and `/.local/share` anything named "plasma", "QT", "tracker" and also things named "kde" more selectively, and also a cache having to do with fonts.

    The deletions reset the desktop configuration but not much else, and so far so good, several hours of no problem from plasmashell. I also disabled search and compositor, but intend to re-enable them if there is no further problem.

    Would be smart for the OpenSuse package managers to identify the specific older configuration file that is causing KDE 5.8 to peg the CPU with the upgrade, and the package maintainers should batch-delete it during the upgrade (with a warning), because KDE simply does *not* work out out-of-box in the standard OpenSuse upgrade procedure as a result of this issue.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •