Results 1 to 6 of 6

Thread: Excessive systemd output?

  1. #1
    Join Date
    Apr 2014
    Location
    "Great North Wet"
    Posts
    147

    Default Excessive systemd output?

    Hi,
    Is there any way to stop this kind of output from systemctl? It just isnt necessary for a normal user, maybe if you are working on systemd it would be helpful, but mostly its annoying when trying to restart some custom services
    Thanks

    Example from: /usr/bin/systemctl -q stop tempmon
    Code:
    Sent message type=method_call sender=n/a destination=org.freedesktop.systemd1 object=/org/freedesktop/systemd1 interface=org.freedesktop.systemd1.Manager member=StopUnit cookie=1 reply_cookie=0 error=n/a                                                                              
    Sent message type=method_call sender=n/a destination=org.freedesktop.systemd1 object=/org/freedesktop/systemd1 interface=org.freedesktop.systemd1.Manager member=GetUnit cookie=2 reply_cookie=0 error=n/a                                                                               
    Sent message type=method_call sender=n/a destination=org.freedesktop.systemd1 object=/org/freedesktop/systemd1/unit/temperature_monitor_2eservice interface=org.freedesktop.DBus.Properties member=Get cookie=3 reply_cookie=0 error=n/a                                                             
    Adding /org/freedesktop/systemd1/job/475066 to the set                                                          
    Got message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1 interface=org.freedesktop.systemd1.Manager member=JobNew cookie=2 reply_cookie=0 error=n/a
    Got D-Bus request: org.freedesktop.systemd1.Manager.JobNew() on /org/freedesktop/systemd1                       
    Got message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1/unit/temperature_monitor_2eservice interface=org.freedesktop.DBus.Properties member=PropertiesChanged cookie=3 reply_cookie=0 error=n/a                                                                                            
    Got D-Bus request: org.freedesktop.DBus.Properties.PropertiesChanged() on /org/freedesktop/systemd1/unit/temperature_monitor_2eservice
    Got message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1/unit/temperature_monitor_2eservice interface=org.freedesktop.DBus.Properties member=PropertiesChanged cookie=4 reply_cookie=0 error=n/a                                                                                                       
    Got D-Bus request: org.freedesktop.DBus.Properties.PropertiesChanged() on /org/freedesktop/systemd1/unit/temperature_monitor_2eservice           
    Got message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1/job/475066 interface=org.freedesktop.DBus.Properties member=PropertiesChanged cookie=5 reply_cookie=0 error=n/a                                                                                                                              
    Got D-Bus request: org.freedesktop.DBus.Properties.PropertiesChanged() on /org/freedesktop/systemd1/job/475066                                  
    Got message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1/unit/temperature_monitor_2eservice interface=org.freedesktop.DBus.Properties member=PropertiesChanged cookie=8 reply_cookie=0 error=n/a                                                                                                                                    
    Got D-Bus request: org.freedesktop.DBus.Properties.PropertiesChanged() on /org/freedesktop/systemd1/unit/temperature_monitor_2eservice                                        
    Got message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1/unit/temperature_monitor_2eservice interface=org.freedesktop.DBus.Properties member=PropertiesChanged cookie=9 reply_cookie=0 error=n/a
    Got D-Bus request: org.freedesktop.DBus.Properties.PropertiesChanged() on /org/freedesktop/systemd1/unit/temperature_monitor_2eservice
    Got message type=signal sender=n/a destination=n/a object=/org/freedesktop/systemd1 interface=org.freedesktop.systemd1.Manager member=JobRemoved cookie=10 reply_cookie=0 error=n/a
    Got D-Bus request: org.freedesktop.systemd1.Manager.JobRemoved() on /org/freedesktop/systemd1
    Got result done/Success for job temperature_monitor.service
    Turkey Creek Jack Johnson: Nobody move!
    Doc Holliday: Nonsense. By all means, move.

  2. #2

    Default AW: Excessive systemd output?

    Well, I do not see such output here (and never have):
    Code:
    wolfi@amiga:~> lsb-release -d
    Description:    openSUSE Leap 42.2
    wolfi@amiga:~> systemctl -q stop tempmon
    Failed to stop tempmon.service: Unit tempmon.service not loaded.
    wolfi@amiga:~> systemctl -q stop mysql
    wolfi@amiga:~>
    So you must have enabled it somehow...

    Things I would check:
    - kernel boot options:
    Code:
    cat /proc/cmdline
    - systemd's config files in /etc/systemd/, in particular the "LogLevel" option in system.conf.

    Looks very much like systemd's log-level is set to "debug".

  3. #3
    Join Date
    Apr 2014
    Location
    "Great North Wet"
    Posts
    147

    Default Re: Excessive systemd output?

    /proc/cmdline just shows the expected kernel cmd line, no extra options were specified apparently
    /etc/systemd/system.conf is at defaults, I want to try setting LogLevel=warning but not sure how to make it take effect short of rebooting.
    I'd rather not reboot if possible as there is a weather station running on that system
    Turkey Creek Jack Johnson: Nobody move!
    Doc Holliday: Nonsense. By all means, move.

  4. #4
    Join Date
    Apr 2014
    Location
    "Great North Wet"
    Posts
    147

    Default Re: Excessive systemd output?

    ok, it looks like to get systemd to re-read /etc/systemd/system.conf you can execute 'systemctl daemon-reexec'
    but after setting /etc/systemd/system.conf > LogLevel=error and then doing a systemctl daemon-reexec my problem persists
    Turkey Creek Jack Johnson: Nobody move!
    Doc Holliday: Nonsense. By all means, move.

  5. #5

    Default Re: Excessive systemd output?

    It shouldn't be necessary to change the defaults.

    As I said, I don't get those messages with the default settings, but I can reproduce your problem by setting LogLevel=debug in /etc/systemd/system.conf and re-exec systemd (though the messages go to the log, not the shell, this is apparently configurable with the LogTarget option though).

    Maybe there's some override elsewhere in the directories where systemd looks for its config?
    According to the man page, these are searched:
    /etc/systemd/system.conf, /etc/systemd/system.conf.d/*.conf,

    /run/systemd/system.conf.d/*.conf,

    /usr/lib/systemd/system.conf.d/*.conf
    Last edited by wolfi323; 16-Jun-2017 at 07:48.

  6. #6
    Join Date
    Sep 2012
    Posts
    5,366

    Default Re: Excessive systemd output?

    systemd debug level can also be enabled (and disabled) with signal to PID 1. This should be visible in logs though.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •