Results 1 to 5 of 5

Thread: Zypper always prompts to accept key

  1. #1

    Question Zypper always prompts to accept key

    Since at least March, I get the same prompt to accept key:
    Code:
    linux-f5tb:/home/Kilbert # zypper dup --no-allow-vendor-change
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Retrieving repository 'KDE:Extra' metadata ------------------------------------------------------------------------------------------------------------------------------------------------[\]
    
    New repository or package signing key received:
    
      Repository:       KDE:Extra                                           
      Key Name:         KDE:Extra OBS Project <KDE:Extra@build.opensuse.org>
      Key Fingerprint:  1A04160E 8C77D8FE 43CA364B 20F8C4F4 0D210A40        
      Key Created:      Thu 27 Oct 2016 03:38:47 PM EDT                     
      Key Expires:      Sat 05 Jan 2019 02:38:46 PM EST                     
      Rpm Name:         gpg-pubkey-0d210a40-581257c7
    I always choose "a" to accept, and every time I run it I copy it to a text file to compare to the previous key and its always the same.
    What can be wrong, is there a text file somewhere I can update or delete/rebuild?
    thanks
    JOhn

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,865
    Blog Entries
    15

    Default Re: Zypper always prompts to accept key

    Hi
    How did you add the repo?

    What about in the rpm database and repository key checking?
    Code:
    rpm -qa |grep pubkey
    rpm --rebuilddb
    zypper lr -E
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Zypper always prompts to accept key

    Thanks Malcolm, I tried that,

    Not sure if it worked, but extras showed up, but the extras did not refresh, but i will try again in a few days

    Code:
    Kilbert@linux-f5tb:~> su
    Password: 
    linux-f5tb:/home/Kilbert # rpm -qa |grep pubkey
    gpg-pubkey-0d210a40-581257c6
    gpg-pubkey-307e3d54-4be01a65
    gpg-pubkey-6f88bb2f-54032bd3
    gpg-pubkey-6867f5be-4d77cecd
    gpg-pubkey-1abd1afb-54176598
    gpg-pubkey-3dbdc284-53674dd4
    linux-f5tb:/home/Kilbert # rpm --rebuilddb
    linux-f5tb:/home/Kilbert # zypper lr -E
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                               | Name                        | Enabled | GPG Check | Refresh
    ---+-------------------------------------+-----------------------------+---------+-----------+--------
     1 | Libdvdcss                           | Libdvdcss                   | Yes     | (r ) Yes  | Yes    
     2 | Packman-Tumbleweed                  | Packman-Tumbleweed          | Yes     | (r ) Yes  | Yes    
     3 | Plex                                | Plex                        | Yes     | ( p) Yes  | Yes    
     5 | http-download.opensuse.org-9d6a228c | KDE:Extra                   | Yes     | (r ) Yes  | Yes    
     6 | openSUSE-20160720-0                 | openSUSE-Tumbleweed-oss     | Yes     | (r ) Yes  | Yes    
     8 | repo-non-oss                        | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes    
    10 | repo-update                         | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes    
    linux-f5tb:/home/Kilbert # zypper dup --no-allow-vendor-change
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Retrieving repository 'Packman-Tumbleweed' metadata ....................................................................................................................................[done]
    Building repository 'Packman-Tumbleweed' cache .........................................................................................................................................[done]
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    The following 3 NEW packages are going to be installed:
      libmpeg2convert0 normalize transcode
    
    3 new packages to install.
    Overall download size: 1.5 MiB. Already cached: 0 B. After the operation, additional 7.2 MiB will be used.
    Thanks
    John

  4. #4

    Default Re: Zypper always prompts to accept key

    It's a bug in PackageKit ('s zypp backend):
    http://bugzilla.opensuse.org/show_bug.cgi?id=1036659

  5. #5
    Join Date
    Feb 2016
    Location
    Berlin
    Posts
    357

    Default Re: Zypper always prompts to accept key

    i disabled update apper from menu offered by right clicking in the toolbar icons, have not had the issue since

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •