Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: HDD troubles

  1. #1
    Join Date
    Dec 2008
    Location
    Rotterdam (NL)
    Posts
    771

    Default HDD troubles

    Volgende melding gekregen, helaas zal de hdd het wel opgegeven hebben. maar wil toch ook kijken of ik nog wat kan redden aan spul. Hoe gaat dat nu lukken. Ben even de juiste weg zoek.

    Er is een fout opgetreden bij het aanspreken van 'Persoonlijke map', het systeem geeft de volgende foutmelding weer: De gevraagde bewerking is mislukt: Error mounting /dev/sdh3 at /run/media/ben/c8407ea8-be46-45c9-91f5-f3e80b107188: Command-line `mount -t "xfs" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdh3" "/run/media/ben/c8407ea8-be46-45c9-91f5-f3e80b107188"' exited with non-zero exit status 32: mount: mount /dev/sdh3 on /run/media/ben/c8407ea8-be46-45c9-91f5-f3e80b107188 failed: Structure needs cleaning
    HP Z420 Intel Xeon & Lenovo T440s Intel I7vPro
    openSUSE Tumbleweed KDE
    Raspberry PI3 met openSUSE TW en Raspbian
    Linux counter #241023

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,871

    Default Re: HDD troubles

    Hallo Ben,

    Het gaat kennelijk om een verwijderbaar apparaat dat je probeert te gebruiken. Dus niet om éën van de disk (partities) die je altijd gebruikt (zoals / and eventueel /home).

    Klopt dat?
    Henk van Velden

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,871

    Default Re: HDD troubles

    Hallo Ben,

    Kennlijk zit je niet springend om hulp te wachten.

    Je hebt kennelijk nogal wat mass-storage apparaten aangesloten. Weet je welke sdh is?
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,654
    Blog Entries
    14

    Default Re: HDD troubles

    Quote Originally Posted by Benmh View Post
    Volgende melding gekregen, helaas zal de hdd het wel opgegeven hebben. maar wil toch ook kijken of ik nog wat kan redden aan spul. Hoe gaat dat nu lukken. Ben even de juiste weg zoek.

    Er is een fout opgetreden bij het aanspreken van 'Persoonlijke map', het systeem geeft de volgende foutmelding weer: De gevraagde bewerking is mislukt: Error mounting /dev/sdh3 at /run/media/ben/c8407ea8-be46-45c9-91f5-f3e80b107188: Command-line `mount -t "xfs" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdh3" "/run/media/ben/c8407ea8-be46-45c9-91f5-f3e80b107188"' exited with non-zero exit status 32: mount: mount /dev/sdh3 on /run/media/ben/c8407ea8-be46-45c9-91f5-f3e80b107188 failed: Structure needs cleaning
    Kijk eens even naar xfs_repair. Heeft ook man pages.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,654
    Blog Entries
    14

    Default Re: HDD troubles

    O, ja, en aannemend dat dit een externe schijf is ( anders zou ie niet op /run/media .... aangekoppeld worden ), draai eens
    Code:
    dmesg -w
    , sluit de schijf aan en kijk naar de output. Evt.. hier kopiëren tussen CODE tags ( #)
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Dec 2008
    Location
    Rotterdam (NL)
    Posts
    771

    Default Re: HDD troubles

    Quote Originally Posted by Knurpht View Post
    O, ja, en aannemend dat dit een externe schijf is ( anders zou ie niet op /run/media .... aangekoppeld worden ), draai eens
    Code:
    dmesg -w
    , sluit de schijf aan en kijk naar de output. Evt.. hier kopiëren tussen CODE tags ( #)
    Ik heb deze hdd uit een andere pc gehaald en aan mijn pc gehangen.. Ben inderdaad de CODE tags vergeten, sorry.
    Zit nu even niet thuis, zal het even doen als ik weer daar ben.
    Zal de hdd eerst in de originele pc proppen.
    HP Z420 Intel Xeon & Lenovo T440s Intel I7vPro
    openSUSE Tumbleweed KDE
    Raspberry PI3 met openSUSE TW en Raspbian
    Linux counter #241023

  7. #7
    Join Date
    Dec 2008
    Location
    Rotterdam (NL)
    Posts
    771

    Default Re: HDD troubles

    Zo heb de hdd even terug gezet in de pc. Kan nu IceWM opstarten , echter zonder internet. Snapper rollback wil ook niet werken.
    Er is in ieder geval een interne error XFS_WANT_CORRUPTED_RETURN op sda3
    Zal toch moeten gaan zoeken nu.

    Code:
    An error occurred while accessing '190,9 GiB harde schijf', the system responded: De gevraagde bewerking is mislukt: Error mounting /dev/sda3 at /run/media/linux/c8407ea8-be46-45c9-91f5-f3e80b107188: Command-line `mount -t "xfs" -o "uhelper=udisks2,nodev,nosuid" "/dev/sda3" "/run/media/linux/c8407ea8-be46-45c9-91f5-f3e80b107188"' exited with non-zero exit status 32: mount: mount /dev/sda3 on /run/media/linux/c8407ea8-be46-45c9-91f5-f3e80b107188 failed: Structure needs cleaning
    Heb nu de pc gestart met een live usb stick 42.2
    Last edited by Benmh; 13-Jun-2017 at 10:50. Reason: meer nieuws
    HP Z420 Intel Xeon & Lenovo T440s Intel I7vPro
    openSUSE Tumbleweed KDE
    Raspberry PI3 met openSUSE TW en Raspbian
    Linux counter #241023

  8. #8
    Join Date
    Dec 2008
    Location
    Rotterdam (NL)
    Posts
    771

    Default Re: HDD troubles

    dmesg -w geeft het volgende heb wel een deel info niet erbij gezet, er is duidelijk wat fout met sda3.

    Code:
    [
    [   14.783701] systemd-fstab-generator[1236]: Failed to create mount unit file /run/systemd/generator/-.mount, as it already exists. Duplicate entry in /etc/fstab?             
    [   15.157647] systemd[1230]: /usr/lib/systemd/system-generators/systemd-fstab-generator failed with error code 1.
    [   15.246491] systemd[1]: read\x2donly.mount: Unit is bound to inactive unit dev-loop0.device. Stopping, too.
    [   15.246586] systemd[1]: livecd.mount: Unit is bound to inactive unit dev-sdb2.device. Stopping, too.
    [   15.246757] systemd[1]: read\x2dwrite.mount: Unit is bound to inactive unit dev-sdb3.device. Stopping, too.
    [   15.260857] systemd[1]: nss-lookup.target: Dependency Before=nss-lookup.target dropped
    [   15.267044] systemd[1]: Reached target Remote File Systems (Pre).
    [   15.267205] systemd[1]: Reached target System Time Synchronized.
    [   16.070465] Adding 2103292k swap on /dev/sda1.  Priority:-1 extents:1 across:2103292k FS
    [   18.615946] systemd-journald[1267]: Received request to flush runtime journal from PID 1
    [   18.715015] audit: type=1305 audit(1497375720.658:2): audit_pid=1319 old=0 auid=4294967295 ses=4294967295 res=1
    [   19.978453] kvm: disabled by bios
    [   20.147892] input: PC Speaker as /devices/platform/pcspkr/input/input9
    [   20.148355] kvm: disabled by bios
    [   20.158264] i2c i2c-7: nForce2 SMBus adapter at 0x2d00
    [   20.158276] ACPI Warning: SystemIO range 0x0000000000002E00-0x0000000000002E3F conflicts with OpRegion 0x0000000000002E00-0x0000000000002E3F (\SM00) (20150930/utaddress-254)
    [   20.158277] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
    [   20.298254] acpi-cpufreq: overriding BIOS provided _PSD data
    [   20.391153] EDAC MC: Ver: 3.0.0
    [   20.655761] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
    [   20.730369] MCE: In-kernel MCE decoding enabled.
    [   20.871659] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 19
    [   20.926936] firewire_ohci 0000:01:05.0: added OHCI v1.0 device as card 0, 8 IR + 8 IT contexts, quirks 0x0
    [   21.178936] AMD64 EDAC driver v3.4.0
    [   21.178998] EDAC amd64: DRAM ECC disabled.
    [   21.179006] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
                    Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
                    (Note that use of the override may cause unknown side effects.)
    [   21.443510] firewire_core 0000:01:05.0: created device fw0: GUID 001e8c0000b53372, S400
    [   21.826236] forcedeth 0000:00:0a.0 eth1: renamed from eth0
    [   22.001572] ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 20
    [   22.001590] snd_hda_intel 0000:00:07.0: Disabling MSI
    [   22.278799] raid6: sse2x1   gen()  1213 MB/s
    [   22.346757] raid6: sse2x1   xor()  1070 MB/s
    [   22.414777] raid6: sse2x2   gen()  2041 MB/s
    [   22.482760] raid6: sse2x2   xor()  1820 MB/s
    [   22.550775] raid6: sse2x4   gen()  2350 MB/s
    [   22.618760] raid6: sse2x4   xor()  1157 MB/s
    [   22.618768] raid6: using algorithm sse2x4 gen() 2350 MB/s
    [   22.618770] raid6: .... xor() 1157 MB/s, rmw enabled
    [   22.618772] raid6: using intx1 recovery algorithm
    [   22.691037] xor: measuring software checksum speed
    [   22.730743]    prefetch64-sse:  3290.000 MB/sec
    [   22.770738]    generic_sse:  3114.000 MB/sec
    [   22.770741] xor: using function: prefetch64-sse (3290.000 MB/sec)
    [   22.977091] BTRFS: using crc32c-generic for crc32c
    [   22.977676] Btrfs loaded, assert=on
    [   22.978136] BTRFS: device fsid a82aad6f-bad5-4ddf-b743-6f2d5f92b1c1 devid 1 transid 162873 /dev/sda2
    [   23.438814] snd_hda_codec_realtek hdaudioC0D0: ALC888: SKU not ready 0x411111f0
    [   23.526808] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC888: line_outs=4 (0x14/0x15/0x16/0x17/0x0) type:line
    [   23.526826] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
    [   23.526838] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
    [   23.526844] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
    [   23.526849] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x1e/0x0
    [   23.526852] snd_hda_codec_realtek hdaudioC0D0:    inputs:
    [   23.526859] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
    [   23.526864] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
    [   23.526869] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1c
    [   26.479995] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:07.0/sound/card0/input10
    [   26.482042] input: HDA NVidia Front Mic as /devices/pci0000:00/0000:00:07.0/sound/card0/input11
    [   26.488289] input: HDA NVidia Rear Mic as /devices/pci0000:00/0000:00:07.0/sound/card0/input12
    [   26.488525] input: HDA NVidia Line as /devices/pci0000:00/0000:00:07.0/sound/card0/input13
    [   26.490820] input: HDA NVidia Line Out Front as /devices/pci0000:00/0000:00:07.0/sound/card0/input14
    [   26.491062] input: HDA NVidia Line Out Surround as /devices/pci0000:00/0000:00:07.0/sound/card0/input15
    [   26.491254] input: HDA NVidia Line Out CLFE as /devices/pci0000:00/0000:00:07.0/sound/card0/input16
    [   26.491439] input: HDA NVidia Line Out Side as /devices/pci0000:00/0000:00:07.0/sound/card0/input17
    [   26.491631] input: HDA NVidia Front Headphone as /devices/pci0000:00/0000:00:07.0/sound/card0/input18
    [   81.543673] usb 3-2: USB disconnect, device number 2
    [   83.188502] usb 3-2: new low-speed USB device number 3 using ohci-pci
    [   83.402570] usb 3-2: New USB device found, idVendor=045e, idProduct=0084
    [   83.402585] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [   83.402589] usb 3-2: Product: Microsoft Basic Optical Mouse 
    [   83.402592] usb 3-2: Manufacturer: Microsoft 
    [   83.415846] input: Microsoft  Microsoft Basic Optical Mouse  as /devices/pci0000:00/0000:00:02.0/usb3/3-2/3-2:1.0/0003:045E:0084.0004/input/input19
    [   83.415977] hid-generic 0003:045E:0084.0004: input,hidraw0: USB HID v1.11 Mouse [Microsoft  Microsoft Basic Optical Mouse ] on usb-0000:00:02.0-2/input0
    [  109.187821] vboxguest: loading out-of-tree module taints kernel.
    [  109.191430] vboxguest: PCI device not found, probably running on physical hardware.
    [  109.575513] vboxguest: PCI device not found, probably running on physical hardware.
    [  111.928057] ip6_tables: (C) 2000-2006 Netfilter Core Team
    [  112.318887] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
    [  112.662786] ip_tables: (C) 2000-2006 Netfilter Core Team
    [  118.306149] forcedeth 0000:00:0a.0 eth1: MSI enabled
    [  119.403125] NET: Registered protocol family 17
    [  260.681515] SGI XFS with ACLs, security attributes, realtime, no debug enabled
    [  260.721131] XFS (sda3): Mounting V5 Filesystem
    [  260.930805] XFS (sda3): Starting recovery (logdev: internal)
    [  261.037135] XFS (sda3): Internal error XFS_WANT_CORRUPTED_RETURN at line 188 of file ../fs/xfs/libxfs/xfs_dir2_data.c.  Caller xfs_dir3_block_verify+0x85/0x90 [xfs]
    [  261.037157] CPU: 0 PID: 3235 Comm: mount Tainted: G           O     4.4.27-2-default #1
    [  261.037160] Hardware name: Hewlett-Packard HP Pro 3015 Microtower PC/2A9Eh, BIOS 5.13    11/12/2009
    [  261.037167]  0000000000000000 ffffffff81327657 ffff88000382bdf0 ffff88000382b000
    [  261.037172]  ffffffffa097e6fb ffff88000382b030 ffff88000382bdf0 ffff88006c669800
    [  261.037177]  0000002200408800 ffff880059ebfd40 ffff88000382bff8 ffff88000382b6b1
    [  261.037178] Call Trace:
    [  261.037207]  [<ffffffff81019e69>] dump_trace+0x59/0x320
    [  261.037218]  [<ffffffff8101a22a>] show_stack_log_lvl+0xfa/0x180
    [  261.037231]  [<ffffffff8101afd1>] show_stack+0x21/0x40
    [  261.037240]  [<ffffffff81327657>] dump_stack+0x5c/0x85
    [  261.037306]  [<ffffffffa097e6fb>] __xfs_dir3_data_check+0x44b/0x560 [xfs]
    [  261.037398]  [<ffffffffa097c5d5>] xfs_dir3_block_verify+0x85/0x90 [xfs]
    [  261.037467]  [<ffffffffa097c760>] xfs_dir3_block_write_verify+0x30/0xe0 [xfs]
    [  261.037538]  [<ffffffffa0997f66>] _xfs_buf_ioapply+0x86/0x400 [xfs]
    [  261.037609]  [<ffffffffa0999b29>] xfs_buf_submit+0x59/0x1d0 [xfs]
    [  261.037682]  [<ffffffffa0999e16>] __xfs_buf_delwri_submit+0x176/0x290 [xfs]
    [  261.037754]  [<ffffffffa099ac5f>] xfs_buf_delwri_submit+0x2f/0xf0 [xfs]
    [  261.037834]  [<ffffffffa09c4b60>] xlog_recover_commit_trans+0x1a0/0x250 [xfs]
    [  261.037912]  [<ffffffffa09c4c8d>] xlog_recovery_process_trans+0x7d/0xb0 [xfs]
    [  261.037999]  [<ffffffffa09c4e05>] xlog_recover_process_data+0x75/0xc0 [xfs]
    [  261.038076]  [<ffffffffa09c521e>] xlog_do_recovery_pass+0x3ce/0x4b0 [xfs]
    [  261.038156]  [<ffffffffa09c5379>] xlog_do_log_recovery+0x79/0xc0 [xfs]
    [  261.038234]  [<ffffffffa09c53d1>] xlog_do_recover+0x11/0xd0 [xfs]
    [  261.038310]  [<ffffffffa09c5e66>] xlog_recover+0xa6/0x140 [xfs]
    [  261.038385]  [<ffffffffa09ba0e1>] xfs_log_mount+0x241/0x2b0 [xfs]
    [  261.038461]  [<ffffffffa09b164f>] xfs_mountfs+0x49f/0x820 [xfs]
    [  261.038539]  [<ffffffffa09b4699>] xfs_fs_fill_super+0x429/0x520 [xfs]
    [  261.038555]  [<ffffffff8120854e>] mount_bdev+0x19e/0x1e0
    [  261.038566]  [<ffffffff81208e64>] mount_fs+0x34/0x170
    [  261.038575]  [<ffffffff81223cb2>] vfs_kern_mount+0x62/0x110
    [  261.038583]  [<ffffffff812261a3>] do_mount+0x213/0xcf0
    [  261.038592]  [<ffffffff81226f65>] SyS_mount+0x85/0xd0
    [  261.038601]  [<ffffffff816093f2>] entry_SYSCALL_64_fastpath+0x16/0x71
    [  261.044567] DWARF2 unwinder stuck at entry_SYSCALL_64_fastpath+0x16/0x71
    
    [  261.044569] Leftover inexact backtrace:
    
    [  261.044685] XFS (sda3): Metadata corruption detected at xfs_dir3_block_write_verify+0xc8/0xe0 [xfs], xfs_dir3_block block 0x5f702e0
    [  261.044695] XFS (sda3): Unmount and run xfs_repair
    [  261.044697] XFS (sda3): First 64 bytes of corrupted metadata buffer:
    [  261.044702] ffff88000382b000: 58 44 42 33 94 85 cf f5 00 00 00 00 05 f7 02 e0  XDB3............
    [  261.044705] ffff88000382b010: 00 00 00 20 00 02 61 fe c8 40 7e a8 be 46 45 c9  ... ..a..@~..FE.
    [  261.044707] ffff88000382b020: 91 f5 f3 e8 0b 10 71 88 00 00 00 00 08 00 00 42  ......q........B
    [  261.044710] ffff88000382b030: 03 40 00 48 05 50 00 48 06 e0 00 48 00 00 00 00  .@.H.P.H...H....
    [  261.044715] XFS (sda3): xfs_do_force_shutdown(0x8) called from line 1254 of file ../fs/xfs/xfs_buf.c.  Return address = 0xffffffffa0997f96
    [  261.044721] XFS (sda3): Corruption of in-memory data detected.  Shutting down filesystem
    [  261.044724] XFS (sda3): Please umount the filesystem and rectify the problem(s)
    [  261.046389] XFS (sda3): log mount/recovery failed: error -117
    [  261.046454] XFS (sda3): log mount failed
    [  297.217076] BTRFS info (device sda2): disk space caching is enabled
    [  297.217084] BTRFS: has skinny extents
    [  297.549299] BTRFS: checking UUID tree
    [  299.943468] XFS (sda3): Mounting V5 Filesystem
    [  300.153137] XFS (sda3): Starting recovery (logdev: internal)
    [  300.242805] XFS (sda3): Internal error XFS_WANT_CORRUPTED_RETURN at line 188 of file ../fs/xfs/libxfs/xfs_dir2_data.c.  Caller xfs_dir3_block_verify+0x85/0x90 [xfs]
    [  300.242827] CPU: 0 PID: 3367 Comm: mount Tainted: G           O     4.4.27-2-default #1
    [  300.242830] Hardware name: Hewlett-Packard HP Pro 3015 Microtower PC/2A9Eh, BIOS 5.13    11/12/2009
    [  300.242837]  0000000000000000 ffffffff81327657 ffff88004ac35df0 ffff88004ac35000
    [  300.242842]  ffffffffa097e6fb ffff88004ac35030 ffff88004ac35df0 ffff8800387e8000
    [  300.242854]  0000002200401000 ffff880056695780 ffff88004ac35ff8 ffff88004ac356b1
    [  300.242859] Call Trace:
    [  300.242887]  [<ffffffff81019e69>] dump_trace+0x59/0x320
    [  300.242901]  [<ffffffff8101a22a>] show_stack_log_lvl+0xfa/0x180
    [  300.242910]  [<ffffffff8101afd1>] show_stack+0x21/0x40
    [  300.242924]  [<ffffffff81327657>] dump_stack+0x5c/0x85
    [  300.242987]  [<ffffffffa097e6fb>] __xfs_dir3_data_check+0x44b/0x560 [xfs]
    [  300.243082]  [<ffffffffa097c5d5>] xfs_dir3_block_verify+0x85/0x90 [xfs]
    [  300.243153]  [<ffffffffa097c760>] xfs_dir3_block_write_verify+0x30/0xe0 [xfs]
    [  300.243225]  [<ffffffffa0997f66>] _xfs_buf_ioapply+0x86/0x400 [xfs]
    [  300.243297]  [<ffffffffa0999b29>] xfs_buf_submit+0x59/0x1d0 [xfs]
    [  300.243370]  [<ffffffffa0999e16>] __xfs_buf_delwri_submit+0x176/0x290 [xfs]
    [  300.243443]  [<ffffffffa099ac5f>] xfs_buf_delwri_submit+0x2f/0xf0 [xfs]
    [  300.243520]  [<ffffffffa09c4b60>] xlog_recover_commit_trans+0x1a0/0x250 [xfs]
    [  300.243600]  [<ffffffffa09c4c8d>] xlog_recovery_process_trans+0x7d/0xb0 [xfs]
    [  300.243680]  [<ffffffffa09c4e05>] xlog_recover_process_data+0x75/0xc0 [xfs]
    [  300.243757]  [<ffffffffa09c521e>] xlog_do_recovery_pass+0x3ce/0x4b0 [xfs]
    [  300.243838]  [<ffffffffa09c5379>] xlog_do_log_recovery+0x79/0xc0 [xfs]
    [  300.243916]  [<ffffffffa09c53d1>] xlog_do_recover+0x11/0xd0 [xfs]
    [  300.243993]  [<ffffffffa09c5e66>] xlog_recover+0xa6/0x140 [xfs]
    [  300.244070]  [<ffffffffa09ba0e1>] xfs_log_mount+0x241/0x2b0 [xfs]
    [  300.244147]  [<ffffffffa09b164f>] xfs_mountfs+0x49f/0x820 [xfs]
    [  300.244226]  [<ffffffffa09b4699>] xfs_fs_fill_super+0x429/0x520 [xfs]
    [  300.244243]  [<ffffffff8120854e>] mount_bdev+0x19e/0x1e0
    [  300.244263]  [<ffffffff81208e64>] mount_fs+0x34/0x170
    [  300.244274]  [<ffffffff81223cb2>] vfs_kern_mount+0x62/0x110
    [  300.244284]  [<ffffffff812261a3>] do_mount+0x213/0xcf0
    [  300.244295]  [<ffffffff81226f65>] SyS_mount+0x85/0xd0
    [  300.244306]  [<ffffffff816093f2>] entry_SYSCALL_64_fastpath+0x16/0x71
    [  300.250262] DWARF2 unwinder stuck at entry_SYSCALL_64_fastpath+0x16/0x71
    
    [  300.250264] Leftover inexact backtrace:
    
    [  300.250385] XFS (sda3): Metadata corruption detected at xfs_dir3_block_write_verify+0xc8/0xe0 [xfs], xfs_dir3_block block 0x5f702e0
    [  300.250391] XFS (sda3): Unmount and run xfs_repair
    [  300.250395] XFS (sda3): First 64 bytes of corrupted metadata buffer:
    [  300.250400] ffff88004ac35000: 58 44 42 33 94 85 cf f5 00 00 00 00 05 f7 02 e0  XDB3............
    [  300.250405] ffff88004ac35010: 00 00 00 20 00 02 61 fe c8 40 7e a8 be 46 45 c9  ... ..a..@~..FE.
    [  300.250410] ffff88004ac35020: 91 f5 f3 e8 0b 10 71 88 00 00 00 00 08 00 00 42  ......q........B
    [  300.250414] ffff88004ac35030: 03 40 00 48 05 50 00 48 06 e0 00 48 00 00 00 00  .@.H.P.H...H....
    [  300.250421] XFS (sda3): xfs_do_force_shutdown(0x8) called from line 1254 of file ../fs/xfs/xfs_buf.c.  Return address = 0xffffffffa0997f96
    [  300.250425] XFS (sda3): Corruption of in-memory data detected.  Shutting down filesystem
    [  300.250430] XFS (sda3): Please umount the filesystem and rectify the problem(s)
    [  300.280527] XFS (sda3): log mount/recovery failed: error -117
    [  300.280622] XFS (sda3): log mount failed
    HP Z420 Intel Xeon & Lenovo T440s Intel I7vPro
    openSUSE Tumbleweed KDE
    Raspberry PI3 met openSUSE TW en Raspbian
    Linux counter #241023

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,654
    Blog Entries
    14

    Default Re: HDD troubles

    Code:
    [  300.250385] XFS (sda3): Metadata corruption detected at xfs_dir3_block_write_verify+0xc8/0xe0 [xfs], xfs_dir3_block block 0x5f702e0
    [  300.250391] XFS (sda3): Unmount and run xfs_repair
    Daar zit de crux.

    Code:
    su -
    umount /dev/sda3
    xfs_repair /dev/sda3
    Als er anders niks meer mee te beginnen is ( schijf kan een tik gehad hebben en dan houdt het een keer op ), kun je nog
    Code:
    xfs_repair -d /dev/sda3
    maar die "-d" staat voor "repair dangerously".
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  10. #10
    Join Date
    Dec 2008
    Location
    Rotterdam (NL)
    Posts
    771

    Default Re: HDD troubles

    Quote Originally Posted by Knurpht View Post
    Code:
    [  300.250385] XFS (sda3): Metadata corruption detected at xfs_dir3_block_write_verify+0xc8/0xe0 [xfs], xfs_dir3_block block 0x5f702e0
    [  300.250391] XFS (sda3): Unmount and run xfs_repair
    Daar zit de crux.

    Code:
    su -
    umount /dev/sda3
    xfs_repair /dev/sda3
    Als er anders niks meer mee te beginnen is ( schijf kan een tik gehad hebben en dan houdt het een keer op ), kun je nog
    Code:
    xfs_repair -d /dev/sda3
    maar die "-d" staat voor "repair dangerously".
    Bedankt GertJan ,
    daar zal wel een rottigheidje uit gaan rollen. Hoop dat ik in ieder geval nog wat data kan overhevelen naar een andere hdd.
    Waar de eventuele tik vandaan kan komen is niet belangrijk, helaas was dit wel na een update.
    Is trouwens niet de eerste pc die ik met dit probleem had, helaas ook steeds met Leap 42.1
    Op deze pc kreeg ik het probleem niet getackeld, de andere kon ik nog met een snapper oplossing terug krijgen.
    HP Z420 Intel Xeon & Lenovo T440s Intel I7vPro
    openSUSE Tumbleweed KDE
    Raspberry PI3 met openSUSE TW en Raspbian
    Linux counter #241023

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •