I first posted this in the setup/install forum but got no replies at all, so I'm wondering if it is actually an application problem:

I set up mail with amavis and clamd and spamassassin but not DKIM and got that all successfully running.
I then additionally selected DKIM in the YAST email setup, and everything continued to work as before.
I ran /etc/amavisd showkeys, and obtained the key and installed it in my DNS.
I ran /etc/amavisd testkeys and got a "pass" result.
Inbound mails with DKIM signatures are being checked and passed.
However, the outgoing mails are not getting a DKIM signature.

My amavisd.conf file is as set up by YAST and includes the following lines:

$enable_db = 1; # enable use of BerkeleyDB/libdb (SNMP and nanny)
# $enable_zmq = 1; # enable use of ZeroMQ (SNMP and nanny)
$nanny_details_level = 2; # nanny verbosity: 1: traditional, 2: detailed
$enable_dkim_verification = 1; # enable DKIM signatures verification
$enable_dkim_signing = 1;
dkim_key('this-domain.com', 'default', '/var/db/dkim/this-domain.com.pem'); (With "this-domain" being my actual domain.)
@local_domains_maps = ( [".$mydomain"] ); # list of all local domains (with .$mydomain just as shown.)
@mynetworks = qw( 127.0.0.0/8 [::1] [FE80::]/10 [FEC0::]/10
10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 );

Please advise what I need to check next or what more info you need.

Thanks