Results 1 to 4 of 4

Thread: Dependency issues when trying to update using YAST.

  1. #1

    Default Dependency issues when trying to update using YAST.

    Hello,

    I usually update TW once a month using YAST (Install/Remove Software). This time when I go to "Package" > "All Packages" > "Update if newer version available". I get this:



    If instead i choose "All Packages" > "Update Unconditionally", only the one in the middle (libgcj-...) shows up. I searched the web, but didnt get anywhere. I dont know how to proceed. Please advice.

  2. #2
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,022

    Default Re: Dependency issues when trying to update using YAST.

    The entire system switched over to GCC7, tossing old GCC6 devel files is a-ok.

    sudo zypper dup

    from a command line should work better tbh.
    .: miuku #suse @ irc.freenode.net
    :: miuku@opensuse.org

    .: h​ttps://download.opensuse.org/repositories/home:/Miuku/

  3. #3

    Default Re: Dependency issues when trying to update using YAST.

    or you could load software manager select the oss repository and click on switch packages to oss repo. this usually makes it easier

  4. #4

    Default Re: Dependency issues when trying to update using YAST.

    Thanks for the replies guys,

    I'm switching packages to the OSS repo, like you mentioned jshand2015. It showed just the one in the middle (from 1st post). I'm taking your advice Miuku and selected:

    * de-installation of libgcj-devel-6.1.1.x86_64
    * de-installation of libgcj-devel-gcc6-6.3.1+r245113-1.5.x86_64

    It's downloading a lot, 15% done so far. I'll update this thread with the results.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •