Results 1 to 2 of 2

Thread: ld cannot find -ldsk -lzzipmmapped -lbz2 -lz, what packages do I need to install?

  1. #1

    Default ld cannot find -ldsk -lzzipmmapped -lbz2 -lz, what packages do I need to install?

    [ 35s] /usr/lib/gcc/i586-suse-linux/4.8/../../../../i586-suse-linux/bin/ld: cannot find -ldsk
    [ 35s] /usr/lib/gcc/i586-suse-linux/4.8/../../../../i586-suse-linux/bin/ld: cannot find -lzzipmmapped
    [ 35s] /usr/lib/gcc/i586-suse-linux/4.8/../../../../i586-suse-linux/bin/ld: cannot find -lbz2
    [ 35s] /usr/lib/gcc/i586-suse-linux/4.8/../../../../i586-suse-linux/bin/ld: cannot find -lz

    What packages am I missing?

    This is what I am trying to build:
    https://build.opensuse.org/package/s...lators/ubee512

  2. #2
    Join Date
    Sep 2012
    Posts
    4,044

    Default Re: ld cannot find -ldsk -lzzipmmapped -lbz2 -lz, what packages do I need to install?

    You try to link program statically, so you need static libraries. Randomly checking the first package (libdsk) - it explicitly disables static library in it's spec. So you either need to link your program dynamically or contact maintainers of each package asking to provide static development files.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •