Results 1 to 2 of 2

Thread: Cross-compile for Ubuntu ARM with OBS

  1. #1

    Default Cross-compile for Ubuntu ARM with OBS

    Hello,
    I have HelloWorld test package: https://build.opensuse.org/package/s...asBedrnik/Test
    This compiles well for x86 and various distributions - opensuse, debian, ubuntu...
    For ARM it only compiles for opensuse_Factory_ARM, other distrubitions are "unresolvable"
    Debian: "nothing provides debhelper >= 4.1.16, nothing provides cmake, nothing provides build-essential"
    Ubuntu: "nothing provides debhelper >= 4.1.16, nothing provides cmake, nothing provides autoconf, nothing provides automake, nothing provides binutils, nothing provides bzip2, nothing provides gcc, nothing provides gettext, nothing provides libc6, nothing provides libtool, nothing provides libncurses5, nothing provides perl, nothing provides zlib1g, nothing provides dpkg, nothing provides build-essential"

    What I'm doing wrong?

    If I get it right, there are no repositories for Debian/Ubuntu ARM - is this intention? How do I add it?

    There is some 9 years old wiki page describing settings your own OBS instance for cross-compiling, but I would like to test it on build.opensuse.org first, if it is possible.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    23,238
    Blog Entries
    15

    Default Re: Cross-compile for Ubuntu ARM with OBS

    Quote Originally Posted by TomasBedrnik View Post
    Hello,
    I have HelloWorld test package: https://build.opensuse.org/package/s...asBedrnik/Test
    This compiles well for x86 and various distributions - opensuse, debian, ubuntu...
    For ARM it only compiles for opensuse_Factory_ARM, other distrubitions are "unresolvable"
    Debian: "nothing provides debhelper >= 4.1.16, nothing provides cmake, nothing provides build-essential"
    Ubuntu: "nothing provides debhelper >= 4.1.16, nothing provides cmake, nothing provides autoconf, nothing provides automake, nothing provides binutils, nothing provides bzip2, nothing provides gcc, nothing provides gettext, nothing provides libc6, nothing provides libtool, nothing provides libncurses5, nothing provides perl, nothing provides zlib1g, nothing provides dpkg, nothing provides build-essential"

    What I'm doing wrong?

    If I get it right, there are no repositories for Debian/Ubuntu ARM - is this intention? How do I add it?

    There is some 9 years old wiki page describing settings your own OBS instance for cross-compiling, but I would like to test it on build.opensuse.org first, if it is possible.

    Thanks.
    Hi
    You need to ask the OBS admins if they will import the relevant distribution ARM release into OBS;

    https://en.opensuse.org/openSUSE:Mai...s_subscription
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    openSUSE Leap 42.2 (x86_64) GNOME 3.20.2
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •