Results 1 to 3 of 3

Thread: Powerdown monitor without X running

  1. #1

    Default Powerdown monitor without X running

    I'd like my box running tumbleweed in console mode to power down it's monitor output after a timeout, but I'm struggling to get it to work.

    I've tried
    Code:
    setterm --blank 10 --powersave powerdown --powerdown 10
    without success. The blanking happens (although that was happening already) but the now blank output is still sent to the monitor keeping it awake.

    Anything else I can try?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,846
    Blog Entries
    15

    Default Re: Powerdown monitor without X running

    Hi and welcome to the forum
    So your system is set to boot to runlevel 3 (systemctl set-default multi-user.target)?

    Have you checked the monitor settings (eg the menu) to see what the power settings (if any are set to), what if you set powersave to on rather than powerdown, does that work?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Powerdown monitor without X running

    Thanks for the welcome and your help!

    It turned out my problem was that I was booting the kernel with 'nomodeset'. As soon as I took that out it worked fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •