Results 1 to 5 of 5

Thread: Has there been a change in broadcom wl drivers in kernel 11.1?

  1. #1
    Join Date
    Dec 2015
    Location
    Atoka, Tennessee USA
    Posts
    49

    Default Has there been a change in broadcom wl drivers in kernel 11.1?

    Please help me understand how the wifi works. When I did a clean install of TW with kernel 11.1, I cannot get TW to recognize my broadcom 4360 wifi chip. However, when I do a clean install of Leap 42.2, I download the wl driver from packman, (prior to, I do a package switch), reboot, and the software identifies the broadcom 4360 wifi as I normal. However, I do the same as I always have in the new install of TW, download the wl driver, reboot and nothing. I tried the workaround, nothing., I tried a couple of different drivers, nothing. However, my KDE connect works fine, and my bluetooth works fine. Does this mean that my driver is working although the broadcom chip is not identified? I know my AMD GPU drivers are automatically installed, I just wonder if there is a change in the wifi settings in the new kernel that automatically locates and installs. Thanks, I learn alot from just reading posts.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,727

    Default AW: Has there been a change in broadcom wl drivers in kernel 11.1?

    Did you try to build the initrd new after installing broadcom-wl-kmp-default and broadcom-wl by:
    Code:
    mkinitrd

  3. #3
    Join Date
    Dec 2015
    Location
    Atoka, Tennessee USA
    Posts
    49

    Default Re: AW: Has there been a change in broadcom wl drivers in kernel 11.1?

    Quote Originally Posted by Sauerland View Post
    Did you try to build the initrd new after installing broadcom-wl-kmp-default and broadcom-wl by:
    Code:
    mkinitrd
    no I didn't. Never had to do that before. After I select the drivers, hit accept, then do I just open a terminal and do "mkinitrd"?

  4. #4
    Join Date
    Dec 2015
    Location
    Atoka, Tennessee USA
    Posts
    49

    Cool Re: AW: Has there been a change in broadcom wl drivers in kernel 11.1?

    Quote Originally Posted by louparker View Post
    no I didn't. Never had to do that before. After I select the drivers, hit accept, then do I just open a terminal and do "mkinitrd"?
    That worked! I never had to load it into the ram disk image before. Thanks so much!!! Learn something new everyday from you guys.

  5. #5
    Join Date
    May 2017
    Location
    Singapore
    Posts
    34

    Thumbs up Re: AW: Has there been a change in broadcom wl drivers in kernel 11.1?

    Quote Originally Posted by louparker View Post
    That worked! I never had to load it into the ram disk image before. Thanks so much!!! Learn something new everyday from you guys.
    It worked on my end too. Similar problem definition, same resolution. Required a reboot before the wifi shows up. Thanks.

    Lin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •